Sign in with
Sign up | Sign in
Your question

LAN Bandwith and File Transfers

Last response: in Networking
Share
July 16, 2010 1:01:32 AM

Hello,

I recently purchased two new manchines. Both OS's are Windows 7 64 Bit. I setup a file share on one of them. I noticed when I move files to and from the computer I usually get about 20-30MB a second and network Utilization is around 10-20%. How can I push the nic to or at least close to 100% utilization. The files being tranfered are from disk arrays capable of tranfers way hight than this. I have proved it by tranfering to USB 2.0, 3.0 and Esata. The Network controller or onboard both showing PCIE 1gig. I have a cisco 3750 gig switch and i'm connecting them at 1gig. I don't have QOS running and I setup jumbo frames on it. I tried setting the MTU on the interfaces to 9000. I tried using jperf to test transfers. I am getting about 30MB/sec. I guess I'm down to the OS, onboard nic or some configuration I'm missing.

Does anyong have any helpful hints to max out the transfers?


Thanks,

Steve
July 16, 2010 3:08:20 PM

try updating the drivers of your mobo or setting your nic card to 1000 instead of auto
July 16, 2010 4:31:11 PM

I tried turning to 1000 full on both machines, but still have the same issue. I also turn off all energy efficient settings and green settings. The newest drivers were installed from the web during my initial configuration less than a month ago. I will reinvestigate the drivers though.
Related resources
July 16, 2010 4:49:57 PM

thinking maybe your PC cant handle that high of mtu level... but you said you tried it normal at 1500 correct

also do yo gave fiber connecting to your switches?
July 16, 2010 6:38:21 PM

When I changed the MTU it was originally set at 1300 on both machines. I had never previously changed this so I'm not sure why its not at 1500. At either 1300 or 9000 the performance is the same. I try 1500 too just to say I did.
July 16, 2010 6:56:15 PM

when you say it was at 1300 on both machines do you mean the router was config to 1300 because or did you do a regedit on your win7 machines?
July 16, 2010 7:15:09 PM

Here is what is was set to:

C:\Users\sgaron>netsh interface ipv4 show subinterfaces

MTU MediaSenseState Bytes In Bytes Out Interface
------ --------------- --------- --------- -------------
4294967295 1 0 1046 Loopback Pseudo-Interface 1
1300 1 12591931404 271635974 Local Area Connection


I used this command to change the MTU:
netsh interface ipv4 set subinterface "Local Area Connection" mtu=9000 store=persistent
July 16, 2010 7:23:51 PM

and for the router whats the mtu on that?
July 16, 2010 8:36:24 PM

Where did you disable QOS? on the router or in both PC's? You will also have to disable QOS on both machines, here is one way:( http://pcsplace.com/tips-n-tricks/best-way-to-increase-...). But that only accounts for 20%...

You could turn off DHCP services, and set both PC's to static. This should eliminate some network chatter.

You could also try disabling "Nagle’s algorithm"/ TCP no delay :( http://lifeandcode.net/2009/05/reduce-game-network-late...). This basically says, do not wait for a packet to reach a certain size, send NOW what you have.

Also you might find this Link helpful http://forums.malwarebytes.org/index.php?showtopic=2662... . There are a few things there I just found out and thought they were interesting.

In PC's (home/business's) I have never seen a PC transfers above 50%, servers are different... And to increase your speeds, you are going to have to dig deep into the TCP/IP stack, and get rid of any kind of excess fat...

Most of the links are for "gaming", but they should help with file transfers as well... Just some thoughts, it might help.
!