Sign in with
Sign up | Sign in
Your question
Closed

Experiencing "Display Driver stopped responding and has recovered"

Last response: in Graphics & Displays
Share
January 5, 2011 3:59:44 PM

Yesterday I recieved my new Sapphire AMD HD6970, and since installing it I am experiencing the "Display driver stopped responding and has recovered" error. It happens while idling at the desktop, surfing the internet, or while playing a game.

Before I installed the new card, I first uninstalled the previous ATI drivers, rebooted in safe mode, ran Driver Sweeper and CC Cleaner, shutdown, installed the 6970, booted up and installed the latest drivers from the AMD website (10.12).

I was experiencing the same error before with my ATI Radeon HD4650, and I was hoping the new card would fix it, but alas it has not. I have tried most of the "fixes" I have read about on the internet, and none of them has fixed the problem.

My specs are:

Core i7 860
ASUS P7P55D-E
Sapphire AMD HD6970
G.skill Ripjaws 8GB
1 TB Seagate Barracuda 7200 rpm

Can anyone help me? I am sure you all know how frustrating it is to get a new component (especially the GPU), and not have it work properly.

Thanks!
a b U Graphics card
January 5, 2011 7:09:42 PM

What fixes did you try? Did you try to up your idle clock speed?

To do that here are some quick instructions:

Go to CCC, then turn on ATI Overdrive (unlock it first). Then go to the Profile manager (in the old CCC it was on the top right) and create a new profile and save it. Don't apply it just yet. Now you'll need to edit that profile file, the location is somewhere in your C:\Users\AppData\Local\ATI\ACE\Profiles\ . Then you will find the profile you created, open in notepad, and change the lowest 6 digit number there up (it is for the clock speed). Depending on your card, but change it to maybe 300000. Then save the doc and then load that profile through CCC.

Score
0
January 6, 2011 3:50:09 AM

I tried uninstalling and installing various versions of drivers. I tried editing the Atikmdag file that some had suggested. I disabled Aero, UAC, and other stuff I can't even remember.

I created a profile as you said, but I am not able to locate the folder where the profile is located, so I can't edit the profile.

I was really hoping the 10.12a hotfix CCC package would solve the problem since it says it added support for 6900 series cards, but alas it did not.

I just don't know what to do next.
Score
0
Related resources
a c 216 U Graphics card
January 6, 2011 5:17:06 AM

What your PSU like? Could your PSU gone bad?
Score
0
January 6, 2011 12:12:08 PM

I have a Corsair 650TX, which is roughly 4 months old. So I wouldn't imagine that would be the source of the problem.
Score
0
a b U Graphics card
January 6, 2011 12:37:29 PM

When you say you couldn't find the profile file, what do you mean? Did you find the folders? I think that is your best bet to try right now.
Score
0
January 6, 2011 2:42:31 PM

Yeah I couldn't find the folder that the profile was located in. But I am not sure exactly what to change. I increased the memory clock, but I wasn't sure if I should increase the core clock speed too. The core clock speeds were like 25000 or something like that. In addition there are three values to change for each clock, want 0, want 1 and want 2. So I am not sure exactly which ones I should change, or how much I should change them.
Score
0
a b U Graphics card
January 6, 2011 2:48:58 PM

Okay good so you found the profile file. You'll want to change want_0 for the core clock.

Can you copy and paste what is there in the file? We can edit it and then you can paste what we edited.
Score
0
a c 173 U Graphics card
January 6, 2011 2:55:54 PM

This is also the same symptom of thermal and power issues and if it is driver related I see no point to getting another modern ati card any time soon. Check your volts on that psu and check for any odd noises coming from the unit while under heavy load.
Score
0
January 7, 2011 3:23:02 AM

Here is the profile, if you could let me know what to change that would be awesome.

<Profile>
<Caste name="Graphics">
<Groups>
<Group name="Overdrive5">
<Feature name="TimeUnlocked" />
<Feature name="OverclockEnabled">
<Property name="OverclockEnabledProperty" value="True" />
</Feature>
<Feature name="AutoTuneSupport" />
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="25000" />
<Property name="Want_1" value="50000" />
<Property name="Want_2" value="88000" />
</Feature>
<Feature name="PowerControl_0">
<Property name="Want" value="0" />
</Feature>
<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="30000" />
<Property name="Want_1" value="137500" />
<Property name="Want_2" value="137500" />
</Feature>
<Feature name="CoreVoltageTarget_0">
<Property name="Want_0" value="900" />
<Property name="Want_1" value="1000" />
<Property name="Want_2" value="1175" />
</Feature>
<Feature name="MemoryVoltageTarget_0">
<Property name="Want_0" value="0" />
<Property name="Want_1" value="0" />
<Property name="Want_2" value="0" />
</Feature>
<Feature name="FanSpeedProtocol_0">
<Property name="FanSpeedProtocolProperty" value="Percent" />
</Feature>
<Feature name="FanSpeedAlgorithm_0">
<Property name="FanSpeedAlgorithm" value="Automatic" />
</Feature>
<Feature name="FanSpeedRPMTarget_0">
<Property name="Want" value="1146" />
</Feature>
<Feature name="FanSpeedPercentTarget_0">
<Property name="Want" value="50" />
</Feature>
</Group>
</Groups>
<Adapter name="PCI_VEN_1002&DEV_6718&SUBSYS_0B001002&REV_00_4&113C73B2&0&0018A">
<Aspect name="Overdrive5" />
</Adapter>
</Caste>
</Profile>
Score
0
January 7, 2011 3:24:55 AM

I just check all my RAM and that doesn't seem to be the problem.

My PSU is not making any odd noises, how to I check to see if it is having any problems?
Score
0
a b U Graphics card
January 7, 2011 1:26:59 PM

Under this section:

Quote:

<Feature name="AutoTuneSupport" />
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="25000" />
<Property name="Want_1" value="50000" />
<Property name="Want_2" value="88000" />
</Feature>


try changing it to this and then activate the profile through CCC

Quote:

<Feature name="AutoTuneSupport" />
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="30000" />
<Property name="Want_1" value="50000" />
<Property name="Want_2" value="88000" />
</Feature>


if that doesn't work, try this and then activate the profile through CCC

Quote:

<Feature name="AutoTuneSupport" />
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="50000" />
<Property name="Want_1" value="50000" />
<Property name="Want_2" value="88000" />
</Feature>
Score
0
January 8, 2011 3:06:00 AM

I tried both clock speeds and it didn't change/improve anything :( 

I just have no idea what to do next.
Score
0
January 8, 2011 8:04:32 PM

I just tried installing the 10.12a hotfix drivers that I stumbled across on the AMD site.

It didn't fix the problem, but it seemed like it may have taken a little longer for the "display driver stopped responding and has recovered" error to occur.
Score
0
a b U Graphics card
January 8, 2011 9:42:12 PM

Have you tried going back to 10.11?
Score
0
a b U Graphics card
January 8, 2011 9:58:16 PM

The 10.12's gave me the exact same issue, reverted back to 10.11's and everything is butter..

Score
0
a c 216 U Graphics card
January 8, 2011 10:01:15 PM

Unfortunately, I do not know if the 6970's can use the 10.11 drivers.
Score
0
January 9, 2011 12:08:07 PM

I tried installing 10.11 and it wouldn't recognize my 6970. So no luck there.

I re-installed 10.12a and I noticed in the dxdiag that it lists the card generically as a 6900 series card, and that it has 1077 MB of memory. When in fact it actually has 2GB of memory. Does that indicate anything?

Should I try updating my BIOS? (Although I don't know how to do that)
Score
0
January 10, 2011 2:44:10 PM

Is it worth reformatting my hard drive? I am getting desperate lol, I have this brand new graphics card that I haven't been able to use it yet :( 
Score
0
a c 173 U Graphics card
January 10, 2011 3:07:40 PM

I don't think so unless your instillation of windows is partially corrupted which is something that I have to do due to a perm issue that prevents me from installing programs but for you it is driver related. I suggest that you bitch (hate to use that word) and moan to customer support to accept your return or send you another card i hope that you will not have the same issue. If the same issue for the card you may have to wait for a new driver release in hope that the problems will go away (I have had to do this ended up waiting 3 months once) that will be stable. I stopped buying ati cards due to this issue. Their early drivers for each introduction of a new series always sucks major ass (not forgetting the whole frank and beans).

They can make great cards but their drivers are of tears of blood from thy eyes.
Score
0
January 10, 2011 7:00:34 PM

Thanks for the advice. I am working for a replacement card right now, so we'll see.

Do you think I should try to update my BIOS? I have never done it, but maybe it is worth a shot?
Score
0
January 11, 2011 2:12:33 PM

I updated my BIOS and it didn't make a difference.

I have been trying to talk with Sapphire but their support is absolutely terrible. It took four days for them to respond, and all they asked me was if I installed the latest drivers, which I said I did in my original message. I wish I could just call them instead of using e-mail, but I can't find any phone number.

I bought the card from NewEgg, can I just ask for an RMA? And they will just send me a replacement? I wish I could just return this 6970, get all my money back and get a 570.

Anyone have any advice or wisdom?
Score
0
a b U Graphics card
January 11, 2011 2:29:18 PM

NewEgg will take care of it all for you. You can probably return it through them too.
Score
0
January 11, 2011 2:30:59 PM

If I return it, is there a restocking fee? I am guessing there probably is.
Score
0
a c 173 U Graphics card
January 11, 2011 3:28:02 PM

I think so but I would say that what you have is defective and that you just want to get your money back or exchange it for a different model card.
Score
0
a c 216 U Graphics card
January 11, 2011 5:25:05 PM

My guess, based on past problems of this sort, is you got a card with a bad VRM or the thermal tape applied to the VRM allowing it to overheat.

I'd return or exchange it if you can.
Score
0
January 14, 2011 11:55:17 AM

I'm having this same issue. First it occurred with HD 5770 1GB from MSI. I thought that the card was broken, so I bought and replaced it with a brand new Sapphire HD6870 1GB, reinstalled Windows 7 (64-bit), installed newest 10.12a CCC, updated BIOS etc. but I'm still having the same issue over and over again. I haven't changed voltages or overclocked either of them.

Mobo: Asus M4A89GTD
CPU: AMD X6 1055t
Mem: Kingston ValueRAM 2GB x 4
PSU: Corsair 750HX
GFX: Sapphire Radeon HD 6870 1GB

I also ran MemTest but it didn't give any signs of faulty memory. I don't even know if it is a driver issue, as the 5770 worked properly for until January. I tried downgrading drivers back to 10.10 when I had 5770 installed, but it was no use.
Score
0
a b U Graphics card
January 14, 2011 12:31:50 PM

I'd try the card on another machine then, two bad cards seems less likely, but it is possible. It could be you have some power issue.
Score
0
January 14, 2011 8:10:51 PM

The problem originally started with my old card, an Radeon HD4650. I never had any problems with it until a month ago, when this problem started happening. So I decided to replace that card with a HD6970, and the problem still persisted.

How do I tell if I am having power issues?
Score
0
a b U Graphics card
January 15, 2011 9:28:36 PM

If you have a PSU tester then you can test the power supply. Or if you have a multimeter.

If you have neither, then your best bet would be to try the card in another machine that has a good power supply, if it is working then you know the issue isn't the card.

You can check with a local computer store to see if they can test your PSU. If they charge you only $10 or less then it is worth it.
Score
0
a b U Graphics card
January 15, 2011 9:30:17 PM

You might be able to get a general idea of power output through your system BIOS. Consult the Asus manual to see if your motherboard supplies that information. Take it with a grain of salt though, it will probably be 90% accurate, but enough to get you an idea.

You can post your results to continue to troubleshoot.
Score
0
November 8, 2011 12:46:11 PM

Hi,

I experienced the same problem on my pc. I was browsing on some websites and at the same time browsing some videos from youtube through RealPlayer. My screen suddenly went black and back and then it said that the display driver had stopped responding and has recovered. The pc restarted and I was asked to choose between running in safe mode or running windows normally. I chose to run normally but when it displayed the desktop it stopped responding. I restarted the pc and ran in safe mode. I restarted the pc, this time I was asked if I would like to run Startup Repair or run normally. I chose to repair. When the repair was done, the pc restarted but it wouldn't get past through the screen that displays the animated windows logo.
I reboot the pc again and was able to restore to a previous system setting but that still didn't work.

Here's what I have:
core i3 2100
intel DH61WW mother board
2GB ram
using on board graphics and audio (no video cards)
generic power supply that comes with the casing
Score
0
!