New motherboard wont power on

Hi I have a new gigabyte mono and a new amd fx 8120 processor and a 2 year old 500 Watt psu ram and CPU and CPU fan installed correctly the front panel connectors installed correctly I plug up the 8 pin 12volt and 24pin connector to.the motherboard I hit the power button nothing happens no noise no nothing is my mono DOA? Thanks
6 answers Last reply
More about motherboard wont power
  1. Hi and welcome to Tom's forum.

    Can you give us the model of your new mobo and current PSU?
  2. 740a-ud3 gigabyte diablotek 500 Watt psu
  3. I will assume that your refer to 970A-UD3 because I can't find that model.

    Regarding the PSU: If this is your current PSU: http://www.newegg.com/Product/Product.aspx?Item=N82E16817822008

    I'm not sure if that PSU can handle the new system because your need 2x4 PIN power connector..your PSU only have one, test the rig with a better PSU.
  4. Oops ya 970a-ud3 gigabyte so that psu can't even power on just the CPU? I'm taking it back to mictocenter and I already knew I needed a better psu cause I have gtx 550ti to power thanks for your help ill let you know what happens
  5. psycrow395 said:
    Oops ya 970a-ud3 gigabyte so that psu can't even power on just the CPU? I'm taking it back to mictocenter and I already knew I needed a better psu cause I have gtx 550ti to power thanks for your help ill let you know what happens


    Correct, you need a PSU with 1x24 PIN power and 2x4 PIN power or 1x8 pin power, the current PSU have the 24 pin power but none of the others two.
  6. OK well my old psu had all those you mentioned Guy at computer place said he didn't think it was the board said it was psu but I exchanged the board anyways and bought a 600watt thetmaltake
Ask a new question

Read More

Motherboards Power Product