Sign in with
Sign up | Sign in
Your question
Closed

Recurring ATAPI Error 9 and SATA boot issues.

Last response: in Motherboards
Share
February 14, 2012 3:00:26 AM

Hi
My PC Config: Intel Core2Duo 1.86ghz
2GB DDR2 RAM, Windows XP Prof SP3
Samsung 80GB IDE HDD, Seagate 320GB IDE HDD
IDE DVD Drive


I've tried just about everything and googled every possible solution, and nothing worked. So here I am.

My Event Manager repeatedly keeps reporting the following:
1. This is the one that starts all the trouble Source ATAPI event 9 "The device, \Device\Ide\IdePort2, did not respond within the timeout period."
2. At every system boot: Event ID 7000 Service Control Manager "The NPVR Recording service failed to start due to the following error: The service cannot find the specified file"
3. For the first time i got the error from source DISK Event ID 51 "An error was detected on device Device\HardDisk1\D during a paging operation."

Things I have tried:
1. Everytime my Primary IDE channel switched to PIO mode, i uninstall that channel and that takes switches it back to UltraDMA 5. This is good only till the next heap of ATAPI errors.
2. Disconnecting my IDE DVD Drive from the PSU as well as the IDE Cable (will give more details about this below)
3. Disconnecting my IDE samsung HDD from PSU n the IDE cable.
4. The last thing i tried this morning was modifying the registry as given on the following link http://support.microsoft.com/kb/817472

Thus far none of it has worked for me. The registry edit has not yet been fully tested yet, but am sure its not going to work since i could also see the symptoms n the same pattern of my PC freezing for a minute or so etc.

Anyways I lack knowledge about IDE Master and Slave thing. I referred to my mother board manual but the settings shown in there do not seem to be working. For example; it says "connect black to Master and Grey to Slave" This obviously leaves me with blue to connect to the motherboard. When I connect the blue to the MB and black to the IDE HDD, my PC boots and immediately shuts down without even allowing me to access BIOS. I've tried it with another IDE cable too which came with my motherboard. Same result. Same thing happens with blue to MB, black to IDE HDD and grey to DVD. The only times it boots correctly is when I connect the black to the MB.

I also have tried booting with NO IDE Devices and Only my SATA HDD plugged. My OS doesnt boot (although my OS is on the SATA). "Reboot and select proper boot device or insert boot media in selected"
Been through this thread:
http://www.tomshardware.com/forum/255401-30-reboot-sele...

What i need help with:
1. The Atapi errors show up with even my DVD not plugged in
2. My PC recognizes ONLY the DVD as the Primary in spite of shuffling between the grey /black connector. With the DVD unplugged, it says no Primary IDE detected. So i think i need help figuring out where the problem is with this whole Master slave or primary secondary thing.
3. How do I boot with ONLY My SATA HDD plugged??? I hit F8 on boot and theres only 1 boot device listed which is my SATA. Boot sequence also is set as SATA 1st and nothing else since theres nothing connected.

Anyways, my primary concern is the ATAPI errors which switch my PC to the PIO mode everyday. And at a scarily increasing frequency now.
February 16, 2012 12:05:35 PM

no help on this ?
Score
0
February 26, 2012 2:25:23 AM

issue solved... pls stop sending me automated messages for this :) 
thanks
Score
0
Related resources

Best solution

March 31, 2012 3:24:26 PM

four321zero said:
issue solved... pls stop sending me automated messages for this :) 
thanks

Would be interesting to know how it was solved...
Share
April 7, 2012 9:43:24 AM

Volanne said:
Would be interesting to know how it was solved...


Hi volanne

I am almost certain the ATAPI errors were not caused by my DVD Writer. Instead it was my IDE Hard Disk. I tried changing the IDE cable, I even made it a primary IDE. Yet kept getting those errors. I wasnt aware of Jumper settings to shift between Primary and Secondary, which I learnt later. In case you aren't aware, there is a small 3 or 5 pin slot on any IDE device. It comes with a cap that fits those pins. The cap u use determines whether the device is primary or secondary.
Anyways the mater-slave setting wasnt the cause of my troubles. It was most likely a bad hard disk (almost 7 year old samsung)

However, when i wrote this post, i was unable to boot with my IDE hard disk unplugged and using ONLY my SATA HDD. This was a fairly simple thing. The reason it wasnt booting with my SATA OR refusing to install a fresh OS in my SATA (without my IDE) was because all the partitions on my SATA drive were Logical. So i booted with my IDE, went to disk management and re-formatted all the partitions in my SATA as Primary.
Then unplugged the IDE, installed a fresh OS and the ATAPI errors are gone.



Score
0
April 7, 2012 9:44:07 AM

Best answer selected by four321zero.
Score
0
a c 328 V Motherboard
April 7, 2012 9:57:06 AM

This topic has been closed by Nikorr
Score
0
!