Sign in with
Sign up | Sign in
Your question

Chip on motherboard blew up

Tags:
  • Motherboards
Last response: in Motherboards
Share
February 15, 2012 2:34:47 PM

So last night I finished putting together a new pc just to find when all the parts were connected it wouldnt switch on. I have an Asus mobo P8Z68-v/Gen3 powered by an OCZ ZS 750W PSU. So I double checked the connections and everything and I decided to leave the power connected for a while to see if there was any difference. A couple of minutes later there was an intense burning smell and smoke coming from the motherboard so I switched everything off. After reconnecting the board to the psu I tried to swith the system on and boom! there was a loud noise spark and smoke from the mobo and I discovered that a chip blew up! Any ideas were the problem is ? is it the psu or just a faulty mobo
Any ideas ? Thanks



PS: There is a power switch on the mobo which blinked red before the burning smell and stayed lit red after the incident.

More about : chip motherboard blew

a c 121 V Motherboard
February 15, 2012 2:56:35 PM

More than likely there was either a short on the Motherboard itself or something shorting the MB to the Case.
Related resources
February 15, 2012 3:49:52 PM

Is it possible its not covered by the waranty ?
a c 121 V Motherboard
February 15, 2012 4:06:33 PM

You would have to call the manufacturer's customer support phone number to double check.
a b V Motherboard
February 15, 2012 4:46:35 PM

did you use the motherboard standoffs?
sounds like a short circuit to me
February 15, 2012 5:02:16 PM

Its hard to say what caused the problem so you will have to use the process of elimination. I would start with the PSU. You will need a volt meter to check the voltages for the mobo cable to ensure that they are in line with the PSU specs. If not then you need to contact the PSU manufacturer to see what recourse you may have. If the voltages are good then it could either have been an internal mobo short or something caused by the case. Hopefully it was an internal mobo short so that you can RMA the board. I know you are really frustrated so hang in there.
a b V Motherboard
February 15, 2012 5:42:21 PM

I'd remove the MoBo and check for burn marks on the backside. Sounds like it shorted to something, a loose screw or the case. You say the computer wouldn't turn on intitally. Didn't that give you a clue? It's pretty hard to screw up PSU to MB connectors as every plug is keyed to a particular mate on the MB. Maybe you can RMA it to either the vendor or Asus.
a b V Motherboard
February 15, 2012 5:44:58 PM

That's one of the MOSFETs that supplies power to your memory slots. Either you had a short, a memory module insert backwards (part way, since they won't fully seat backwards) or a bad / shorted stick of RAM.
February 15, 2012 6:10:52 PM

i tried to turn it on without the RAM memory, and itdidn't beep either, which menas is not the ram, and i confirm it was inserted propely.
February 16, 2012 8:12:46 AM

Thanks guys for ur support, ive issued an RMA with scan.co.uk from were I bought it hopefully they will send a new one. meanwhile can anyone sugest a cheap replacement ?
!