Sign-in / Sign-up
Your question

Windows Boot Error on SSD

Tags:
  • Boot
  • Windows 7
Last response: in Windows 7
November 29, 2011 3:32:14 AM

Hi guys, this problem is kinda multi-layered, and I tend to be quite verbose.... So bear with me.

Initial Symptom:
Booted up the Computer this morning. As I recalled there was no major changes made to the system yesterday except for perhaps a Windows update. When the system attempts to load the desktop, it just shows me a Black Screen and freezes there. No mouse pointer whatsoever.

Upon the reboot, it tells me that I should run Startup recovery and insert my Windows disk. I only have the option to hit enter and not "Load last good config etc.". Anyway I insert my CD-rom but it did not seem to automatically boot into it.

So I proceeded to change the boot order - First boot from Hard Disk to CD-Rom drive and vice-versa (I am using Gigabyte motherboard that adds a delay of another 5 secs if CD rom drive is the first boot).

With this I managed to boot into the Windows Recovery Environment, but now it tells me that I have an "Unknown Windows Installation on (Unknown) Hard Disk.

I THINK in doing so I might have fudged the Bootrecord. So this is kinda problem #2. Anyway I go back to BIOS, revert the Boot order, then manually get it to boot into the CD-rom by hitting F12 (and cursing under my breath that I should've just done this from the start).

I disconnect my other 2 secondary hard drives to MAKE SURE that windows has no confusion whatsoever where the installation might be located. BUT ALAS, it still says that my Windows Installation is 'missing'. I tried using the bootrec.exe step, FixMBR, fixboot, rebuildbcd... But it gave me a bunch of errors... To a point where I rebooted into the recovery environment and it wasn't even showing me a HDD anymore.

However, despite this, if I leave the computer to be, it manages to get past the "Loading Windows" screen and then immediately Blue Screens with a stop error. So somehow, even though the Recovery environment isn't detecting Windows, it hasn't disappeared it's just umapped??

Somewhere down the line I managed to boot into safe mode. It briefly told me that my paging file size was going to be temporarily changed... Then it freezes and after a while my desktop disappears and black screens again.

I let it reboot again. After the 'Loading Operating System' option it started showing me some text about the RAID controller Realtek PCIe things and the computer's MAC address????? I reboot again.

This is currently where I'm at. I get past the 'Loading Windows' screen and it's now running chkdsk. Now it's just telling that File Record Segment ###### is unreadable and its been going for about 30mins straight now.

Was this whole problem just my SSD failing? Or did I create a bigger problem? :S

More about : windows boot error ssd

a b $ Windows 7
November 29, 2011 3:46:34 AM

When you initially loaded windows onto your SSD did you enable AHCI ? If you did then chack and see if it is still enabled , maybe the setting has changed and you need to reset it to AHCI.
m
0
l
November 29, 2011 3:55:14 AM

I will check that again once chkdsk is done, but I'm pretty sure I didn't mess with the IDE/AHCI settings. The installation of the OS was done in AHCI mode.
m
0
l
Related resources
November 29, 2011 4:50:04 AM

Update: Chkdsk turned out pretty anti-climatic. After telling me that my entire drive has that error, it pretty much hung when moving on to the other steps. I wonder if I caused the entire drive to fail because I messed with the boot record?

I also checked the BIOS. It is still in AHCI mode. Attempting to boot to Windows and skipping chkdsk just instantly gives me a BSOD stop error.

Meanwhile I'm just going to plug the SSD into another computer and attempt to salvage the data from it.
m
0
l
November 29, 2011 5:12:23 AM

Update2: Ok I can access the data from the SSD on my other computer. Currently backing up all the information if a reformat becomes the only solution. Surely this must mean the SSD itself is operational? Is there any suggestions to what diagnostics I can run on it, or how I can have it boot functionally / recognized on the other PC?

EDIT: Wanted to clarify that I did not boot from the SSD, merely used it as a data disk

Update3: Ok it hung when I tried to open the Appdata folder. Seems to be some kinda of corruption in some sectors. Not too sure if a fresh install will fix it if it's a hardware issue :( 
m
0
l
a b $ Windows 7
November 29, 2011 1:36:32 PM

Might be the SSD is going bad? Kinda sounds that way based on the descrption of things here...
m
0
l