Sign in with
Sign up | Sign in
Your question

4890 Clock Dropping

Last response: in Graphics & Displays
Share
January 11, 2011 6:07:05 PM

Hi,

Long time reader, first time asking a question...

My 4890 rests at 230(235?)MHz. When I start up 3D (a game), it jumps to 850 MHz. This is all normal.

If I play a flash video, it jumps up to 500MHz (I guess this is the 2D clock?). This is normal too, as hardware acceleration is enabled.

If I'm playing a game (850) and then start up a flash video, the clock instantly drops to 500, and stays at 500 for as long as flash is open in the background. If I disable hardware acceleration, then it stays at 850.

The issue here is that I can't play a game and keep hardware acceleration enabled for video due to the fact that my card will drop to 500. The game begins to drop in FPS. I used to be able to OC my card to 851 and that would cause it not to drop, but with newer drivers, this solution no longer seems effective (it drops to 500 and ignores the OC). I've messed around with overdrive in catalyst and afterburner with no success.

My question is: is there a way to stop the card from dropping to 500MHz, and remain at 850MHz?

More about : 4890 clock dropping

January 11, 2011 6:33:08 PM

Are you using the most current Flash Player updates for your browser(s)?
m
0
l
January 11, 2011 6:34:31 PM

COLGeek said:
Are you using the most current Flash Player updates for your browser(s)?


Yes, and this occurs in both Chrome and Firefox. I'm using Chrome Nightly and Minefield Nightly.
m
0
l
Related resources
January 11, 2011 6:40:12 PM

What OS and what version of Catalyst are you using?
m
0
l
January 11, 2011 6:51:24 PM

Windows 7 Professional 64

Catalyst 10.12 (Was happening with non-preview as well)
m
0
l
January 11, 2011 7:04:52 PM

Scratching my head here....How does your Flash playback perform if hardware acceleration is disabled?
m
0
l
January 11, 2011 8:48:03 PM

COLGeek said:
Scratching my head here....How does your Flash playback perform if hardware acceleration is disabled?


I just disable hardware acceleration through the flash context menu. Flash works fine by running off the CPU.
m
0
l
January 11, 2011 9:28:23 PM

I suggest you run that way so your GPU won't get gimped when gaming. Still, a pain, I know.
m
0
l
January 11, 2011 9:59:25 PM

COLGeek said:
I suggest you run that way so your GPU won't get gimped when gaming. Still, a pain, I know.


I just figure there should be a way to stop it from dropping to 500MHz. It's a silly restriction preventing me from using my GPU for one of the things its intended for. :|

This is especially true if there is a performance gain that I could be having if I was using hardware acceleration.
m
0
l
January 12, 2011 12:04:38 AM

Crevox said:
I just figure there should be a way to stop it from dropping to 500MHz. It's a silly restriction preventing me from using my GPU for one of the things its intended for. :|

This is especially true if there is a performance gain that I could be having if I was using hardware acceleration.

I actually agree with you. Dug into this for awhile with both Catalyst and Flash Player and I just don't see the connection (that is obviously somewhere in the mix). Sorry I couldn't help with a more satisfying solution.
m
0
l
January 18, 2011 10:59:25 PM

Got a 6870 (not because of this) and it's doing the same thing.
m
0
l
January 18, 2011 11:53:58 PM

Crevox said:
Got a 6870 (not because of this) and it's doing the same thing.

That would have to be something that Flash does in its config. This requires more investigation.
m
0
l
January 19, 2011 12:41:51 AM

Digging through the Adobe Flash Player forums, others have reported the same issue. All had ATI GPUs. Nothing from Adobe was provided.

Dug through my registry and nothing jumped out. Also, digging around the amd.com (a.k.a. ati.com) forums was fruitless as well.

I am completely stumped on this one.
m
0
l
January 19, 2011 12:56:05 AM

I'm surprised such a popular issue hasn't been fixed. :| It doesn't downclock while running like, VLC player with hardware acceleration.
m
0
l
January 19, 2011 10:18:24 AM

Crevox said:
I'm surprised such a popular issue hasn't been fixed. :| It doesn't downclock while running like, VLC player with hardware acceleration.

Agreed and understood. This is odd and seems to be well documented (from the issue side), but I have seen zip on a solution or work-around. Seems to take a combo of Win 7, ATI, and Flash, and then only under certain circumstances. I have a HD4850, a HD5850, and a HD6870 and none of them do this. However, the OP is not alone in this issue. While I enjoy solving a mystery, this one has gotten the best of me for now.
m
0
l
January 21, 2011 11:06:57 PM

Email says to add details...

uhhhhh

It's still happening ;\
m
0
l
January 23, 2011 12:58:28 AM

It actually does downclock with GPU acceleration in VLC. So it's not a flash specific issue.
m
0
l
!