Sign in with
Sign up | Sign in
Your question

Crossfire not running 16x 16x like it should

Last response: in Graphics & Displays
Share
January 13, 2011 12:19:01 AM

Im running crossfire 5770s on a crosshair iv formula and for some reason the cards are running 16x and 8x. Ive checked that they are in the correct slots but im wondering if there is something in the bios maybe that im missing ? Its been running for almost 4 months without problems but i noticed in GPU-Z that the first card [GPU0] is running at 8x. If someone could tell me how to enable 16x i would be forever greatful :??: 
a c 537 U Graphics card
January 13, 2011 2:40:45 AM

Specifications
•ChipsetAMD 890FX

•CPU supportSocket AM3 Phenom II, Athlon II, Sempron 100

•Memory support 4 slots: max 16GB DDR3 (2,000MHz)

•Expansion slots Three 16x PCI-E 2.0 slots (two 16x or one 16x and two 8x), one 16x PCI-E 1.1 (4x), two PCI, one 1x PCI-E

"The slots are clearly labelled so that you know that if you only want to use two graphics cards, you know that it’s the top two that will give you full bandwidth per card"
Make sure you are using the correct PCIe lanes (the top two), then I would go to your BIOS to make sure you are configured correctly. Make sure you have the latest BIOS version. If you can't figure it out, rest assured that you are not missing out on any performance as a result of the x16/x8 configuration.
a b U Graphics card
January 13, 2011 2:43:52 AM

yeah basically you are not losing out on any performance running a 5770 on an 8x, its bandwidth is not that high, in fact I recall a test where a 5870 is only reduced by 3-5% performance on an 8x vs a 16x
Related resources
a c 503 U Graphics card
January 13, 2011 4:01:12 AM

The manual for the Crosshair IV Formula states that you should be using the PCIe 2.0 x16_1 and PCIe 2.0 x16_3 slots for PCI Express x16 graphics cards to get better performance.

If you have the cards in the PCIe 2.0 x16_1 and PCIe 2.0 x16_2 slots that may explain why the card in the PCIe 2.0 x16_2 slot is running at x8.
January 13, 2011 4:05:16 AM

I have the cards in 1 and 3 just like the manual says [and the solder points on the back of the board ;) ] but it seems like its a bios IRQ thing so im going to go dig for a setting to fix it. I know it wont really do anything but id like it to run full bandwidth.
Im used to the gigabyte bios which is much more simple to navagate, this asus bios has so many sub menus its hard to find stuff.
a c 503 U Graphics card
January 13, 2011 7:44:01 PM

If your PCIE Frequency is currently set to 100 MHz change it to 101 MHz. Leave the cards in slots 1 and 3.

Crosshair IV Formula BIOS Setup --> Extreme Tweaker --> AI Overclock Tuner [Manual] --> PCIE Frequency [101]
a b U Graphics card
January 13, 2011 7:55:25 PM

ko888 said:
If your PCIE Frequency is currently set to 100 MHz change it to 101 MHz. Leave the cards in slots 1 and 3.

Crosshair IV Formula BIOS Setup --> Extreme Tweaker --> AI Overclock Tuner [Manual] --> PCIE Frequency [101]


Curious as why to change it to 101Mhz. I was under the impression changing the PCI-E frequency is a bad thing.
January 13, 2011 8:54:19 PM

Ill try changing it to 101. And about changing pci-e being a bad thing it really isnt but normaly there is nothing to gain by doing it and it can cause data curruption if set to high but 101 shouldn't even matter that much, all that should do is lock it from changing during use if i understand correctly.
!