Sign in with
Sign up | Sign in
Your question

Battlefield Bad Company 2, Low FPS w/ GTX 275

Last response: in Graphics & Displays
Share
January 15, 2011 3:03:27 AM

Hey all,

I just purchased Battlefield Bad Company 2 off steam. I initially had the video settings on "Advanced" on 1920x1080 (I have a single GTX 275) however after playing it for about 5 min. I noticed substantial lag. So I turned back the settings to "High" w/ V Sync off, HBAO off, same resolution (1920x1080) and turned AA down to 1x. I'm only getting about 15 fps according to FRAPs even when I have the graphics turned to medium it is still only about 18 fps. I have to have the settings on low to get about 35-40 fps for the game to run smoothly. Even if I turn down the resolution to 1600x1024, I notice little improvement in frame rate as I still get about 18fps on High and about 24fps on medium. Is this normal for a GTX 275 to get this FPS on this game and if not is there any way to improve the frame rate? I was fairly sure that I could at least have the game on high w/o any problems with this card. I have also noticed very minor artifacts like diagonal blurry lines on faces and walls and some wall textures moving. I have the latest Nvidia drivers (260.99). Also I listed my system specs below. Any help is greatly appreciated!

Specs:
i7 920 @ stock 2.66 ghz
6gb OCZ ram
850 watt Corsair PSU
Windows 7 64 bit
1tb HDD
EVGA GTX 275
Asus P6T deluxe V2 mobo
January 18, 2011 12:56:00 PM

That is wierd. you should be running that on max, 1920 x 1080 easy with your rig. i run it on max with a 9800gtx+ black edition, E8400 @ 4.0Ghz, 4 gig corsair DDR2 ram. i am guessing that there is a problem with your new card.

18 fps on high with 1680x1024 is not right. i would contact your supplier.

Also, before you do that, run prime95 on your cpu and memtest on your memory to rule those out. then you'll know its the card.
m
0
l
January 18, 2011 8:38:26 PM

zerobdr said:
Hey all,

I just purchased Battlefield Bad Company 2 off steam. I initially had the video settings on "Advanced" on 1920x1080 (I have a single GTX 275) however after playing it for about 5 min. I noticed substantial lag. So I turned back the settings to "High" w/ V Sync off, HBAO off, same resolution (1920x1080) and turned AA down to 1x. I'm only getting about 15 fps according to FRAPs even when I have the graphics turned to medium it is still only about 18 fps. I have to have the settings on low to get about 35-40 fps for the game to run smoothly. Even if I turn down the resolution to 1600x1024, I notice little improvement in frame rate as I still get about 18fps on High and about 24fps on medium. Is this normal for a GTX 275 to get this FPS on this game and if not is there any way to improve the frame rate? I was fairly sure that I could at least have the game on high w/o any problems with this card. I have also noticed very minor artifacts like diagonal blurry lines on faces and walls and some wall textures moving. I have the latest Nvidia drivers (260.99). Also I listed my system specs below. Any help is greatly appreciated!

Specs:
i7 920 @ stock 2.66 ghz
6gb OCZ ram
850 watt Corsair PSU
Windows 7 64 bit
1tb HDD
EVGA GTX 275
Asus P6T deluxe V2 mobo



I have the same exact setup as you, but I play the single-player game at 1680x1050 on HIGH with no issues whatsoever. The new NVIDIA 266.58 drivers came out today, so update that to see if it helps any. I do get slowdown in BC2 on mulitplayer though, even on LOW settings, but I think it is more of a network issue I am having.
m
0
l
Related resources
a b Î Nvidia
January 18, 2011 10:40:43 PM

With the 260.99 drivers I had no performance problems at all with a single GTX 470. I'm not aware of any bugs/conflicts with BFBC2 with that particular driver. Though BFBC2 did have problems with the last Beta driver.

As misfit14 noted, you might uninstall your existing drivers and update to the newest 265.58 driver and see if that helps.

Reference the graphical errors:
1) What are your GPU temps after playing the game for 5 mins or so?
2) Try updating or reinstalling your drivers.
3) Make sure your DirectX is up to date.
4) If all that is fine, try having Steam the game for any errors.
m
0
l
January 19, 2011 3:00:13 AM

Thanks for all the responses! I'm going to update my driver's tonight and see if anything happens, the issue isn't as bad as it was before my temps are around 66C after about 5-10 min. of gameplay. My FPS I believe is around 40-50 fps average so it is running fairly smoothly. I will most likely run prime95 or something like it to just double check that there is nothing wrong with my the GPU. Thanks again for the responses
m
0
l
January 19, 2011 3:20:29 AM

zerobdr said:
Thanks for all the responses! I'm going to update my driver's tonight and see if anything happens, the issue isn't as bad as it was before my temps are around 66C after about 5-10 min. of gameplay. My FPS I believe is around 40-50 fps average so it is running fairly smoothly. I will most likely run prime95 or something like it to just double check that there is nothing wrong with my the GPU. Thanks again for the responses


40-50 sounds about right for your system, why not overclocking your 920 or your gtx 275 a bit? Personally i run it maxed on all high at 1080p with a phenom ii x4 955 @ 4.0 ghz and a slightly oc'ed 6870, I feel like this game likes a high cpu frequency so an overclock may help, but then again your gpu may be holding you back a bit but 40-50 fps sounds pretty good I would say your performance is correct for your setup as it is right now, so why not try an oc, isnt the 920 known for that?
m
0
l
January 19, 2011 3:22:01 AM

I have to say that BFBC2 has some of the best use of DX11 imo, with that gtx 275 you are missing out a bit with the visual details.
m
0
l
!