Memory limited to 1066mhz?

Hi!

I bought a lenovo thinkpad e125, with an AMD E-450 APU. According to the news, and AMD's website, the E-450 has a memory controller that can handle 1333mhz memories, which i have in my netbook. The memory is Samsung made, and the speed is PC3-10700, according to speccy.

The problem is, that in every measurement software (speccy, cpu-z, gpu-z), i see that the memory is operating at 533mhz (which means 1066mhz).

I couldnt find any memory related settings in the bios (updated to the latest one). The latencies are: 7-7-7-20.

Any advice?

note: i checked gpu-z because the vga card is using the System ram as well
note2: i tried looking at the values when the machine was under heavy load (both cpu&gpu), but the frequency was still the same 1066.

5 answers Last reply
More about memory limited 1066mhz
  1. If you see one AMD E-450
    http://www.amd.com/us/products/notebook/apu/mainstream/pages/mainstream.aspx#6

    They also mention if DDR3L means Low Voltage that is use 1066 only and you get around 533 is right

    What is the SPD Sceen
  2. hmm what does that mean? so should i replace the ram module? or is it fine as it is? :)
  3. In speccy and in cpuz i see only DDR3, and PC3-10700

    by SPD extensions there is a EPP only.
  4. I seriously doubt that your BIOS allows you to modify the 'DRAM Frequency', and if it did look at the 'SPD' tab, more than likely DDR3-1333 (667MHz) is at CAS 9. The 'real' performance difference running DDR3-1333 CAS 9 (slower) vs DDR3-1066 CAS 7 (faster) is fractional. You'd gain in the real world nothing; i.e. leave it alone.

    There's a difference between different RAM frequencies being 'specified' as compatible vs 'running' and working at the higher frequencies. RAM's speed as shown below is BOTH a function of Frequency (higher=faster) and the CAS aka pauses (lower=faster).

  5. My E-450 based machine came with a Samsung PC3-10600s memory module that should have been clocked at 667 MHz but was running at 533 MHz according to the Vision Control Center. The problem went away after upgrading the BIOS and telling it to load optimum defaults. When the machine restarted the memory was running at full speed.
Ask a new question

Read More

Memory AMD