Intel D975 Motherboard cannot find SSD

I have an Intel D975XBX. I just bought a Mushkin Chronos 60GB SATAIII SSD.

In the BIOS, I can see the SSD listed as an HD, but I can never get it to boot to it.
I've tried perfectly fine SSDs from other machines.
I've tried both the Intel and the Marvell ports.
I've tried the BIOS setting to AHCI, RAID, and IDE.
I have the latest BIOS for the MB.

Has anybody run into the problem before? Did you find a solution?
4 answers Last reply
More about intel d975 motherboard find
  1. Why don't you prep it first. Use hardrive software to detect and format the ssd; then it should work fine. I use maxblast 5.0 (seagate and maxtor drives only) but other manufacturer's have their own available for download. Most retail box drives include the software cd and it should act as a bootdisk. Or you can clone another drive if it was running on your board.
  2. Thank you for your response. Yes, I formatted 30G of it to NTFS with no problem on another machine. The D975 won't see any of the 4 SSD drives I own.
  3. On one of my boards, the only way the ssd would run was in "native ide" mode. Try that if you haven't already.
  4. IDE Mode is the only way...

    Thanks for your help!

    K
Ask a new question

Read More

Chipsets SSD Intel BIOS Motherboards