Sign in with
Sign up | Sign in
Your question

K9N SLI V2 drivers for Win 7

Last response: in Motherboards
Share
February 24, 2012 3:34:43 AM

I have K9N SLI V2 mainboard and I'm going to install Windows 7 home premium 64 bit, but the problem is there is no drivers for it. The newest System drivers there is are XP 64 bit and Vista 64 bit drivers. So what drivers should I go for?

I've seen people have this exact same mainboard and Win 7 64, so there's gotta be some drivers to go with..

And, I asked MSI support about this but they just said "That mb is too old, we dont recommend installing Win 7"

So what to do?

More about : k9n sli drivers win

a c 107 V Motherboard
February 24, 2012 4:02:27 AM

If that mobo support Vista 64 i think can support Win 7 64. At the beggining of Win 7 there was no drivers and i used drivers from Vista 64 and all was great. Try to see. You don't have nothing to loose.
February 26, 2012 7:05:56 AM

sosofm said:
If that mobo support Vista 64 i think can support Win 7 64. At the beggining of Win 7 there was no drivers and i used drivers from Vista 64 and all was great. Try to see. You don't have nothing to loose.


Ok. I'll test them out then, thanks :) 

Someone said that vista64 drivers might work but might not be very stable(?). And recommended getting a new mb.

That's easy to say, "get new this, get new that", but I'm sticking with this s**t for now, because if I just change to new mb it forces me to change processor+rams too...and possibly something else. No way, I'd rather struggle with these things as long as I can.

So... let's see those Vista drivers, shall we ;) 
Related resources
a c 107 V Motherboard
February 26, 2012 7:25:13 AM

Good luck.
February 27, 2012 3:13:22 AM

Ok, I did some more digging and found this german thread
http://msi-forum.de/index.php?page=Thread&threadID=9546...

Based on that I found this driver package:
http://www.nvidia.com/object/nforce-vista-win7-64bit-15...

( nForce > nForce 5 series > nForce 570 SLI AMD > Driver > Windows 7 64-Bit )

And, since the information on product detail
http://www.msi.com/product/mb/K9N-SLI-V2.html#/?div=Bas...
says: Chipset NVIDIA® nForce 570LT SLI I thought this driver should do the trick.

So why isn't that newer driver listed on the MSI site but can be found on nvidia site?

And, is this the driver I'm looking for or am I missing something here?


!