Sign in with
Sign up | Sign in
Your question

Intel Motherboard does not power on

Last response: in Motherboards
Share
February 24, 2012 1:07:26 PM

Hi all,

I ordered parts for a custom PC but am having difficulty getting it on.

The first thing I did was plug everything in (including video cards, fans, etc.) then tried to turn it on using the switch on the case but nothing was happening. We were getting the standby light on the mother board but that was it nothing else would power on. So, I thought that maybe the video card or some other things might be preventing it from turning on so I took everything out besides the RAM, processor, and power but still nothing would turn on.

I thought maybe the problem was the switch so I used the screwdriver trick up just connecting the two pins where the switch plugs into and everything turned on! I then got a little too excited and plugged everything back in but then when i tried the screwdriver trick again it did not work. It still will not turn on with or without all the extra plugs like usb's and video card.

This is a picture of the motherboard right now that I have been trying to power on.

The Specs are
Processor: Intel Core i7-2600K Sandy Bridge 3.4GHz (3.8GHz Turbo Boost) LGA 1155
Motherboard: Intel BOXDH67BLB3 LGA 1155 Intel H67 HDMI SATA 6Gb/s USB 3.0 Micro ATX Intel Motherboard
RAM: G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9D-8GBRL
Power Supply: VisionTek PSU650VTZ 650W ATX12V Power Supply
Case: NZXT Apollo Black SECC Steel Chassis ATX Mid Tower Computer Case

Any help or suggestions would be greatly appreciated! :D 
a c 328 V Motherboard
February 24, 2012 1:33:27 PM

Hi there,

Did u do this?

If AC power has been switched off and the standby power indicator is still lit,
disconnect the power cord before installing or removing any devices connected to the
board. Failure to do so could damage the board and any attached devices.
m
0
l
a c 328 V Motherboard
February 24, 2012 1:34:43 PM

What video cards do u have?
m
0
l
Related resources
a c 328 V Motherboard
February 24, 2012 1:41:38 PM

Did u tried booting with just one stick of RAM installed?
m
0
l
February 24, 2012 2:31:12 PM

The video card is a Radeon HD 6850.
and yes I did disconnect the power cord before unplugging anything.
Also, yes we tried with just one stick of ram
m
0
l
!