System is unresposive, doesn't boot

I'v decided to put my system in a different case, in which I can also install chassis fans that I need.
The problem is that once everything is in place, and even if I try with just mobo, CPU, 1 stick of RAM, I turn on power to my power supply and the system already starts "working". My monitor is just black, CPU fan spins, but the speaker don't sound any confirmation or error messages.
Power and reset buttons aren't responsive and I have to shut down the system in the same way I "turned" it on.
It works and boots perfectly in a different case, which is a very old one. The one I'm trying to install the system in is from ASUS, which is pretty old too. It's a stock case from an old P4 system.
I'v rechecked all of the cables, and tried with a different video card, different speaker, different power/lights cables.


Components:

Corsair CX500 PSU
Asrock 4CoreDual-SATA2 mobo
Intel Core 2 Duo @ 2.93 Ghz CPU
Corsair VS1GB400C3 RAM(x2)
HIS Radeon HD 4670 AGP videocard


I know I can mix up things or provide unrelated or insufficient info, since I'm fairly a newb in PC building. So if there is any info that you might need or could find useful in order to determine the cause of this problem, please ask. Any ideas on this matter are appreciated.
3 answers Last reply
More about system unresposive doesn boot
  1. I noticed this thread and going to go through as much steps as I think could cause this problem:
    http://www.tomshardware.co.uk/forum/261145-13-perform-steps-posting-boot-video-problems

    Feel free to share any ideas anyway.
  2. Fixed.
  3. Well, shucks. What fixed it?
Ask a new question

Read More

Homebuilt Systems