Sign in with
Sign up | Sign in
Your question

PicoPSU-120 + 80W Adapter Powerful enough for my HTPC?

Last response: in Components
Share
June 24, 2011 8:13:24 AM

I have an HTPC with the following specs and am wondering if the picoPSU-120 + 80W Adapter is enough for it:

- Mobo: ASUS E35M1-M PRO
- SSD: OCZ Vertex2 60.0 GB
- Slot-loaded ODD: Sony Optiarc BC-5600S
- Memory: Crucial 4GB (2 x 2GB) DDR3 SDRAM DDR3 1066 (PC3 8500)
- 1 x 60 mm case fan

I put the picPSU in the build and couldn't get it to boot, but the build worked fine when I swapped it for a standard PSU. I'm trying to decide if the picoPSU is enough of whether or not it could be faulty. Thank in advance for any help and I'd be happy to answer any more specific questions about the build.
a b ) Power supply
June 24, 2011 12:54:40 PM

I would say your pico is faulty... either the AC transformer or the PSU itself. Just for comparison, my E35M1-I Deluxe is relatively a "power hog" as it uses 40-50W. Most Zacate builds I see on other forums are in the 20-30W neighborhood. 80W should be plenty for what you've listed.
Related resources
June 24, 2011 7:43:41 PM

Thanks for the quick replies. I think I'm going to try testing the pico w/ a Voltmeter to make sure all the pins are the correct voltages. I'll let you know the results. Thanks again
June 24, 2011 8:11:07 PM

I think I may have a faulty picoPSU. The transformer is working fine as the dc input for the picoPSU is getting 12 volts. However, I can't get any voltage readings on any of the 20 pins using a multimeter. Any suggestions?
July 1, 2011 4:11:18 PM

I wasn't thinking and forgot to signal the power supply on so I shorted pins 14 and 15 and measured correct voltages on all the ATX pins and the molex connector as well. After this I put it back in my system without plugging in the slot-loaded blu ray drive and it worked fine. Then I plugged in the blu ray drive and the system still works but the blu ray drive doesn't power on even though its plugged in. So now the HTPC is working, just can't get the optical drive to get power even though its plugged in. Seems like the drive isn't getting enough power and the drive says 5 volts and 2 amps on it. I got a 80 Watts A/C adapter with my pico so I might just have to up that to 120 Watts. Anyone know how I use my multimeter to test the current going into the optical drive?
a b ) Power supply
July 1, 2011 4:48:46 PM

Very strange. According to Sony, it needs +5V/1A. If you had an adapter, you could try the drive on something with more power, like a desktop PC. Can you read how many watts are being pulled at the wall when you try with and without the ODD?
July 8, 2011 11:46:23 AM

Pretty sure the drive is faulty, swapped out the PicoPSU for a 585 Watt power supply that works fine and couldn't get the drive to power up. Tested the voltage on both sides of the connector and its correct so hopefully a new drive will fix the problem. And regarding the Pico, I've been using it without the front panel connectors plugged in (2 USB's and an eSata), but as soon as I plug those in, the system won't boot. So obviously those use too much power. I think I may get a 120 Watt AC adapter just so I can have the most power available to the pico and hopefully that will let me use the drive and the front connectors but we'll see. Thanks again everyone for the responses and help.
a b ) Power supply
July 8, 2011 12:40:09 PM

Keep us updated on your project. I'm interested in how it turns out.
July 15, 2011 12:29:11 AM

Still waiting on the new optical drive to be shipped back ... as I said I'm sure that's faulty as I tested it in another working build and it wouldn't power up. However, I've done some research on the board and it seems odd that it won't boot with the front panel connectors (just 2 USB slots and one SD card slot) plugged in. If there's nothing plugged into these slots, I wouldn't think that they take up any additional power. Also, according to the testing done on my board, the ASUS E35M1-M Pro, with a load on the CPU it still consumes under 45 Watts (http://www.overclock3d.net/reviews/cpu_mainboard/asus_e35m1-m_pro_micro_atx/6). So just the board with an SSD drive works fine, but introducing the two USB connectors and an SD card connector causes it to not boot? This seems like it could be more than a PSU, anyone have any thoughts? Sorry for the blabbing, just kind of thinking out loud. This is my first experience with an APU board and my first time really trying to build a lower power consumption PC so a lot of this is new to me. Thanks again for all the help!
a b ) Power supply
July 15, 2011 2:47:03 AM

I've got a Gigabyte board that won't boot if I have a card reader plugged into a header unless I tweak one setting in the BIOS. I think that for some reason it was searching the empty card slot for a boot device and it halted the boot.

Might want to poke around the BIOS for legacy USB boot, alternative boot device, or other settings if your board is doing the same thing my Gigabyte board was doing.
!