Sign in with
Sign up | Sign in
Your question

Image Quality Issue on Blu-Ray Movies

Last response: in Graphics & Displays
Share
January 19, 2011 8:53:22 PM

Hi,

I recently changed my graphics card from a radeon hd 4350 to a xfx radeon hd 5770. before I changed, blu ray movies would play perfectly and beautifully. now the image is pixelated and noisy, it's viewable, but it gets on my nerves quickly.

I have a UH08LS10 blu-ray player that I added in an HP pavillion elite e9230f some time ago ( like one year ). I have an acer h213h full hd 22" monitor hooked to my pc with DVI connection ( on the radeon hd 5770 ). I use powerdvd 10 mark II to watch blu-ray movies.

Thanks in advance for your help.

by the way I used to have HDMI connection on my monitor, the image was noisy as well. My DVI ports have HDCP as well.
January 19, 2011 9:41:09 PM

Try using a different blu ray player if possible. It sounds like encoding trouble. How about trying different video drivers?
January 20, 2011 7:05:16 AM

Always use the latest AMD Catalyst drivers from the official website http://support.amd.com/us/gpudownload/Pages/index.aspx

You should enable the GPU Acceleration in your video player software (usually, automatically enabled, but check for sure). You can then try tweaking CCC settings for better video quality. Hope this helps.
Related resources
January 21, 2011 12:59:58 AM

okay

1. my CCC is already up to date

2. gpu acceleration is activated in powerdvd

3. CCC tweaking doesn't solve anything

i'm going to open my computer and verify that I didn't created an electricity conflict with the blu-ray player when I installed the hd 5770.

thanks to you for your answers, keep posting, it helps :) 
January 21, 2011 1:23:27 AM

Check list:

1. Disable Integrated Graphics in the BIOS and select PCI-E Slot Graphics Card as primary.
2. Uninstall the drivers from Device Manager and then restart. Once again install Catalyst Driver suite.
3. Try using GPU->HDMI <-> Acer Display->HDMI Connection.
4. Disable any GPU Overclocking.
5. Check for PCI-E slot compatibility (i.e. Radeon HD 5770 has PCI Express 2.1 x16 bus interface and your mobo actually supports it).
6. Make sure your Power Supply is able to handle the massive power requirement of the card.
February 5, 2011 12:52:26 AM

I tried everything above, still noisy image.
February 5, 2011 6:11:52 AM

One more thing, check for any Electromagnetic sources of Interference (At the vicinity of the PC), they may interfere with the computer signals. Also, could you please upload some screenshots of the movie with noise clearly visible?
February 14, 2011 9:32:17 PM

Ok,

1. I tried changing the sata port for the blu ray player. didn't do anything.

2. Everything is up to date (the bd player, powerdvd, the radeon 5770, etc.)

3. I bought an hdmi cable and I use it now. however :

on default settings I have black bars up and down and by each sides of the screen (in fact I am not full screen, even in 1920 x 1080.), so I went in CCC to activate the overscan option. Now I'm full screen. Normally it shouldn't affect image quality, but I may be wrong. Anyone knows ?

thank you
February 14, 2011 9:34:42 PM

for the power supply thing, I'm okay, mine is a 700w PSU.
February 15, 2011 11:12:17 AM

Overscan upscales a part of the movie to the Monitor's resolution, upscaling means you will lose some quality. Always keep your Monitor in native res only. "Please upload some screenshots of the movie with noise visible." It would be helpful.
March 30, 2011 8:02:44 AM

I have the same problem too...just like you.

My old 8500GT play very well, but GTS 250 doesn't give me a smooth playback, and HD 5770 doesn't give me a good picture...
So, I have to upgrade to GTX 460, which is the model in PowerDVD's support list.
!