Sign in with
Sign up | Sign in
Your question

Sapphire 5850 not detected, unresponsive

Last response: in Graphics & Displays
Share
January 21, 2011 3:03:50 PM

I have a Sapphire HD 5850 1GB graphics card. Bought it in May 2010. Has been working fine for so long. But today while playing Call Of Duty Black Ops, my system crashed. It became non responsive and i had to keep my power button pressed for 6sec to turn my pc off. After this it wouldn't start again.

The graphics card fan runs at full rpm (its very loud) and there is no display. My motherboard is unable to detect the gpu. tried it by plugging it into a friends pc but still same result.

I have tried disconnecting and reconnecting all cables. Also reset my motherboard bios but no help.

System config -
Core i5 750
ASUS P7P55D-E Pro
Sapphire Radeon HD5850
Corsair 650VX
GSkill 4GB ram

everything is running at stock. no overclocking. Please help!!

PS - the motherboard gives a long beep followed by 3 short beeps which according to the user manual means that the motherboard didn't detect any graphics card installed.
a c 1362 U Graphics card
a c 1097 V Motherboard
January 21, 2011 7:34:29 PM

If the card did not work in your friends computer either, it is time to RMA the card! It is the card that died.
m
0
l
a b U Graphics card
a b V Motherboard
January 21, 2011 7:54:35 PM

rolli59 said:
If the card did not work in your friends computer either, it is time to RMA the card! It is the card that died.

rolli59 is spot on, the card died, You should contact the manufacturer (Sapphire) for a RMA to get a replacement.
m
0
l
Related resources
January 22, 2011 12:39:10 AM

:(  guess don't have anything else to do. :( 
m
0
l
May 24, 2011 4:43:23 PM

How did this work out for you? I have a 4850 that I bought in April of 2010, getting ready to start the RMA process with Sapphire.

Were they responsive? Did they replace your card? Charge for return shipping?

Thanks
m
0
l
!