Sign in with
Sign up | Sign in
Your question

ATI Radeon HD 5450 & my HTPC - I can`t see Windows!!

Last response: in Graphics & Displays
Share
January 22, 2011 7:08:50 AM

Okay, let's get the specs out of the way first...

AMD Athlon II X2 265 3.3GHz dual-core CPU
Gigabyte GA-890GPA-UD3H motherboard
4GB (2 x 2GB) Patriot DDR3 PC3-10666 RAM
ATI Radeon HD 5450 video card
HT Omega Claro HD sound card
Toshiba HD-DVD drive (IDE only - unfortunately, no such thing as a SATA HD-DVD drive)
2X Seagate 1.5TB SATA hard drives (as is - I couldn't get the RADI0 config to work)
All housed in a Thermaltake VC7001SNS Mozard media case (very squishy)
Plugged in to a Sony 60" SXRD Projection TV (1080i) using a DVI --> HDMI cable

Once I finished my build, I decided to install Windows using a simple 17" VGA monitor. I had no problems installing Windows or Updates, but things started going a little wacky when I elected to install Catalyst and the latest drivers from the ATI website. The first time I rebooted, I could see the CMOS and initial bootup, but once Windows came on, everything vanished. I tried rebooting again, and this time, Windows did come up - but boy, was it acting weird. I imagine the problem here was simple - it's an old bugger monitor, and it couldn't handle the input from the card. Even doing something simple like opening up a folder would make the monitor refresh at a horrible rate - it seemed like one second/line refresh rate. That's really hard to look at, so I decided to move the PC over to the TV (since that was going to be it's new home anyway) and finish installing software and such. Bad move. Even after a half-dozen reboots, I still wasn't able to see Windows on my TV.

As an experiment, I turned on the onboard video and plugged the TV into that - and Windows suddenly appeared. However, it was stuck at 640x480 resolution and the TV itself was showing up as a PnP monitor in the Display Settings. Okay, that was a bust.

I decided I would try to reinstall Windows while the PC was plugged into the TV and see what would happen. I had no problems with the install (aside from a really nasty overscan problem - I lost the top & bottom couple of lines when the CMOS was up, and I lost my taskbar when Windows came up (once again, only 640x480)). This time, I elected to install the ATI drivers from Windows Updates, rather than the ATI website - and *exactly* the same thing happened. I could only see the CMOS and initial bootup on screen, then Windows vanishes completely.

I'm absolutely *convinced* that the problem is a settings problem, but if I can't see Windows, how do I go about fixing it??

Any help anyone can provide would be greatly appreciated.
January 22, 2011 11:09:13 PM

Did you go into the BIOS settings and tell it to override the onboard GPU when the Radeon is detected?
January 23, 2011 3:40:22 AM



Yes, I did... I ended up going into Safe Mode (duh - why I didn`t think of this sooner) and uninstalling the drivers... I tried rolling it back to previous versions of the drivers and ended up going all the way back to last August to even get a picture on my TV... big problem *there* was that the refresh rate maxed out at 30fps - ick!! So, as of right now, it`s sitting with no ATI drivers at 640x480, waiting for a solution... I`m wondering if it`s even worthwhile to bother with so many problems, when my old Radeon HD 2600 XT works like a charm... maybe I should just go back to my old card...
Related resources
January 30, 2011 5:52:56 AM

mister g said:
How about this download Driver Sweeper http://www.guru3d.com/category/driversweeper/ and uninstall all the Catalyst files, then go and install the new ones from AMD.


Didn't take, I'm afraid - highly annoying... so I ended up pulling the 5450 and popping the 2600 XT back in... an older card, I know, but it works like a charm and all 1080i content plays back just fine (and so do my HD-DVDs), without any skips, pops or glitches - go figure...

But here's something *really* bizarre... I popped the 5450 into my little guy's PC (didn't want the card to go to waste, and I had the video onboard only before), with the latest Catalyst & drivers, and guess what - it works just dandy. I'm wondering if something about the 5450 and the Sony TV just didn't like each other or something... but whatever - everything works just fine now - I'm a happy camper... :) 
January 30, 2011 11:01:46 AM

Good for you then, I was thinking a BIOS flash might solve your problem but if you're happy then there's no need.
!