Sign in with
Sign up | Sign in
Your question

GIGABYTE GA-970A-UD3 stuck on post screen. Need help!

Last response: in Motherboards
Share
February 29, 2012 4:18:11 AM

I just got this motherboard today and everything was working fine i wasn't stuck on the posting screen until now. I can't even load up the bios menu, boot menu, Q-Flash ext. I had cleared the CMOS, took out the battery for a few minutes. Unplugged everything and replugged. Nothing happens...


Is there a way to fix this?






My specs:

GIGABYTE GA-970A-UD3
MSI N550GTX-Ti Cyclone OC GeForce GTX 550 Ti (Fermi) 1GB
OCZ Fatal1ty 550W Modular Gaming Power Supply
AMD Phenom II X4 960T Zosma 3.0GHz Socket AM3
Patriot 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10600)
Seagate Barracuda ST500DM002 500GB 7200 RPM 16MB Cache SATA 6.0Gb/s 3.5
a b V Motherboard
March 1, 2012 12:02:35 AM

Is there any beep sound? One short beep means booting up to Post but may have no display so that you can not notice where it goes.
Check your vga power connection if it required.
Check your 12v power connector.
Related resources
March 1, 2012 2:14:53 AM

Thanks for the help. I had solved a while ago so that's taking care of.

But i have a completely different problem now when i try to install windows it says "Select the driver to be installed" when i try to browse for the drivers an error page comes up. It says "No device drivers were found. Make sure that the installation media contains the correct drivers" to be honest i don't know what drivers to use.

I tried using my Gigabyte CD that came with the MOBO, same error pops up. So i went and switch the SATA cables around and it didn't work, not only that on the Standard CMOS Features i notice that my ASUS drive reads 0MB on one of the IDE Channels master/slave.

What should i do?
a b V Motherboard
March 1, 2012 11:27:47 PM

It mostly encounter when ..
- no driver installed yet with hdds configured to ahci or raid mode.
- ill formatted hdds before installation.
i tried once to boot up with windows xp dvd and it can recognize hdds much easier and the format program there working with my hdds .. after it .. return to windows 7 and then they are appeared.
March 2, 2012 4:45:46 AM

It won't let me format the Hdd, I even tried in CMD. And what drivers do I need? I tried many times to configure Ahci and raid but nothing really happens. I been using IDE mode, any ideas?
March 11, 2014 2:28:28 AM

How have you solved BIOS problem? I've got same strange behaviour.
!