Sign in with
Sign up | Sign in
Your question

ATI Crossfire Problem!

Last response: in Graphics & Displays
Share
January 22, 2011 8:27:16 PM

Hello,

I recently purchased another 4890 pcs+, as I already have one and therefore can crossfire them. I have a phenom 955 4gb ddr3 ram and a 750w xfx psu. Now I was expecting to see a nice increase in fps when playing games such as crysis and black ops, ( I know there have been some crossfire issues with BO) however when I actually enable the crossfire I actually loose 15-20 fps in game. Yet on 3d mark vantage my system gpu scores like 18000 which is higher than the single card. So I can get to the bottom of what it is? Any help would be much appreciated!

Thanks in advance

Mat

More about : ati crossfire problem

January 22, 2011 9:04:07 PM

What motherboard do you have? and what driver version are you running for catalysis
January 22, 2011 9:33:16 PM

Are you using GamerOSD or Smartdoctor? They can have issues with Crysis.

What is your motherboard? Your PCIe slots might not be optimal. having a x4 slot for your 2nd card can cause problems in performance. Try downloading GPU-Z to see what PCIe bus interface they are running at.
Related resources
January 22, 2011 9:45:07 PM

Crysis might be one of those games that doesn't scale well in cross fire. You should look at benchmarks around the web.
January 22, 2011 10:03:30 PM

batch16 said:
Hello,

I recently purchased another 4890 pcs+, as I already have one and therefore can crossfire them. I have a phenom 955 4gb ddr3 ram and a 750w xfx psu. Now I was expecting to see a nice increase in fps when playing games such as crysis and black ops, ( I know there have been some crossfire issues with BO) however when I actually enable the crossfire I actually loose 15-20 fps in game. Yet on 3d mark vantage my system gpu scores like 18000 which is higher than the single card. So I can get to the bottom of what it is? Any help would be much appreciated!

Thanks in advance

Mat

in ati catalist, set everything on "aplication controled" catalist AI on default, tripple buffer enabled. then check and see if u have CrossX in games. thats solves my problem, i also have 2x4890.
!