Sign in with
Sign up | Sign in
Your question

Explorer.exe No Disk

Tags:
Last response: in Windows 7
Share
November 30, 2011 12:21:58 PM


Does anyone else get this?

Basically I'll boot up my machine (alienware m17rx3) and then open ‘My Computer’. Then I’ll insert a USB stick or a dvd. Everything happens normally. However with ‘My Computer’ still open I will right click the USB stick and click eject & a message will always pop up. Most commonly ‘Explorer.exe – No disk’ ‘There is no disk in the drive. Please insert a disk into drive\Device\Harddisk1\DR1’. The box gives options to cancel, continue & re-try. If I click cancel the box will re-appear. Basically I have to click through it about 5 or 6 times before it eventually disappears. After that all is fine and dandy.

If I eject using the icon in the system tray I don't get the same problem. Likewise with a DVD, if I use the button on the top right of the laptop to eject the dvd the error message doesn't happen. It's only when ejecting using right click, eject on the drive within 'my computer'. I’ll get same message but instead of please insert to device\harddisk\DR1 it will say ‘Please insert a disk into drive D:’.

It’s also odd because it only does it once. Subsequent ejections of a dvd or USB stick are then fine. Until the next boot anyway. I have managed to stop / suppress the error by changing the errormode in the registry to 2. However it’s not a real fix. As far as I can see there are no side effects, everything works absolutely fine but it does concern me. I have trawled google til I’m blue in the face with no joy. The common issue being that the USB stick has been assigned the C: letter and to change it in disk management but that doesn’t apply to me as it always gets assigned as E: whilst my DVD drive is D: I did try changing the drive letter for the sake of it but it didn’t help. Also tried disabling all start up items & clean booting with only MS services running – again no joy. Finally tried logging in with a new user profile and again no help. Other things I did was clear recent documents so nothing points towards either the optical or USB drives.

Is it possibly some kind of other issue? It’s getting kind of irritating. I am inclined to think Windows updates have intro’d this bug. But I can’t confirm when this started happening as I don’t normally eject this way. But now I have noticed the problem it is something I am keen to fix.

Thanks
Wayne

More about : explorer exe disk

a b $ Windows 7
November 30, 2011 12:25:34 PM

Hello Scottyboy99;

How does the USB stick behave in other systems?
a b $ Windows 7
November 30, 2011 12:27:15 PM

Scottyboy99 said:
The common issue being that the USB stick has been assigned the C: letter
Explain the details behind this comment.
Related resources
November 30, 2011 12:40:18 PM

Hi,

The stick behaves fine in other systems. Well, I only have a Vista machine to test it on. The box only comes up when ejecting, and only if I eject using right click in 'my computer' in the drive. It will do exactly the same when ejecting a DVD the same way. But it only does it once, after this it is fine. And it won't do it at all if I eject using the system tray icon. Weird huh?

Sorry to further clarify the comment. Googling around gives so many solutions of how a drive letter conflict maybe occuring with the C: drive and to assign the DVD or USB drive a new drive letter. However, for me under disk management everything looks fine. For the sake of it I did assign the USB drive a new letter but it made no difference.

Many thanks,
Wayne
a b $ Windows 7
November 30, 2011 12:48:55 PM

Has that USB stick ever been used as a boot drive? As in, having a bootloader? Maybe as Live RescueCD on a USB stick?

Any problem with just reformatting the drive on your laptop?
November 30, 2011 1:05:55 PM

Hi,

The only thing is the USB stick contains a drive image created by 'Alienware Respawn' but I get the same problem when ejecting a normal movie dvd first time around.

Well I could re-format / re-install but this option is a little unpalatable considering everything I have done after the last 6 months.

Many thanks,
Wayne
a b $ Windows 7
November 30, 2011 1:26:58 PM

Have the same problem with other USB flash drives?
a b $ Windows 7
November 30, 2011 1:28:15 PM

Scottyboy99 said:
USB stick contains a drive image created by 'Alienware Respawn'
You defiantly do not want to reformat that particular USB drive.

November 30, 2011 1:35:20 PM

I'll try another one later but I suspect that will be the case (I am sure I did try another one some weeks ago anyway and had same result). The reason I think that it is likely to happen is because I get exactly the same thing happen with a DVD when ejecting except rather than say 'please insert a disk into hardisk\device\DR1' it'll say 'Please insert a disk into D:'

I can suppress the error via the registry but it does alarm me and using such a method could hide more sinister system messages that I'd need to be seeing in the future.

Many thanks,
Wayne
a b $ Windows 7
November 30, 2011 1:40:41 PM

Im leaning toward this is a hardware/laptop thing. And not Windows 7.
Have you asked in the Alienware support forums? Might have someone else with the same issue there.
November 30, 2011 1:44:50 PM

Ok. Many thanks for your help. I'll try over on those forums.

Cheers,
Wayne
a b $ Windows 7
November 30, 2011 1:46:00 PM

If you find a solution toss in in here.
You'll probably not the be the last person with that type of issue.
November 30, 2011 2:08:37 PM

I was testing your theory about the CD Drive.... it seems as if it is accessing the data and you eject it while it is still using the CD drive, so it shoots up that message....

I put a disk in and while it was "auto-playing" it... I ejected it... no message... But, I went into Computer Management and disabled 'Plug and Play' Service and tried the same thing... but this time it sent an error message telling me to insert a disc... tried it again and again with same result.

Check what the status of that service is... it should be 'Started' and 'Automatic'. Try disabling enabling that and see if you get any change.

Do you see an further information in Event Viewer? Sounding like a software problem most definitely... not hardware.
November 30, 2011 2:37:01 PM

Many thanks for the suggestion. It is a weird issue. Your right, I am sure it's a software issue but trying to find what is proving tricky. Especially the fact it's still there after a clean boot. I am inclined to think windows updates/hotfixes have triggered it.

In any case I will look for the service later and try it out. What's the exact name of the service - presumably just autoplay (sorry I haven't got the machine to hand)?

I can't see any references in the event viewer. It's a minefield of info but nothing sticks out!

Cheers,
Wayne
November 30, 2011 2:43:55 PM

'Plug and Play'.... I am on a XP machine right now, so it may be different in Windows 7.
November 30, 2011 3:09:47 PM

Sorry, you did actually tell me that in the message prior - I should of read it properly! It's definetely as if the drives (whether they be DVD or USB) are still being accessed when I eject them. Strange that it only happens when doing via right click on the relevant drive under 'my computer'. Ejecting via the system tray icon in the bottom right is fine. Also strange that it only happens once - after that it's fine!

I will report back if your suggestion works

Many thanks,
Wayne
!