Sign in with
Sign up | Sign in
Your question

Crossfire 5970 flicker problem

Last response: in Graphics & Displays
Share
January 23, 2011 5:44:06 AM

Hi

I recently brought a SSD which uses a PCIe link card which requires PCIe 4X to work.
My motherboard already plugged with 2 ATI 5970 graphic cards under PCIe setting of 16x 16x 1x

I plugged the SSD link card (raid card) to the 3rd PCIe slot and went to Bios and change the northbridge chipset > PCI Express Selector, from [auto] to 16x [8x 8x] (options are auto, 16+8+8, 16+16+1)

After bootup, everything is working good, except when I begin to test the crossfire using 'Alien vs predator benchmark'
When going in crossfire mode, i can see the ATI crossfire logo on topright corner, and i can see there are activities under each of the 4GPUs. However, the screen flicker every frame, like odd frame's resolution is different from even frame's resolution.

I also tested with 'Heaven' benchmark tool, same thing happened.
By disabled crossfire, the flicker gone, but i don't want to just use single GPU instead of 4 i owned
I checked and already changed the crossfire bridge which links the 2 cards
I reinstalled CCC and also went back to 10.11 from 10.12
I swap the 2 5970 cards from the motherboard
I even did a clean install of windows7 and then CCC
problem still there

I read some suggestion about down tune the memory clock to 900MHz to fix flicker problem, but under CCC AMD overdrive, the min Memory clock is 1000MHz

So my question, does 5970 crossfire need run on 16x + 16x PCIe? or am i doing anything wrong?

Current Config:
Win 7 x64 Ultimate
Intel i7 Extreme i7-975
ASUS P6X58D Premium http://ca.asus.com/product.aspx?P_ID=wurRaDZ8lo4Ckukj&t...
ATI 5970 + ATI 5970
OCZ IBIS 3.5" HIGH-SPEED DATA LINK SSD
Intel X25-M 160G
WD Black 2T
6 X 2G Skill DDR3-2000
22" + 30" +22" (1680x1050 + 2560x1600 + 1680x1050)

Thanks very much for your time
January 23, 2011 6:45:41 AM

Do the cards work fine in dual x16 mode ? (without the SSD installed)
m
0
l
January 23, 2011 7:21:53 AM

Yes, it was working in 16x + 16x mode before.

I just found out that if I turn on the vertical sync in the settings of the Benchmark programs, the whole thing is working fine. So i think its necessary to turn on the vsync option if i want to do a crossfire Directx 11.

I downloaded 'LostPlanet Benchmark' and I found out that if i use DirectX9, everything is working as expected. But when I use DirectX11, I need to turn on the vertical Sync to make it work, otherwise the frames will flicker.

weird, cause I didnt have to select this option before, when I first used that Alien vs P to test DX11.

I donno turning on the vsync is normal or not, but seemed the only option for my cards to work on xFire Dx11.

Thx
m
0
l
Related resources
January 24, 2011 7:30:21 AM

Well i have a 5970 and in some games I have to use Vsync;otherwise, some textures may not be displayed well.(flickering problems)
Can you test more games ?
m
0
l
January 25, 2011 7:29:34 AM

yes, i will try to test more games coming few days, thanks a lot for your help

i will post results or problems
m
0
l
January 26, 2011 1:07:33 AM

I have the same exact problem (also described here, together with everything I tried already and with pictures displaying the issue on page 3).

In my case, I'm running a 5870 and a 5970 in (tri)Crossfire, with 3 x 30" displays at 2560x1600 each.

After running the Lost Planet 2 Benchmark you mentioned, I can confirm it is indeed a problem with DirectX 11 games only - the screen 'twitching' does not happen on DirectX 9 games (for instance, I don't have that problem when running Left For Dead 2 or the Call of Duty - Modern Warfare games). Crysis Warhead flickers like crazy too.

By the way, I set the card's memory clocks to 900 Mhz using MSI Afterburner and that does NOT cure the problem. Enabling V-Sync in the benchmark or a game helps a bit but does not get rid of the screen flicker.

Some people confuse this issue with the old overclock 'screen tearing' issue on multi-monitor systems because of the card clocking down to 157 Mhz whenever ATI Overdrive was enabled. This is NOT the same.

My cards are *both* running at x16 PCIe (verified with GPU-Z).

I suspect this is some kind of hardware timing problem - I once changed something on the BIOS that solved another issue I was having at the time (unrelated to this problem, sound was cracking up when running CPU-Z, for instance) but which also fixed the screen tearing issue. Unfortunately after adding 6 GB of RAM something happened and the problem is now back.

Are you overclocking your system, by any chance?

Something else I have in common with you are Intel SSDs (actually three X25-M 80 GB G2 in RAID 0), but those are connected to the SATA ports on the motherboard, not to a dedicated card. I do have a USB 3.0 x1 card to drive my external WD My Book 3.0 though, but when I accidentaly fixed the problem by tweaking the BIOS that card was already installed.

Curious fact: before I got the ZR30W, turning off the 24" HP 3rd monitor (connected via Displayport) I had before would fix the flicker (but it was a pain doing this, as all the windows on that monitor would move back to the primary).

Current config:

Win 7 64 bit Ultimate
Intel i7 920 @ 4 Ghz
Asus P6T Deluxe v2
ATI 5970 + ATI 5870
3 x Intel X25-M 80 GB G2 in RAID 0
Samsung F3 1 TB
WD Green 1 TB
6 x 2B Corsair DDR3-1600 Mhz
30" LG + 30" ZR30W + 30" LG (2560x1600 x 3)
m
0
l
January 26, 2011 3:08:49 AM

I did a little bit of overclocking my memories to 1600 @ 1.6v, thats it
(i m new to overclock)

Do u have a Logitech g19 keyboard which comes with a little color display?
or an External USB3 hub?

coz these 2 pieces of hardwares are also causing problems once a while to my new install clean win7

e.g. the USB3 sometimes popup sounds of unplug and then couple secs later, sound of plugged again.

Since the flicker problem only happens on xFire to DX11 games, I m not urgently needed to solve it, coz when the day there is a DX11 MMO game I need to play, I might go back to nvidia by that time.
m
0
l
January 26, 2011 5:03:11 PM

Hmmm... No USB 3 hub here, but a USB 3 PCIe card (to plug my USB 3.0 WD external hard drive to, as the P6T Deluxe V2 only supports USB 2.0).

Your motherboard has a USB 3.0 NEC controller - the card I have is also based on the NEC USB 3.0 controller. Haven't tried removing the card yet to see if that makes the problem go away.

A known issue with the NEC controller is that it passes the PCIe spread spectrum to the device through the USB 3.0 interface. The NEC controller does not have it's own reference clock for USB 3.0. If the motherboard has an out-of-spec PCIe reference clock (either incorrect frequency or excessive spread spectrum), the device attached to the USB 3.0 controller will not be able to track the signal and will fail to enumerate on the system.

This actually happened to me, I had the PCIe frequency set to 101 Mhz instead of 100 Mhz and that was enough for the WD external hard drive not to be recognized.

Ah, I also tried running Battlefield Bad Company 2 in DX 10 mode and the screen tear is present as well. Only running it under DX 9 mode solves this issue. So the problem happens with DX11 *and* DX10 games.
m
0
l
February 1, 2011 1:35:59 AM

last week, when i got time, i tried...

download more game's benchmarks to test
open the case and push harder the graphic cards in case they are not probably plugged to the slots
make sure my 1200w PS connections to the graphic cards

sadly, same thing happens
Flickers will happen when running crossfire in dx10 or dx11 games

However, I found one little hint, i was running 3 monitors, if I disable other 2 and just using my 30" dell as single monitor, all games can run solid without flicker under crossfire on dx10 or dx11, even without vsync checked!

So my own best bet is the current driver problem, since the cards can run without problem. (I am using CCC 10.12), i will try to test more afterwards...

PS I will buy a Nvidia single GPU card next time for sure. When I build this system Jan 2010, the market's top card was 5970 and ATI 5000 series was better performance vs price, so i just gave it a try, I always use Nvidia before... I dont blame ATI, the cards are powerful, but its just a personal unlucky experience, things just went not smooth.. and wasted myself a lot of time and struggling ...
m
0
l
February 1, 2011 3:18:19 AM

As I mentioned in my previous message, before getting the ZR30W I had a HP 2475W 24" monitor connected via Displayport, with one of the 30" LGs being my primary monitor. Turning off the 24" HP monitor also solved the problem for me.

For some reason (I suspect because it was connected via the DP port) that actually removed the display from my extended desktop (windows on it would all pile up on my primary). This is what actually 'fixed' the issue.

Now the ZR30W is my primary monitor (connected via DP) and the LG's are at the left and right of it, both connected via DVI-D. Turning them off has no effect, since they do not get removed from the extended desktop configuration and simply display no image.

Still, I know this problem can be somehow fixed. I run without the issue for quite some time - until it came back. If only I knew what actually fixed it in the first place!

This truly is a pain. :-(
m
0
l
February 2, 2011 9:42:01 AM

I cloned my HD to setup a testing environment, after hours of testing, I found out that this flicker problem of my system can be fixed by using older version CCC version 10.7-10.5

The first version to cause my system to flicker begins 10.8. After I read the release notes, this 10.8 includes the following new functions:

-OpenGL ES 2.0 support
-Video Quality default options
-Performance enhancement for Eyefinity Quad ATI CrossFireX™ configurations
-Anti-Aliasing support for StarCraft I

I suspect its the 3rd one... i donno

Here are the list i have actually installed on the win7
11.1a Flicker
11.1 Flicker
10.12 Flicker
10.11 Flicker
10.10 Flicker
10.9 Flicker
10.8 Flicker
10.7 OK
10.6 OK
10.5 OK

By saying OK, means it works on my system, using Dx11 crossfire without vsync checked and the screen doesnt flicker. (3 monitors, 30" one is dual-link dvi)

I hope this works on your system too.

sigh.... i donno what went wrong, me or ATI... but this was wasting a lot of time ...
m
0
l
February 4, 2011 2:56:21 PM

Check this thread HERE in the AMD Catalyst forums.

That guy also seems to be having the same problem as us, and guess what? His motherboard has a NEC USB 3.0 controller too.

Right now I'm having problems with the 11.1 WQL drivers I just installed (they brought 2D speeds back down to 157 Mhz, which causes flicker on multi-monitor systems - ATI can't get one right!) but as soon as I solve that I'm going to yank the NEC USB 3.0 card to test my theory.
m
0
l
February 4, 2011 3:47:31 PM

Ok, I pulled out the NEC controller PCIe card and... same thing. Whatever it is, it's not the controller.

Damn, I was so sure I had found the culprit!
m
0
l
February 4, 2011 3:50:33 PM

did you try to install a older version of CCC? preferably 10.5 coz others said its the best one.
m
0
l
February 4, 2011 4:13:06 PM

No, but I have been installing ATI new drivers ever since 9.x and I always had that problem, regardless of CCC version (except when I did those changes to the BIOS, and I'm pretty sure I didn't change the driver version then).

Now 11.1 breaks overclocking on multi-monitor systems again. When idle the GPU clock stays at 400 Mhz as it should, but the memory clock goes down to 300 Mhz, and it needs to stay at 1,000 Mhz, otherwise you get screen 'ripples' on the secondary monitors when doing something like scrolling a IE window.

Turning off overclocking ensures the memory clock stays constant at 1,000 Mhz.
m
0
l
February 4, 2011 5:26:59 PM

Ok, at least I managed to solve the 11.1 driver overclock problem: changed the default profile (C:\Users\<User>\AppData\Local\ATI\ACE\Profiles.xml) so that the memory clock for the main 5970 GPU is always 1,100 Mhz regardless of core clock.
m
0
l
February 5, 2011 11:30:23 AM

Just yesterday I noticed that I've run into the same issue.
I'm running two Sapphire 6850 cards.
I don't know when it occurred, as I've had exams and only played WoW (windowed mode) in between for some time, but I know for sure that I was able to run 3DMark tests before Christmas. The only thing I changed from back then is, that I updated from 10.12 to 10.12a. Just yesterday I noticed that the new 11.1 drivers were out, but updating to those didn't solve anything. Neither did downgrading to 10.10, 10.10e or 10.12. (I'd rather not try to go lower, as my cards won't be supported).

I also have 2 monitors. A 24" with max resolution 1920x1200 and a 22" with max resolution 1650x1050.
As far as I can tell, the problem arise when I'm running a full screen game with crossfire enables and 2 different resolutions on the monitors. That means, if I try to run a game on my primary monitor with the resolution set to 1920x1200 it'll bounce as previously described in here, but if I reduce the resolution to 1650x1050 the problem is gone. In general, there only seem to be a problem when I'm running an application on my primary monitor with greater resolution than the secondary one. If it's equal or lower, there is no problem.

I'll probably try to test a few more things later or perhaps format my computer entirely to see if that solves anything.

e: Tried to disable secondary monitor, didn't help. I discovered that if I enabled GPU scaling, it would start to flicker at all resolutions, instead of just those above 1920x1200.
e2: Running with HDMI instead of DVI removed the issue, but disabled me from using dual monitors.
m
0
l
February 8, 2011 4:16:49 PM

You might be on to something with that different screen resolution idea. Right now I have 3 monitors all running at 2560x1600, but before one of the secondary monitors was a 24" HP running at 1920x1200.

Perhaps because it was connected via DisplayPort, turning off that monitor removed it from the Windows extended desktop group, and it also cured the problem. Unfortunately my new primary monitor (the ZR30W, which replaced the 24" HP) is the one connected via DP, and turning off the two LG DVI-D connected ones only turns the image off and does NOT remove them from the extended Windows desktop.

Perhaps the old driver for the 24" HP is still somewhere on this system and is still causing the problem somehow? I guess I'll have to reboot into safe mode to find out.
m
0
l
February 13, 2011 4:01:06 PM

just an update:

after more than a week of switched back to driver 10.7, i feel my computer went smooth without glitches. I can play Dx11 benchmarks without flicker. Dx9 games without problem.

I know there were some glitches before when sometime bootup without CCC, sometimes bluescreen, sometimes things just not act perfectly as it should be.

I will wait for ATI release new version of driver and test it in future and report here...
subject to if I am still allowing their product plugged on my motherboard coz i will change back to Nvidia when the time comes
m
0
l
March 16, 2011 9:39:58 AM

I have solved the problem today. finally

1)unplug the 2 ATI 5970 from my MB
2)plug the new GTX570 to my MB
problem solved!

games higher FPS
play youtube wont flash 1 sec black screen
OS more stable
CTRL-ALT-DEL wont take long time to get to the menu
can use the latest driver package

most of all, i know my computer is running flawlessly now!
m
0
l
!