Sign in with
Sign up | Sign in
Your question

GT 240 automatic clock rate control

Last response: in Graphics & Displays
Share
Anonymous
a b U Graphics card
January 23, 2011 1:42:19 PM

My GT 240 changes it's clock rate according to what I'm doing to save power, it under clocks itself when I'm in the desktop, and when I watch videos it increases the clock rate, when I play 3D games, in this case HAWX or run 3D applications it goes to the standard or highest clock rate and the game runs fine.
I can run HAWX at max settings with it at 1680x1050, I used GPU-Z to record the clocks and I found that they changed as I just explained, it's an energy saving feature.

My problem is that when I run a browser based or non-Direct-X based game it stays under clocked, for example when I run RuneScape in both OpenGL or Java (It supports both) It stays under clocked and doesn't realize that I'm playing a game, so obviously the game runs like garbage. How do I get the drivers to recognize when I run a non-DirectX game?

Here are the clocks:

Performance Level Default
Core clock 135.0 MHz
Shader clock 270.0 MHz
Memory clock 135.0 MHz

Performance Level 2D Desktop
Core clock 405.0 MHz
Shader clock 810.0 MHz
Memory clock 324.0 MHz

Performance Level 3D Applications
Core clock 550.0 MHz
Shader clock 1340.0 MHz
Memory clock 790.0 MHz

When I run a Java or OpenGL game it stays at Default mode 135MHz!



Anonymous
a b U Graphics card
January 25, 2011 12:14:07 PM

No over clocking software, I didn't use the disk, I just downloaded the drivers from the website and installed them. I don't overclock as it's pointless because my CPU is already doing a bit of bottlenecking.

The disk contains an older driver from the time of the card release along with the EVGA Precision overclocking tool. I didn't open the disk or put it into my computer, it just says what's included on the disk on it.

I have NVIDIA Graphics Driver 266.58 (The latest) and it automatically installed the 3D and HD audio for HDMI drivers and the PhysX system software.


And now that you mention overclocking software, would this energy saving system apply if I use and overclocking software or would it leave the entire clock rates to be handled manually by me?

Could that be a possible solution?
Anonymous
a b U Graphics card
January 26, 2011 6:46:05 AM

Please do so soon.
Related resources
a c 173 U Graphics card
January 27, 2011 12:41:46 AM

I never had an issue like this and don't play this game so I don't know what else to say but the blame can be placed on the driver. I think that maybe you can force the card into 3D mode meaning full clocks by loading another program in the background but that isn't practical. The issue is with the drivers.
Anonymous
a b U Graphics card
January 27, 2011 3:51:32 AM

I tried running 3D programs in the background, it works but they take away a lot of RAM; I only have 2.5GB of DDR2 400MHz memory.

The over clocking software gave me manual control, yet only for the current profile.
If you can, try RunesScape, it can be played via your web browser via Java. See your clocks.
Anonymous
a b U Graphics card
January 27, 2011 5:35:21 AM

Update:

The game supports DirectX, BUT
The game was written in Java, you can play it via web browser if you have Java installed and via web browser you can play DirectX or OpenGL, or Software/Java.

You can also play through a 15MB client that doesn't require Java and can play DirectX or OpenGL or Software/? (What could go here if you don't have Java?)


The company that made the game wrote games exclusively in Java until in 2010 they decided that they will no longer use Java and changed their name from Java Game Experts (Jagex) to some other thing.

And then randomly in the display settings you could choose OpenGL and DirectX.



Since the game was written originally written in Java it means that the DirectX and OpenGL are probably not "pure" they maybe container platforms; DirectX can run through Java and OpenGL can run through Java.

Java may not always be considered a 3D application, so the game has no particular platforms, it is running on multiple platforms.

When I run it in DirectX, the clock rate continuously switches between the 3 performance levels on my first post. This is too complicated and the only solution would probably be to disable the clock rate control or use the over clocking software
to change all 3 profiles to 550/790/1340MHz,

So how do I do that in EVGA Precision?
a c 173 U Graphics card
January 27, 2011 11:44:39 PM

I don't use the tool from EVGA, MSI Afterburner, and Riva Tuner. Some very very old games that I some times play do leave my clock rate in 2D mode but they are old. I don't know enough about your game so I'll leave it at that. By the way why don't you upgrade your ram a little bit? Another 1GB stick to make 3GB after replacing the 512mb?
Anonymous
a b U Graphics card
January 28, 2011 7:45:46 AM

I have only 100 AED ($27) left, I just spend all my money on a GT 240, and I'm running a Pentium D 925, would the upgrade actually make a difference?

I'm actually happy with the my config, although the PD is soooo old and people said that I couldn't run the latest games at low settings it all turned out wrong; nonsense I run Fallout: New Vegas at high settings by default and a resolution of 1680 by 1050 with 20-60 (average 30) fps , my monitor refresh rate is 60Hz.
Fallout: New Vegas is not even 6 months old!

People were saying that I could run 2007-2008 games at medium-low, but I run HAWX at the absolute highest max settings at 1680 by 1050, everything max and 8x AA, frame rate 20-105 (Fraps records 60 because it's the max of my monitor) average 45 fps.

I also max out modern warfare 1, everything highest with an average frame rate of
30.

If I can run a 2010 games on High then why upgrade, I have a PS3 and no money to buy PC games left, I thought of downloading but... it's just garbage with viruses no online and it's theft.
Anonymous
a b U Graphics card
January 28, 2011 7:52:21 AM

I just need to find out ow to disable these profiles and keep it running at 550/790/1340MHz. It continuously switches between all three profiles making the frame rate go up and down.

If there is no solution then I think that I'll just forget it because I don't play that game much, just wait for someone who knows how to disable this feature to post, I'm not in a hurry so just keep this post active till we get an answer because this really is something that could cause problems in other apps and games that require different amounts of graphics processing power that change continuously and switching between different clock rates would cause performance issues.
a c 153 U Graphics card
January 28, 2011 8:41:04 AM

I had this problem with my GTX 260, just turn off the feature in the nVidia control that saves power. Change "power management mode" from Adaptive, to prefer Maximum performance. It will be under "Manage 3D settings" in the control panal.

After you save and exit, restart the PC and see if that works.

If that doesn't work download MSI Afterburner and keep your own profiles.
!