Sign in with
Sign up | Sign in
Your question

ASUSabertooth P67 woes

Last response: in Motherboards
Share
March 1, 2012 6:05:02 PM

I just spent the better part of two days trying to get my brand new Sabertooth P67 to work, to no avail. This is what's inside it:

-ASUS Sabertooth P67 Rev 3.0
-Corsair XMS3 8gb DDR3 1600 9-9-9-24
-Intel Ci5-2500k
-Hitachi 1tB SATA drive
-generic optical drive
-Coolermaster GX 750W PSU
-Nvidia GTX 570 SC
-Coolermaster Hyper 212 plus heatsink

I bought the RAM, mobo, and CPU brand new yesterday. I went home, everything installed fine, and then I ran into a hitch. The motherboard will not post. Everything turns on, but the CPU_LED light comes on and then stays on. Nothing but black on the monitor. At first, the computer would start, shut off, then restart by itself. I realized that I had not plugged in the 4/8 pin power plug and corrected that mistake, but the motherboard just goes straight to the CPU_LED light. Here are all the fixes I tried so far:

-Quadruple checked all plugs to make sure they were snug.
-Tried booting with one stick of RAM in all four slots. I even tried booting with no RAM at all, the motherboard won't even get to the stage of testing the RAM. The MemOK function turns the computer off, restarts, then the DRAM_LED just blinks forever.
-Removed and reinstalled all components.
-Removed CM heatsink. I thought the base of the heatsink could be touching the opposite case wall and causing a short, so I put in the one that came with the CPU. No dice.
-Removed all components one by one to see if it would boot. First USB and audio, then GPU, then RAM. Nothing.
-Reset CMOS several times.
-Checked to see if there were any loose screws or wires under the mobo. Nope.
-Wiped off excess thermal grease.

I am at a total loss. I know the GPU, hard drive, optical drive, and PSU are good to go because I have been using them for several months now trouble free (bought brand new). Just to double check, I put my old rig back together, and no problems. So I believe the issue is with either the motherboard or CPU. That, and the constant on of the CPU_LED isn't helping. I did note, however, that when I was reinstalling the CPU, some of the pins in the mobo socket were bent. I believe that happened during the installation of the CM heatsink. Could that be causing the issue? Am I missing anything else here, or should I just send it back to ASUS for warranty?

More about : asusabertooth p67 woes

!