Sign in with
Sign up | Sign in
Your question

Problem with Tritton AX pro and Asus P5Q Pro on board sound

Tags:
  • Sound Cards
  • Asus
  • Components
Last response: in Components
Share
July 1, 2011 9:32:52 AM

Hey there, can anybody help or give me some ideas to try?

My old headset packed up so i decided to invest in a set of tritton AXpro's. I connected the analogue jacks to the correct connectors on the back of my P5Q motherboard, went into sound settings (win7) and changed to 5.1 sound. Sounds was stereo only although mic worked well. I wasnt able to change the sound to 5.1 in settings.

Solution: I downloaded the latest drivers from asus (released in 2009) for the on board sound.
I did seem to then be able to change the sound to 5.1 in settings and after removeing and reconnecting the jacks all the channels now work! Hurrah!!!!!

However, I still have 2 very annoying issues. With the new drivers my mic now feeds back through the headphones which I find really annoying. I know this is a personal preferance thing but all reviews say that these headphones do NOT do this so I fear it is an issue perhaps linked to my problem 2: TERRIBLE HISS!!!!! By turning everything up to full and my headphones down I can reduce it a little but the sound is still terrible.
...I dont know what to do next :S and would really appreciate some suggestions.

Thanks
Firefly

More about : problem tritton pro asus p5q pro board sound

a b Ĉ ASUS
July 1, 2011 2:49:00 PM

1: The headphone is probably playing back whatever it picks up into the headset; that could also explain the hiss. There should be a setting you can disable for the mic in the sound section of the windows control panel that will disable mic playback. Alternativly, you can mute the mic.

2: Ditch the ASUS sound drivers, and get the latest realtek ones. No reason why 5.1 analog should be disabled...
July 2, 2011 2:15:17 PM

thanks for the tips. I turned the microphone right down in the speaker settings and that has solved my problem. All hiss has gone and cant hear myself anymore through my headphones which i MUCH prefer :)  thx
!