Gigabit network only at 100

Ok, here's the deal. I have two NAS hard drives for remote file storage. I've got several systems attached in the network as well. I'm using Cat-5e cables everywhere, none are longer than 10 feet in length. Every computer in the network has a gigabit network connection (on MB, not PCI). the two NAS devices are gigabit (Jumbo frames turned off). the switch is a gigabit switch, and the router in use is a Linksys WRT610N gigabit router. Basically the Router connects to the switch, then all of the systems are plugged into the switch. All gigabit lights are up so I know there is NO 100 megabit device on the network. All devices also show that they are using gigabit bandwidth.

Now we know that the main limiting factor is the speed of the hard drives. I can copy from one drive to another with an average transfer rate of 56MB/second.

When I push files up to the NAS, the MAX speed I am able to achieve is around 10MB/second. When I pull files down from the NAS, the MAX is 15MB/second.

I get the same responses on all the computers, the Operating systems vasy form Vista 32-Win7 32-Win7 64-bit. What can I do to get the network speeds up from what I had with the previously used 100MB network? Everything is upgraded, but nothing has changed as far as transfer speed. I would realistically expect to get something closer to 35 or 40MB/second on this network.
6 answers Last reply
More about gigabit network
  1. I'd try to isolate what is causing the slowdown.

    1) a particular device
    2) a bad cable
    3) some kind of software or protocol overhead

    things to try:
    1) connect 2 devices directly, via crossover, or 2 devices alone connected to the switch (no router attached)
    2) different protocol, such as FTP, to test speeds
  2. Sounds like the caching on the NAS drives is limited. What are the read/write on the drives anyhow?
  3. I tried a direct connection, still getting the same speeds. I also tried finding the read/write speed on the NAS drives but can't locate it in any of the technical data. All I found was that each device has Two (2) 500GB 7200 RPM PATA Hard Drives (8MB cache each), and the controller has a 64MB cache.
  4. PATA? Yeah, you're not going to get the speeds. SATA drives would improve your speeds.

    You can download a disk write/read program to see what you would get under best circumstances. Then compare that to what you're getting over the network and you'll see if the network or the drives are the culprit.
  5. Can you test the file copy speed from computer to computer instead of to the NAS? That will let you know if it's a data transfer speed from drive to network or the NAS.
  6. I have the same issue. So I hope to get the answer as much as thread owner. So please let me share my situation for your reference.

    My system has a Buffalo LS-QVL NAS, a Clientron 3820 PC running Windows 10 Technical Preview attached to Orico 6538 USB HDD dock, which all have gigabit NIC connecting to TP-Link TL-SG1008D gigabit switch via Buffalo CAT6 2 meter patch code. The HDD in NAS and Orico is WD Red 3TB. The theoretical speed should be limited by USB 2.0 speed only, which I tested on my system is about 34MBps. When I copy files from HDD on Orico to NAS, the maximum speed is only 26MBps. When I use a Fast Ethernet router previously, the speed is about 11.3MBps, which is about 90% of theoretical speed.
    Is there any way to fine tune my system? I am moving 3TB of data each time so an increase in speed is very important.
    Thank you very much.
Ask a new question

Read More

LAN NAS / RAID Switch Networking