PCI speed x8 after put to sleep

I am running a Asus P6x58d MB with two 5870 in Xcrossfire (10.7 Driver). I am having a problem with the Bus Interface speed on my first PCI slot going to x8 after I put my computer to sleep over night. The second PCI slot seems to always be at x16. If I restart the computer it returns to x16 and stays there till I put the computer to sleep again. I am using GPU-Z and CPU-Z and they are both showing x8.

Yesterday I changed my Power Option Plan to High performance and under the Link State Management I made sure it was set to off. I don't believe my MB has any power saver features. The only thing i can find has to do with PCI slots 2 and 3 are the Link Width speed (auto, x8 x8, x16 x1).

It was doing this before I added the second 5870 so that did not cause the problem. Any ideas?

thanks,
5 answers Last reply
More about speed sleep
  1. You may have to go into the BIOS and force those slots to run at x16 x16 mode.
  2. I don't believe I can do anything directly with the #1 slot, just 2 and 3. Unless If i select x16 x1, for the #2 and #3 slots, wouldn't that force #1 slot to x16?
  3. Judging by the fact that slot 1 has no direct control settings, it's default is always x16. It may be an idea to put your cards in slots 1 and 2 (if you haven't already) and to force slot two to x16 mode.

    By the way, the real world performance difference between x16 and x8 is about 4% so you're hardly going to see a huge difference in games.
  4. Yeah they are in 1 and 2 and forcing #2 to x16 was what I was thinking.

    No there isn't much of a difference between x8 and x16, i'd just like to know why it's doing it. Things like that drive me nuts.
  5. Yeah it would get to me as well, but it's good to know that it's not massively affecting your system should it be an incurable thing.
Ask a new question

Read More

Graphics Cards PCI Computer Graphics