Sign in with
Sign up | Sign in
Your question
Solved

Unable to install StarCraft 2

Last response: in Networking
Share
July 27, 2010 9:05:37 PM

I am having some technical issues in the process of downloading the game. When I click install the error message "unable to connect" pops up, but I do have internet access. I turned off my window firewalls too, but I noticed I also have Mcafee turned on even though it is no where to be found under program files or anywhere for that matter. Therefore, I have a feeling that is the cause of stopping me from installing the game. Also, I tried opening all the ports the SC2 tech support site said to have open for the game. Also, I found on another forum a person who seems to have the same problem as me, and he said the solution was;

"All i had to do was delete something in hjack this, The read below mine did the same thing to fix his problem. For anyone else running vista having these problems just delete R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyServer = http=127.0.0.1:5555."

However, I have no idea where or what that is to be deleted. Can someone please help me find my issue, or direct me where to find what to delete.
Anonymous
July 27, 2010 9:39:13 PM

I'm having this same problem. I try to install the game and I get unable to connect error. I'm connected to the internet and i turned off my firewall, but still it will not let me install the game. Any ideas?
m
0
l
July 28, 2010 12:18:46 AM

I was just having trouble installing the game from the storebought copy and have found that it is possible to authenticate by just clicking the little orange triangle in the bottom right of the launcher. When the pop-up box opens, follow the link. Then, copy and paste the key in the body of the page it takes you to into the box for the authentication key (NOT THE KEY ON YOUR BOOKLET). This should allow the game to install.
m
0
l
Related resources
Anonymous
July 28, 2010 6:30:29 PM

Im having this same issue however, yes you can install the game using the little triangle but after the game gets installed it requires patching to play. My store copy just gets into a little infinate loop of telling me i need to patch and then restarting because starcraft 2 does not recognize my internet. I can get online fine and play other games however starcraft 2 keeps telling me i am unable to connect. I've turned off all firewalls and even tried removing the router out of my situation entirely and plugging my desktop directly into my cable internet modem. Still no go... if anyone out there has my problem or a solution please post. I've been waiting for this game for like 10 years and i would really like to play now. :cry: 
m
0
l
July 29, 2010 1:25:49 PM

Quote:
"All i had to do was delete something in hjack this, The read below mine did the same thing to fix his problem. For anyone else running vista having these problems just delete R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyServer = http=127.0.0.1:5555. However, I have no idea where or what that is to be deleted"


Go to start -> run - > regedit
Expand HKEY_CURRENT_USER -> Software -> Microsoft -> Windows -> CurrentVersion -> InternetSettings and delete the entry ProxyServer with that value.

Thats how you would delete it. Haven't needed to use that so don't know what it will do.

m
0
l
Anonymous
July 29, 2010 7:56:12 PM

Just worked for me.

Big thanks! (I am on windows 7 fyi)
m
0
l

Best solution

July 29, 2010 10:50:04 PM

go to Internet Explorer -> File, then make sure Work Offline isn't checked. Also check Internet Explorer -> Tools -> Internet Options -> Connection -> LAN Settings and make sure your proxy information is correct. If you don't use a proxy, make sure that everything is unchecked and hit OK. If that doesn't work, go back there and try toggling your Automatically detect settings box, then hit OK. Try the game again. If you're running Windows Vista or Windows 7, you may have to right-click the game and start it up as an administrator to get write access.

The above fix worked for me, if you have any questions about it, let me know.
Share
August 19, 2010 6:44:24 PM

^^ This worked for me. Thanks jayjr.
m
0
l
October 25, 2010 2:11:10 PM

Best answer selected by l6iudiciani.
m
0
l
!