Sign in with
Sign up | Sign in
Your question

Server 2008 Raid 5 Setup Problem

Last response: in Components
Share
July 2, 2011 11:06:24 AM

Hi,

I'm using disk management to set up raid 5 across 5 disks. The options I use are: File compression, Quick Format and using the maximum space possible. (There is nothing but unallocated space on the 5 drives).

Unfortunately during the Resyncing stage, it always fails, at leaves a screen showing "At risk" for the array and error yellow triangles on the disks.

Cant find anything in the event viewer that explains the problem other than this; which occurred while it was resyncing.

(Warning message) The system failed to flush data to the transaction log. Corruption may occur. Source volmgr, Event ID = 57. It says in the details it relates to \Device\HarddiskVolume10. How do I know which one this is? There is no disk 10 in disk management.

A lot of people say this error relates to using ReadyBoost, however I am not using this and there is no USB stick attached to the system. I have enabled write caching and advanced performance on the system drive (which is an SSD) but I dont see how this relates to readyBoost and its not anything to do with the RAID 5 setup anyway.

Thanks if you can shed some light on this.

More about : server 2008 raid setup problem

July 2, 2011 11:47:56 AM

Edit: Sorry I am not sure this error actually happened during the initial Raid 5 setup. It was close to when I started so I cant really tell. Are there logs to show when you try and create a software Raid 5 array? Right now i am running check disk on the whole (failed) thing with scan for and attempt recovery of bad sectors.
July 2, 2011 5:45:51 PM

Ok right now im using some DOS software provided by SAMSUNG for their HDD's called ESTool to verify each disk is working 100%. It is going to take days. It does all sorts, like smart check, read surface scan etc etc. I'm doing this more out of desperation because I don't have any ideas what could be wrong.

The hard drives are Samsung F4EG (HD204UI). I have updated the firmware on all of them to the most recent version. There are two Sata Expansion PCI cards from Silicon Image which host all the drives. The motherboard Sata was giving me worse issues (resolved) so I had to purchase two.

Please if you have any ideas post because I think all the actual drives are fine, there has never been anything in event viewer to indicate otherwise. The volmgr warning "The system failed to flush data to the transaction log." is the only pointer i have when i last tried creating the raid 5 volume.
July 2, 2011 11:13:22 PM

Ended up running the ESTool with every check apart from "disk surface scan" because it adds hours and hours to the test and is optional - all disks pass. Just tried again to create the volume but it failed around the 8% mark. There are no errors or warnings in Event Viewer now to indicate why this is happening.
!