Sign in with
Sign up | Sign in
Your question

Logitech g110 + usb mouse problem

Last response: in Systems
Share
April 1, 2011 1:48:33 AM

Hello everyone, I didnt know where to post this so sorry if this is in the wrong forum.

I just recently got a new keyboard g110, my mouse is a razer copperhead used for about 3-4 years. The problem is that if i plug both devices into the usb in the back, the computer will not load into windows. It just freezes where it is suppose to detect the harddrive etc...

So i decided to remove the usb mouse (keyboard still plugged in) and now, the computer works perfectly and loads into windows. So my question is that my mouse corrupted? My mouse works perfectly when plugged in during windows and no problems occur. Is there a problem with my mobo, mouse, or power supply? Thank You so much in advance.

My specs
i5 750
OCZ 800W psu stealthxstream
Geforce GTX460 768mb
gskill 2x2 1600
Samsung f3 500gb
gigabyte p55m ud4
April 1, 2011 1:58:10 AM

have you tried other usb slots?
m
0
l
April 1, 2011 2:04:58 AM

yeah i tried all usb slots in the tower including front ports, its strange because when I plug the mouse into the keyboard's usb, it works and thats how the setup is as of now...
m
0
l
Related resources
a b B Homebuilt system
April 1, 2011 5:47:46 PM

If I read this right, you used to have the old keyboard and your mouse separately plugged into rear USB ports. Now, with your new keyboard done that way, the machine can't boot, and it locks up somewhere around dealing with your hard drive. However, if you plug the mouse into the new keyboard's port, it works OK.

I suspect what is going on is that the new keyboard takes control of mouse functions, and the driver for it (now loading automatically from the hard drive early in the boot sequence) is causing some conflict. It insists on sending mouse info to Windows. IF you keep the mouse plugged into the rear port as before, the new system probably is telling Windows it is has no mouse while the BIOS is sending different mouse info at the same time! However, when you let ONLY the keyboard deal with the mouse, there is no confusion and it is all happy. So keep doing it that way.
m
0
l
a b B Homebuilt system
April 1, 2011 7:49:22 PM

It may be an boot order error in your BIOS. Boot into BIOS and make sure that it is indeed trying to boot to your Windows drive first and not a "Removable USB Device." Sometimes that happens with my mice/keyboards/external hard drives/smartphones/etc. (had it happen with pretty much anything).
m
0
l
April 1, 2011 9:43:38 PM

If I read this right(and understand you). Your saying mouse + keyboard=no windows. I'm guessing that you're confusing the issue by even mentioning the hard drive....you're locking up when bios is in the recognize hardware phase...not nescessarily when it's on the hd itself. A quick easy fix would be to get a legacy adapter for the usb mouse and plug it in that way. It's safe to say it's not your mobo your mouse or your psu. It's in your bios. I'm not familiar with your bios offhand but I would be looking for an option to select a usb mouse and a usb keyboard. (was your old kb legacy?) The g110 has usb onboard usb have you tried plugging the mouse into the kb and then booting? Most likely here is a bios issue or a driver conflict.
m
0
l
April 1, 2011 10:04:02 PM

yeah i plug the usb mouse (razercopperhead) into the keyboard which loads to windows successfully. (which is the current setup)

When I plug the usb mouse anywhere on the tower, the system fails to load and freezes up at the post screen.

I also disabled all boot orders except the HD so that shouldn't be a problem as well.
m
0
l
April 1, 2011 10:10:47 PM

Best guess is a driver conflict I read somewhere(so sorry I don't recall where) the g110 "announces"during boot that it is actually not only the kb but the mouse AND a usb audio device. You've narrowed the search evn further GOOD JOB! Sadly now that we know what's causing it I don't know the solution...the best advice I can give is to hit logitech's forums. Barring that....I'd just keep the mouse on the kb usb until you get a definitive solution.
m
0
l
April 2, 2011 3:34:49 PM

Well, I googled it and found out that logitech g110 and gigabyte / asus boards have this problem. Since I was using my gigabyte board I just updated BIOS and now everything runs fine and dandy so anyone else having this problem, update your BIOS and see. Thank You all for the responses!
m
0
l
a b B Homebuilt system
April 2, 2011 6:02:14 PM

Glad to hear you found the best solution!
m
0
l
!