Sign in with
Sign up | Sign in
Your question

OpenGL 2.1 Fails to Render on ATI Radeon HD 5870

Last response: in Graphics & Displays
Share
January 30, 2011 1:05:34 AM

Sometime in late December, 2010, I noticed that my N64 emulator stopped running. I tried other N64 emulators, and they all failed to run.

I tried re-installing my video driver, and reverting to an older video driver version as well, but that didn't work.

I tried system restore, but even the oldest restore point still exhibited the same behavior.

I tried to boot clean using MSConfig. The N64 emulator still failed to run.

I then noticed that other things that used to run would no longer run, such as Quake, Quake III [Team] Arena, and others.

I tried to run Unreal Tournament 2004. I have two versions installed. One is the standalone version, and the other is a version installed through Steam. My standalone version is configured to render using Direct3D. It runs fine. When I try to run the Steam version, it does nothing. That is, I can monitor it through the task manager. It shows up in the list of processes for a few seconds, then goes away, with no indication of why it failed. I suspect it is trying to render in OpenGL, but Steam didn't install a safe mode shortcut for it, so I can't run the program to change the video mode. I'm sure I could use the .ini from my working version to cobble up a working .ini for the Steam version, but that's not what I'm trying to solve here.

With Quake III, the game attempts to change the video mode when first launching, before any title or cinematic is displayed, but I get a Windows message that the application stopped working, and that Windows attempts to find a solution for the problem (which it never does find). The application leaves my desktop color washed out, probably with the settings that would have been used to render the Quake environment.

Games that don't run, but used to a few months ago:
- Quake I
- Quake II
- Quake III [Team] Arena
- All N64 emulators

Games that have never worked since I bought them after my system problems (all through Steam):
- Oddworld: Abe's Exoddus
- Oddworld: Abe's Oddysee
- Oddworld: Munch's Oddysee
- Oddworld: Stranger's Wrath

Games that DO run:
- Unreal Tournament 3
- Left 4 Dead
- Left 4 Dead 2
- Nail'd
- The Ball
- Just Cause 2

I ran GPU Caps Viewer 1.9.5. Most GL 2.1 demos fail, causing the GPU Caps Viewer application to crash, but some of the 2.1 demos actually begin to run for a short while before crashing. If I immediately re-run the utility and launch the same demo, it will fail immediately without rendering any frames.

Here is a list of GL demos that run fine:
- GL 4.x - Tessellation
- GL 3.x - Illuminated Torus
- GL 3.x - Triangle of Death
- GL 2.1 - Vertex Displacement Mapping
- GL 2.1 - CEL-SHADING
- GL 1.2 - Simple Mesh

Here is a list of GL demos that crash
(* = have observed the demo render something sometimes before crashing):
- GL 2.1 - Furry Cube *
- GL 2.1 - HDR, DoF and RadialBlur
- GL 2.1 - HW Geometry Instancing *
- GL 2.1 - Soft Shadows
- GL 2.1 - GLSL Point Sprite Particles *

This is my system:
- ASUS Striker Extreme Motherboard
- Intel Core2 Quad CPU
- 4 Gig RAM
- Windows 7 64-bit Professional
- 2 WD 1TB Black SATA Drives
- ATI Radeon HD 5870
+ Catalyst Control Center V. 2011.004.2155.39304
+ Driver Packaging V. 8.812-110104a-111988C-ATI
+ Catalyst Version 10.12
+ 2D Driver Version 8.01.01.1114
+ Direct3D Version 7.14.10.0806
+ OpenGL Version 6.14.10.10428

-------- Start of HijackThis Log --------

Logfile of Trend Micro HijackThis v2.0.4
Scan saved at 6:23:16 PM, on 1/29/2011
Platform: Windows 7 (WinNT 6.00.3504)
MSIE: Internet Explorer v8.00 (8.00.7600.16700)
Boot mode: Normal

Running processes:
C:\Program Files (x86)\SlySoft\AnyDVD\AnyDVDtray.exe
C:\Program Files (x86)\Steam\steam.exe
C:\Program Files (x86)\DAEMON Tools Pro\DTAgent.exe
C:\Program Files (x86)\CyberPower PowerPanel Business Edition\bin\ppbeuser.exe
C:\Program Files (x86)\Adobe\Acrobat 9.0\Acrobat\acrotray.exe
C:\Program Files (x86)\Razer\Lachesis\razerhid.exe
C:\Program Files (x86)\Razer\Lachesis\OSD.exe
C:\Program Files (x86)\Carbonite\Carbonite Backup\CarboniteUI.exe
C:\Program Files (x86)\SlySoft\CloneCD\CloneCDTray.exe
C:\Windows\SysWOW64\Ctxfihlp.exe
C:\Program Files (x86)\Razer\Lachesis\razertra.exe
C:\Program Files (x86)\Razer\Lachesis\razerofa.exe
C:\Windows\SysWOW64\CTXFISPI.EXE
C:\Program Files (x86)\Common Files\Realtime Soft\RTSHookInterop\x32\RTSHookInterop.exe
C:\Program Files (x86)\DAEMON Tools Pro\DTShellHlp.exe
C:\Program Files (x86)\Mozilla Firefox\firefox.exe
C:\Program Files (x86)\Mozilla Firefox\plugin-container.exe
\buffalo\pub\utils\HijackThis\HijackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://refdesk.com/
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Local Page = C:\Windows\SysWOW64\blank.htm
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =
F2 - REG:system.ini: UserInit=userinit.exe
O2 - BHO: ContributeBHO Class - {074C1DC5-9320-4A9A-947D-C042949C6216} - C:\Program Files (x86)\Adobe\/Adobe Contribute CS4/contributeieplugin.dll
O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll
O2 - BHO: Groove GFS Browser Helper - {72853161-30C5-4D22-B7F9-0BBC1D38A37E} - C:\PROGRA~2\MICROS~1\Office14\GROOVEEX.DLL
O2 - BHO: Windows Live ID Sign-in Helper - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll
O2 - BHO: Adobe PDF Conversion Toolbar Helper - {AE7CD045-E861-484f-8273-0445EE161910} - C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll
O2 - BHO: URLRedirectionBHO - {B4F3A835-0E21-4959-BA22-42B3008E02FF} - C:\PROGRA~2\MICROS~1\Office14\URLREDIR.DLL
O2 - BHO: Java(tm) Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files (x86)\Java\jre6\bin\jp2ssv.dll
O2 - BHO: SmartSelect - {F4971EE7-DAA0-4053-9964-665D8EE6A077} - C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll
O3 - Toolbar: Adobe PDF - {47833539-D0C5-4125-9FA8-0819E2EAAC93} - C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll
O3 - Toolbar: Contribute Toolbar - {517BDDE4-E3A7-4570-B21E-2B52B6139FC7} - C:\Program Files (x86)\Adobe\/Adobe Contribute CS4/contributeieplugin.dll
O4 - HKLM\..\Run: [ppbeuser] C:\Program Files (x86)\CyberPower PowerPanel Business Edition\bin\ppbeuser.exe
O4 - HKLM\..\Run: [AdobeCS4ServiceManager] "C:\Program Files (x86)\Common Files\Adobe\CS4ServiceManager\CS4ServiceManager.exe" -launchedbylogin
O4 - HKLM\..\Run: [Adobe Acrobat Speed Launcher] "C:\Program Files (x86)\Adobe\Acrobat 9.0\Acrobat\Acrobat_sl.exe"
O4 - HKLM\..\Run: [Acrobat Assistant 8.0] "C:\Program Files (x86)\Adobe\Acrobat 9.0\Acrobat\Acrotray.exe"
O4 - HKLM\..\Run: [Lachesis] C:\Program Files (x86)\Razer\Lachesis\razerhid.exe
O4 - HKLM\..\Run: [BCSSync] "C:\Program Files (x86)\Microsoft Office\Office14\BCSSync.exe" /DelayServices
O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files (x86)\Adobe\Reader 9.0\Reader\Reader_sl.exe"
O4 - HKLM\..\Run: [Adobe ARM] "C:\Program Files (x86)\Common Files\Adobe\ARM\1.0\AdobeARM.exe"
O4 - HKLM\..\Run: [Carbonite Backup] C:\Program Files (x86)\Carbonite\Carbonite Backup\CarboniteUI.exe
O4 - HKLM\..\Run: [VirtualCloneDrive] "C:\Program Files (x86)\Elaborate Bytes\VirtualCloneDrive\VCDDaemon.exe" /s
O4 - HKLM\..\Run: [CloneCDTray] "C:\Program Files (x86)\SlySoft\CloneCD\CloneCDTray.exe" /s
O4 - HKLM\..\Run: [CTxfiHlp] CTXFIHLP.EXE
O4 - HKLM\..\Run: [StartCCC] "C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static\CLIStart.exe" MSRun
O4 - HKCU\..\Run: [AnyDVD] C:\Program Files (x86)\SlySoft\AnyDVD\AnyDVDtray.exe
O4 - HKCU\..\Run: [Steam] "C:\Program Files (x86)\Steam\steam.exe" -silent
O4 - HKCU\..\Run: [DAEMON Tools Pro Agent] "C:\Program Files (x86)\DAEMON Tools Pro\DTAgent.exe" -autorun
O4 - HKUS\S-1-5-19\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /autoRun (User 'LOCAL SERVICE')
O4 - HKUS\S-1-5-19\..\RunOnce: [mctadmin] C:\Windows\System32\mctadmin.exe (User 'LOCAL SERVICE')
O4 - HKUS\S-1-5-20\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /autoRun (User 'NETWORK SERVICE')
O4 - HKUS\S-1-5-20\..\RunOnce: [mctadmin] C:\Windows\System32\mctadmin.exe (User 'NETWORK SERVICE')
O4 - HKUS\S-1-5-18\..\Run: [CtxfiReg] CTXFIREG.exe /FAIL2 (User 'SYSTEM')
O4 - HKUS\.DEFAULT\..\Run: [CtxfiReg] CTXFIREG.exe /FAIL2 (User 'Default user')
O4 - Global Startup: UltraMon.lnk = ?
O8 - Extra context menu item: Append Link Target to Existing PDF - res://C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll/AcroIEAppendSelLinks.html
O8 - Extra context menu item: Append to Existing PDF - res://C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll/AcroIEAppend.html
O8 - Extra context menu item: Convert Link Target to Adobe PDF - res://C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll/AcroIECaptureSelLinks.html
O8 - Extra context menu item: Convert to Adobe PDF - res://C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX\AcroIEFavClient.dll/AcroIECapture.html
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~2\MICROS~1\Office14\EXCEL.EXE/3000
O8 - Extra context menu item: Se&nd to OneNote - res://C:\PROGRA~2\MICROS~1\Office14\ONBttnIE.dll/105
O9 - Extra button: Send to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\Program Files (x86)\Microsoft Office\Office14\ONBttnIE.dll
O9 - Extra 'Tools' menuitem: Se&nd to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\Program Files (x86)\Microsoft Office\Office14\ONBttnIE.dll
O9 - Extra button: OneNote Lin&ked Notes - {789FE86F-6FC4-46A1-9849-EDE0DB0C95CA} - C:\Program Files (x86)\Microsoft Office\Office14\ONBttnIELinkedNotes.dll
O9 - Extra 'Tools' menuitem: OneNote Lin&ked Notes - {789FE86F-6FC4-46A1-9849-EDE0DB0C95CA} - C:\Program Files (x86)\Microsoft Office\Office14\ONBttnIELinkedNotes.dll
O10 - Unknown file in Winsock LSP: c:\program files (x86)\common files\microsoft shared\windows live\wlidnsp.dll
O10 - Unknown file in Winsock LSP: c:\program files (x86)\common files\microsoft shared\windows live\wlidnsp.dll
O16 - DPF: {D4B68B83-8710-488B-A692-D74B50BA558E} (Creative Software AutoUpdate Support Package) - http://ccfiles.creative.com/Web/softwareupdate/ocx/1511...
O16 - DPF: {F6ACF75C-C32C-447B-9BEF-46B766368D29} (Creative Software AutoUpdate Support Package) - http://ccfiles.creative.com/Web/softwareupdate/ocx/1511...
O17 - HKLM\System\CCS\Services\Tcpip\..\{CD80014C-7073-4EE7-92BC-B981EEA36ECA}: NameServer = 209.18.47.61,209.18.47.62
O18 - Protocol: wlpg - {E43EF6CD-A37A-4A9B-9E6F-83F89B8E6324} - C:\Program Files (x86)\Windows Live\Photo Gallery\AlbumDownloadProtocolHandler.dll
O18 - Filter hijack: text/xml - {807573E5-5146-11D5-A672-00B0D022E945} - C:\Program Files (x86)\Common Files\Microsoft Shared\OFFICE14\MSOXMLMF.DLL
O23 - Service: @%SystemRoot%\system32\Alg.exe,-112 (ALG) - Unknown owner - C:\Windows\System32\alg.exe (file missing)
O23 - Service: AMD External Events Utility - Unknown owner - C:\Windows\system32\atiesrxx.exe (file missing)
O23 - Service: CarboniteService - Carbonite, Inc. (www.carbonite.com) - C:\Program Files\Carbonite\Carbonite Backup\carboniteservice.exe
O23 - Service: Creative ALchemy AL6 Licensing Service - Creative Labs - C:\Program Files (x86)\Common Files\Creative Labs Shared\Service\AL6Licensing.exe
O23 - Service: Creative Audio Engine Licensing Service - Creative Labs - C:\Program Files (x86)\Common Files\Creative Labs Shared\Service\CTAELicensing.exe
O23 - Service: Creative Audio Service (CTAudSvcService) - Creative Technology Ltd - C:\Program Files (x86)\Creative\Shared Files\CTAudSvc.exe
O23 - Service: @%SystemRoot%\system32\efssvc.dll,-100 (EFS) - Unknown owner - C:\Windows\System32\lsass.exe (file missing)
O23 - Service: ESET HTTP Server (EhttpSrv) - ESET - C:\Program Files\ESET\ESET Smart Security\EHttpSrv.exe
O23 - Service: ESET Service (ekrn) - ESET - C:\Program Files\ESET\ESET Smart Security\x86\ekrn.exe
O23 - Service: @%systemroot%\system32\fxsresm.dll,-118 (Fax) - Unknown owner - C:\Windows\system32\fxssvc.exe (file missing)
O23 - Service: FLEXnet Licensing Service - Acresso Software Inc. - C:\Program Files (x86)\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService.exe
O23 - Service: FLEXnet Licensing Service 64 - Acresso Software Inc. - C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService64.exe
O23 - Service: Game Jackal Server (GJService) - Unknown owner - C:\Program Files (x86)\SlySoft\Game Jackal v4\Server.exe
O23 - Service: GoToMyPC - Citrix Online, a division of Citrix Systems, Inc. - C:\Program Files (x86)\Citrix\GoToMyPC\g2svc.exe
O23 - Service: @keyiso.dll,-100 (KeyIso) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @comres.dll,-2797 (MSDTC) - Unknown owner - C:\Windows\System32\msdtc.exe (file missing)
O23 - Service: @%SystemRoot%\System32\netlogon.dll,-102 (Netlogon) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: NVIDIA Display Driver Service (nvsvc) - Unknown owner - C:\Windows\system32\nvvsvc.exe (file missing)
O23 - Service: PowerPanel Business Edition Service (ppbed) - Cyber Power Systems, Inc. - C:\Program Files (x86)\CyberPower PowerPanel Business Edition\bin\ppbed.exe
O23 - Service: @%systemroot%\system32\psbase.dll,-300 (ProtectedStorage) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @%systemroot%\system32\Locator.exe,-2 (RpcLocator) - Unknown owner - C:\Windows\system32\locator.exe (file missing)
O23 - Service: @%SystemRoot%\system32\samsrv.dll,-1 (SamSs) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @%SystemRoot%\system32\snmptrap.exe,-3 (SNMPTRAP) - Unknown owner - C:\Windows\System32\snmptrap.exe (file missing)
O23 - Service: @%systemroot%\system32\spoolsv.exe,-1 (Spooler) - Unknown owner - C:\Windows\System32\spoolsv.exe (file missing)
O23 - Service: @%SystemRoot%\system32\sppsvc.exe,-101 (sppsvc) - Unknown owner - C:\Windows\system32\sppsvc.exe (file missing)
O23 - Service: Steam Client Service - Valve Corporation - C:\Program Files (x86)\Common Files\Steam\SteamService.exe
O23 - Service: @%SystemRoot%\system32\ui0detect.exe,-101 (UI0Detect) - Unknown owner - C:\Windows\system32\UI0Detect.exe (file missing)
O23 - Service: @%SystemRoot%\system32\vaultsvc.dll,-1003 (VaultSvc) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @%SystemRoot%\system32\vds.exe,-100 (vds) - Unknown owner - C:\Windows\System32\vds.exe (file missing)
O23 - Service: @%systemroot%\system32\vssvc.exe,-102 (VSS) - Unknown owner - C:\Windows\system32\vssvc.exe (file missing)
O23 - Service: @%SystemRoot%\system32\Wat\WatUX.exe,-601 (WatAdminSvc) - Unknown owner - C:\Windows\system32\Wat\WatAdminSvc.exe (file missing)
O23 - Service: @%systemroot%\system32\wbengine.exe,-104 (wbengine) - Unknown owner - C:\Windows\system32\wbengine.exe (file missing)
O23 - Service: @%Systemroot%\system32\wbem\wmiapsrv.exe,-110 (wmiApSrv) - Unknown owner - C:\Windows\system32\wbem\WmiApSrv.exe (file missing)
O23 - Service: @%PROGRAMFILES%\Windows Media Player\wmpnetwk.exe,-101 (WMPNetworkSvc) - Unknown owner - C:\Program Files (x86)\Windows Media Player\wmpnetwk.exe (file missing)
O23 - Service: @%windir%\system32\inetsrv\iisres.dll,-20001 (WMSVC) - Unknown owner - C:\Windows\system32\inetsrv\wmsvc.exe (file missing)

--
End of file - 13048 bytes

--------- End of HijackThis Log ---------

I suspect the problem is GL-related, but I just don't know how to fix it, and how it got trashed in the first place. I can hardly stand the thought of reformatting and starting over, not to mention all of the pain and hassle having to ask Micro$oft for permission to run all of my purchased software, losing activations in the process.

Does anyone have any useful suggestions?

-Knobulous
January 30, 2011 2:08:14 AM

Download and install DriverSweeper (link is below). Then run it to completely remove your video drivers. Before doing that, however, cruise on over to ati.com and downloading the latest version.

After your system is clean, reinstall the latest ATI drivers to see if that solves the problem.

Good luck!

http://www.guru3d.com/index.php?page=driversweeper
m
0
l
February 4, 2011 5:10:05 AM

COLGeek, many thanks for the response.

I had high hopes for Driver Sweeper. It cleaned out my ATI driver, and I installed the latest driver dated January 26, 2011. However, there is no change to the odd behavior described above.

I'm wondering if the system got dorked up from a Steam game installation of some sort. At this point, unless there's some more troubleshooting advice, I will be stuck re-installing from scratch. Aaaarrgh!
m
0
l
Related resources
February 4, 2011 11:02:19 AM

It is possible that Steam dorked something. Have you considered uninstalling Steam, to be reinstalled later? Worth a shot if a full, clean install is in your future.
m
0
l
February 4, 2011 12:04:11 PM

No, i also had an ATi card and it failed to run older versions of OGL. I still play an old game called Starseige Tribes (released in 1999) and i had to ultimately shift to Nvidia coz of the crappy driver support for older OGL versions.
m
0
l
February 4, 2011 1:00:20 PM

sync_nine said:
No, i also had an ATi card and it failed to run older versions of OGL. I still play an old game called Starseige Tribes (released in 1999) and i had to ultimately shift to Nvidia coz of the crappy driver support for older OGL versions.

Odd how your experience and mine have been so different. I have been, primarily, an ATI user for MANY years and I have never had an OpenGL issue....zero. I do admit, that I have had zero problems with my Nvidia systems as well.

Still, the OP seems to have a specific problem that may be associated with Steam because games that used to play will no longer work. Something changed and determining that variable is the key here.
m
0
l
February 7, 2011 4:03:29 PM

I think it's likely that Steam, or an old game installed through Steam, is the culprit, but then uninstalling Steam may not necessarily put things back the way they were. I'm willing to give it a shot, though.

Is there a possibility that it is Glide that has been clobbered? If so, how would I go about fixing it given I've already re-installed the video driver from scratch?
m
0
l
February 7, 2011 4:17:38 PM

Have you tried uninstalling Steam yet? You will also want to run a registry cleaner like ccleaner (piriform.com/ccleaner) afterward to remove any orphans from your registry.

m
0
l
February 7, 2011 7:33:44 PM

Ran Piriform cleaner.
No change.
Uninstalled Steam.
No change.
Re-installed Steam.
Re-installed Quake II through Steam.
No change.

Still wondering about how Glide might play into the whole issue.
m
0
l
February 7, 2011 8:39:32 PM

Unless I am mistaken, GLIDE is installed as part of a driver or as part of a game/application establishing links for the GLIDE API. Logically, if you uninstall a well behaving application (incl. games) or driver, you would also remove GLIDE as well.

If your system is a possibly corrupted as yours may be, the only recourse for a stable install is to do a clean install of the OS and your apps.
m
0
l
February 8, 2011 1:24:46 AM

COLGeek, thanks for your responses. I appreciate the suggestions.

I have one more thing to try. I had replaced a set of nVIDIA SLI cards with my single Radeon 5800 about a year ago, but I think I will try to install at least one of the nVIDIAs to see if installation of its drivers will address the issue. My system tends to overheat, even though I have a Cooler Master case, and I'm not anxious about pushing it with two nVIDIAs, but maybe I'll start with one card just to see.
m
0
l
February 8, 2011 2:14:39 AM

Good luck. If your case supports a side fan (not already in use), that can lower GPU temps a great deal.
m
0
l
February 8, 2011 3:35:08 AM

It's got three huge 120x25mm fans, one on top, one in the front, and one on the side. It's a great case, and beats the Lian Li I had prior for ventilation. It's just that when I play games that really tax the video, after about half an hour or so, and depending on the ambient temperature, the system will just shut off.

I've got a 1200W PS, but the problem isn't the PS, and a humungous CPU heat sink/fan combo. It's got to be the temperature inside the case, and it seems that the stock cooling with the video card is not enough.

OK, so this was a little bit off topic.

I'll post what happens when I do re-install my nVIDIA.
m
0
l
February 8, 2011 11:04:45 AM

Sounds like you have an airflow problem. Things to check.

Front fan sucks cool air in.
Top fan sucks hot air out (exhaust).
Side fan sucks cool air in.
Rear fans (if applicable) suck hot air out (exhaust).

Make sure yours are configured this way. It shouldn't be that hot unless you have inadequate airflow and/or you OCing the heck out of your system.
m
0
l
February 8, 2011 1:33:46 PM

No OCing here. I tried that once, but when I used ATI's utility to auto adjust the clock rates, the video became horribly unstable, so I went back to plain vanilla.

The case is a Cooler Master, right off the shelf. It's supposed to have some of the best airflow in the industry. I thought about adding water cooling, but have never been able to justify the cost. I agree that with the proper airflow, there shouldn't be a problem with my rig.

While I have my system open during the video card swap, I may consider remounting the CPU fan with fresh thermal compound, just as a precaution. I will also verify the direction of airflow to be certain.
m
0
l
February 8, 2011 1:48:23 PM

Your CPU is likely fine. Your best bet is to look at airflow and any possible blockages you may have (like moving cables, especially flat ribbon cables, from in front of fans).
m
0
l
February 8, 2011 6:45:52 PM

Well, ATI does have a bit of a history with OGL drivers...could give 10.8 or 10.4 a try, as I know 10.4 especially worked well with my stock of OGL games...

Let us know if the NVIDIA card works.
m
0
l
February 9, 2011 3:45:48 AM

Just to be sure, I used Driver Sweeper to completely remove my ATI drivers. I then installed 10.4, mentioned as a stable version by gamerk316 (thanks for the suggestion). It unfortunately didn't fix the issue.

I'm now just waiting for the right time to dig into my system. It will likely be a couple of days from now.
m
0
l
February 9, 2011 10:57:52 AM

My only thought to add, is that some N64 emulators don't use OpenGL; I know for a fact Jabo's GPU plugin [Project64] uses Direct3d 7/8...That kind of points to another issue besides OpenGL...
m
0
l
February 12, 2011 3:51:48 AM

I installed my dual nVIDIA 7800GTX boards, and am disappointed in two ways. First, my Windows Experience graphics numbers dropped a couple of full points. Second, I still have the same problem trying to run various GL games and applications.

As for Jabo's GPU plugin, I've tried that as well, and it fails to render. But other Direct3D programs operate just fine.

Google Earth runs rendering in either Direct3D or OpenGL.

I'm afraid it's going to have to be a fresh install for me. I'm not making any headway. And my fear is that after I get a new installation running, I'll install something again through Steam and dork up the whole system again. In the future, though, I'll likely install one thing at a time, creating restore points prior to each install.

Thanks to all of you contributors who provided suggestions.
m
0
l
February 13, 2011 1:28:25 AM

As a follow-up, here I am with a fresh new Windows installation. I'm back on the ATI Radeon HD 5870 with the latest set of drivers and Catalyst Control Center, and I can now run all of the good ol' stuff I used to run (Quake*, Unreal*, N64 Emulators, etc.). I just hope that restore points can bail me out if my system takes a dump like it did before.

I'm seriously considering mirror imaging my drive as-is so I can get back to this point if I ever have to.
m
0
l
February 13, 2011 5:50:09 PM

Make a good backup, as you indicated, just in case. Good job getting the system back to normal.
m
0
l
February 20, 2011 12:27:54 AM

The system is working great...

But what I didn't expect was that the GPU Viewer test scenarios for OpenGL 2.1 still fail. I only downloaded and started using GPU Viewer when attempting to diagnose the failure to run some of the games, so when it was failing to run certain versions of OpenGL, I assumed it was part of the original problem.

I'm not so sure any more. These test cases in GPU Viewer still fail. They may never have run successfully. Should I even expect that they would run properly?

As it is, I mirrored my drive with my activated Windows, Office, etc., so if something happens to my system again, I can restore it bit-by-bit back to today.
m
0
l
February 21, 2011 12:37:44 AM

Good o have a backup. BTW, what specific tests are still failing with GPU Caps Viewer? I DL'd and installed in and am having no troubles in any of the OpenGL demos on my HD5850, Win7 x64, rig. Haven't played with it on any others yet. Just trying to replicate your experience. Will try my HD6870 rig (game rig) next.
m
0
l
!