Sign in with
Sign up | Sign in
Your question

ASRock P67 Extreme4 Gen3 AHCI Wont Boot

Last response: in Motherboards
Share
March 10, 2012 3:09:27 PM

As the title says, I cannot get this board to boot in AHCI mode. Well, let me clearify. With NO OS installed it will not boot my DVD drive or a USB flash drive. It boots strait to BIOS interface. Once in there I can exit without changes and then the DVD drive will start to load. If I exit with Changes it reboots and again strait into BIOS.

Moving on, booting in the unconventional way and went ahead and installe windows on my SSD and it still acts the same. Boots to bios, I exit without changes and the system boots windows.

I'm on the latest BIOS, it's acting as if the AHCI controller won't recognize any of my devices and bootable. Any help would be greatly appreciated and ASRock just keeps telling me to reinstall windows in AHCI mode when I'm already doing that.

One more thing, I've tried 2 different SSD's (one samsung one Corsair) and 2 different DVD's (one Lite-On one Pioneer).

Mobo: ASRock P67 Extreme4 Gen3
CPU: core i5-2500K
Video: MSI TwinFrozr 560ti 2GB VRAM
RAM: 2x4GB G.Skill Raptor X
PS: Silverstone 750W
SSD: Corsair Force GT 120GB
HDD: Seagate BaracudaGreen 2TB
DVD: Lite-On whatever was cheat at newegg
a b V Motherboard
March 10, 2012 4:39:48 PM

Did you try setting BIOS to ACHI mode, saving the config and then rebooting and going to BIOS to see if the ACHI mode held (withnout going to the OS)?

If ACHI mode won't stick I think that there could be a BIOS problem and y0ou might have to flash or reflash your BIOS.
m
0
l
March 10, 2012 9:32:24 PM

Thanks, yeah, it's in AHCI and it stays. Just wont boot.

It is a BIOS issue. I had to downgrade to 1.00 from 1.10 to get it to work. Go figure. May try to upgrade again and see what happens. Thanks for responding!
m
0
l
!