Solved

Asus p8z68-v: Mouse will not work under MS DOS

I have an Asus p8z68-V and cannnot get the mouse to work under MSDOS, regardless of the BIOS USB legacy OS setting.

Is this problem normal. Can anyone who has managed to get a USB mouse to work under MSDOS with this motherboard please reply. Asus have indicated it will not work under DOS and said it is normal and will not approve an RMA.

Thanking anyone in advance
20 answers Last reply Best Answer
More about asus p8z68 mouse work
  1. What are you running via MS-DOS on your system? Been a long time since I heard anyone ask such a question. I am not surprised by Asus' response given the new system and the old OS.
  2. COLGeek said:
    What are you running via MS-DOS on your system? Been a long time since I heard anyone ask such a question. I am not surprised by Asus' response given the new system and the old OS.


    I am running Acronis DiskDirector and Boot Magic. This allows me to keep my main partitions of windows XP Pro healthy by rejuvenating them from time to time. (Sorry about delay in replying)
  3. Are you using an older version of Acronis DiskDirector?
  4. Yes v10, Rescue version for running under dos. But why does it matter if asus states that it supports USB devices on legacy systems [os].
  5. It should work as long as the proper MS-DOS drivers are loaded. Are you booting from a CD/DVD when you run the application?
  6. COLGeek said:
    It should work as long as the proper MS-DOS drivers are loaded. Are you booting from a CD/DVD when you run the application?


    When I run this app I have it set up to run from a bootable USB stick using DOS and also the option of a HDD also under DOS.
    The mouse works fine when run from an earlier ASUS P5WDH Deluxe using legacy mode. But does not work under my P8z68V.
  7. That would imply a driver issue, likely with the USB driver being used. Is your mouse connected to a USB 2.0 or USB 3.0 port?
  8. Maybea misubderstnadingi n my previuos rsponse. I have used the identical software set up on my previous MB P5WDH and the USB mouse works fine under that MB. It does not work under the P8z68 on any of the USB ports.
  9. Are the USB chipset drivers identical between the 2 motherboards? Still, this sounds like a driver issue.
  10. i've had this same problem with my razer abyssus mouse/keyboard, it only worked after connecting mouse + keyboard to a USB 3.0 i've tested everything nothing worked, with an old mouse it was working perfectly, but with razer combo nothing was working, it started to work only when inserted at 3.0 usb, why? no idea.

    i have the same MOBO than you, so it can be the same problem try the usb 3.0 ports, if it does not work try an older mouse, i just plugged in the 3.0 and never had problems with that again.
  11. rglester, are all of your USB ports enabled in your BIOS? ricardois made a good observation.
  12. COLGeek said:
    Are the USB chipset drivers identical between the 2 motherboards? Still, this sounds like a driver issue.


    When you say driver issue I assume you mean something other than a DOS mouse driver. I've tried about 8 dos mouse drivers and none of them worked.
  13. COLGeek said:
    rglester, are all of your USB ports enabled in your BIOS? ricardois made a good observation.


    All USB ports working and all ports tried at boot up.
  14. What mouse (brand/model) are you using when you boot from the USB drive?
  15. ricardois said:
    i've had this same problem with my razer abyssus mouse/keyboard, it only worked after connecting mouse + keyboard to a USB 3.0 i've tested everything nothing worked, with an old mouse it was working perfectly, but with razer combo nothing was working, it started to work only when inserted at 3.0 usb, why? no idea.

    i have the same MOBO than you, so it can be the same problem try the usb 3.0 ports, if it does not work try an older mouse, i just plugged in the 3.0 and never had problems with that again.


    Can you reconfim that your mB is an ASUS P8z68- v, and not another of the variants please
  16. Best answer
    rglester said:
    Can you reconfim that your mB is an ASUS P8z68- v, and not another of the variants please


    i am sure it is, ASUS p8z68-V , it is not PRO and not LE not LX, just -V...

    i didn't updated bios or anything, but i also am not using MSDOS. i was with mouse/keyboard problems at the initialization screen and for formatting windows. so i just was checking if you have tried the USB 3.0 ports and/or another mouse those cheap ones...

    after i plugged it on usb 3.0 doors no more problems were showed.

    i would sugest installing windows 7/8 maybe this is a related windows XP problem.
  17. Thank you all for yourr responses.

    It would appear that none has replied who has got an Asus P8z68 - V (not pro not LE not LX) and has also been able to get a USB mouse to work under DOS.
    (not XP not Windows 7, not Vista)

    If there is anyone who has been able to replicate or disprove my problem, please let me know. I have tried everything suggested in this thread and much more, so it looks like either a manufacturing fault or more likely a design fault.

    Regards Many Thanks.
  18. COLGeek said:
    What mouse (brand/model) are you using when you boot from the USB drive?


    Standard logitech 3 button + wheel mouse. I have tried others. See lat post. Thanks for all your help.
  19. Best answer selected by rglester.
  20. Dear Ricardois,

    My Pc and mouse work fine under windows XP. Could you do me a favour and run your pc from MSDOS and enter the edit utility. I cannot get the mouse to work under MSDOS.
Ask a new question

Read More

Asus Mice MS-DOS Motherboards