Sign in with
Sign up | Sign in
Your question

@ ATI owners: How do you force Vsync?

Last response: in Graphics & Displays
Share
February 1, 2011 12:24:08 PM

Evening all,

My friend has asked me to sort out his laptop, which has a radeon 5870M.

I haven't used an ATI based system for years, and am struggling to enable Vsync for him in certain games.

If i needed to enable Vsync in a game that did not have the option in a system with an nvidia card i would use the control panel and force enable it for that game only, but as far as i can tell you cannot do that with ATI catalyst?

Some games like crysis are choppy as hell without Vsync making them unplayable.

Coudl anyone please advise me as to how to force vsync with sertain games via the catalyst control centre, or via any other application?

Cheers

More about : ati owners force vsync

February 1, 2011 2:50:04 PM

in CCC - graphics - 3D - all - scroll down to 'Wait for vertical refresh' and and set it on the 'quality - allways on' option on far right on the slider

edit: also enable openGL tripple buffering while you're at it.. it's beneath the vsync setting
February 1, 2011 4:48:53 PM

Thanks for the reply Kari, but this doesnt seem to work. After checking on it, it seems that this has been bugged for Win 7 use for a while :( 
Related resources
Can't find your answer ? Ask !
February 1, 2011 5:00:33 PM

I've downloaded Rivatuner and have run D3DOverride form the tools folder. So far it seems to be working will.
February 1, 2011 5:42:32 PM

V-sync works as Kari mentioned, although I usually choose the option just below Quality, so it is on unless the program tells it to turn off.

One thing to note, not all games allow you to force v-sync on. There aren't a lot of games that are like this, but I've run into a couple. Risen and Divinity II are a couple examples.
February 1, 2011 6:00:41 PM

Thanks Bystander, but its currently bugged with windows 7 on ertain driver versions.
February 1, 2011 9:03:25 PM

well i'm running 10.11 and it's working for me just fine (win7 home prem 64)
February 1, 2011 9:32:55 PM

I'm not fully up to date with recent ATI versions, but his system is running the latest drivers for the 5870M and it has been confirmed that both that version and the recently releaset set (26/01/2011) do not work.

I have not tried creating a profile and activating it manualy via a hotkey as D3Doverrider is working well automatically.
February 1, 2011 10:09:49 PM

Is he playing a particular game that is having an issue? I've known games that just won't v-sync.

Or maybe this is a mobile problem only, they both work for my desktop cards.
February 3, 2011 12:23:05 PM

and some games won't vsync in windowed mode but do when in full screen...
February 3, 2011 1:07:46 PM

I hate when games don't support Vsync, it burns my eyes, like cities xl 2011 if anyone has played that, its really annoying!
!