Screen tearing during Video, not gaming

For some strange reason I get a lot of screen tearing when watching fast motion video on my pc. It doesnt happen at all when i game beacuse i have vsync on but when i watch movie files or flash video online I get a lot of tearing during fast motion.

my specs:
AMD Phenom II x4 965
ATI 5870
4GB DDR3 RAM
Win 7 x64

my refresh rate is set to 60Hz which matches my monitor but yet i still get a lot of tearing during movies. This is driving me nuts and I cant figure out a solution. Using the latest 11.1 ATI drivers. Anyone can help me ? plzzzzzzz thank you
3 answers Last reply
More about screen tearing video gaming
  1. Hey there, I was wondering if you fixed your issues. I have the same problem but I can't work it out
  2. Using Windows 7, I had the 'tearing' problem and switched from Aero to Classic themes a few times, then fiddled around with settings and almost randomly the tearing went away, never found out exactly why, then component failed and on re-install the same problem in fast-moving images in videos - cutscenes in games, streaming movies, etc ... only have the issue now with watching movies and videos from desktop or DVDs ...

    Ends up is a problem with Windows 7 synching its 'building' the images with how it renders them ... Windows 7 Aero uses VSynch, but doesn't always get the rendering in time with the monitor's refresh rate, and so some parts of successive images overlap ... sometimes small sections, sometimes across the middle of the screen ...

    'Adaptive VSynch' helps with this issue, as rendering is supposedly adapted to the monitor's refresh rate, but doesn't always work ... lessening tearing with 'Adaptive (half refresh rate)', as monitors that run at 60 are more than double the ~24 or ~29 fps of most videos ... Aero is supposed to fix this, but at times mismatched settings between video card drivers and windows can re-create the same conflict and tearing happens anyway ... forcing the VideoPlayer to use D3D Fullscreen settings can prevent this 'multiple renderers each with slightly different settings' from creating tears ...

    I use MPC-HC (Media Player Classic Home Cinema) - and VLC, as in my experience between the two there's almost nothing that can't be played successfully (I know, I know: "there is an exception to every rule, except this one") - and found that in MPC-HC going into 'Options -> Playback -> Fullscreen -> 'Use autochange fullscreen monitor mode' helped some, but not fully ... so then I tried 'Options -> Playback -> Output -> D3D Fullscreen' ... message pops up 'This option is designed to avoid tearing, but prevents displaying of context menus and dialogue box during playback. Do you reall want to activate this option?' ...

    'Yes' means mouse stays on screen but I can slide it completely out of view to the side ... no on-screen control bar, but keys still work (space = pause, etc) ... 'esc' to exit fullscreen ...

    Perfectly rendered videos again ... only the minor annoyance of the mouse and no 'time bar' ...
  3. Thanks for the info, rinscewind. This helped me solve the problem.
    I had a simillar problem with my new PC configuration, installed Windows 7 with the "Classic and High Contrast Theme" display. Moving around windows gave this choppy motion effect. MSI Afterburner didn't help me, as I don't want to mess around with clockspeeds.
    But after switching to the Windows Aero theme, everything is fine!
Ask a new question

Read More

Radeon Video Graphics