Help clocking ripjaw x memory

Ok i'm just at the point of throwing this whole computer out of the window.
I changed my mainboard, processor and memory last week and have got the cpu at a stable 4.8ghz
Im now trying to play with the memory to see how far i can get it (Other forums are saying 2000mhz). Only one problem this new bios is giving me a headache, changed all the specs to what i'm starting with but every time i start it up i'm still running at 1600.

Ok heres a full build list.

mainboard:- Asrock z68 extreme3 gen3
cpu:- 2500k @4.8ghz
memory:- gskill ripjaw x black 6-8-6-24-1N 1600
Gfx:- Msi GTX460 1gb cyclone @ 880-1760-1900
Hdd:- Samsung 256gb ssd
All liquid cooled temps at 25ish idle and 55ish under full load

http://www.gskill.com/products.php?index=352 Memory specs from gskill

http://www.xtremesystems.org/forums/showthread.php?266839-79.99-G.Skill-F3-12800CL6D-4GBXH-(2x2GB)-1.5v-DDR3-2133-CL7! Link to forum as what i'm trying to achieve.
3 answers Last reply
More about help clocking ripjaw memory
  1. Just tried setting the speeds lower than rated and it still comes up at 1600 even at 1333 and 1066.

    I'm starting to have doubts as to wether this is a memory or mainboard fault now as surely it should let me down clock them.
  2. Problem solved, Was just a wrong setting in bios. Now happily running at 5ghz, 2133 9-9-9-28 @1.5v
  3. Good man on that man
Ask a new question

Read More

G.SKILL Memory