New i7 cpu, ram issues, need help figuring out what to replace

hello recently upgraded cpu from 920 to 990x and now when trying to boot get error "recovering DRAM size" and then authomatically reboots, does this few times until getting into windows. Half time i turn on computer will get this error, other half will boot fine. Also boots fine when restarting, problems when shutting down than starting computer. When in windows noticed in system settings would say 12.0 GB (8.00GB usable). after lots of testing, figured nothing wrong with ram itself for sure. if i have 1 stick only in computer in slots 1 or 5 computer boots but in slot 3 doesnt boot, and if i have all 3 sticks ill get that 12.0 GB (8.00GB usable) in system settings. So almost sure it was motherboard, i tried replacing the 990x with older 920 and with 920 no ram issues. all ram shows in system settings and just one stick in slots 1,3,5 all boot. Swapped the 2 cpu's back and forth like 4 times, every time i put in the 990x i would get the ram issues. So the 990x is bad? should i send it back for replacement? could it be mobo?...

gigabyte ga-x58-ud4 latest bios
x3 ocz gold tripple channel 1333 4gb ram
corsair 650w power supply
win 7 64bit
10 answers Last reply
More about issues figuring replace
  1. neone?
  2. This might be of some help -
  3. Well one of the problems is with the RAM. It looks like the memory that you are using is 1.65v memory. With the Intel® Core™ i7-990X you really shouldn’t be using any memory over 1.5v. While it is possible that the memory could work without a problem it is pushing the tolerances for the memory controller. In most cases you want to be using memory that is rated at 1.5v or low if you don’t it can void your warranty and damage the processor.

    Christian Wood
    Intel Enthusiast Team
  4. yes ram is rated at 1.65 but i read many many users using 1,65 ram on 980/990x and im getting this problem with all stock settings in bios, which i believe sets the voltage at 1.5

    i cant figure if the issue is with mobo or the cpu itself, could the cpu memory controller mayb b damaged...?

  5. bump, so i just talked with gigabyte, they sent me a beta bios they said should support 990x, same issue :pfff:
    ne ideas?
  6. At this point I'd definitely go for replacement if possible. That's a very costly processor (in case bad) to take chances.
  7. alittle update, k some good news, i hope. I tried now only the 1gb's sticks, so total 3gb's in slots 1,3,5. And boots perfect every time, no errors. Looks like just when the 4gb sticks are installed gettting errors, which cant figure out y, tested each stick separately and whenever the i7 920 was installed everything worked perfect, just whenevr swapping with the 990x giving this issue, very odd have no idea y... Below are the specs of the rams, please advise what to do, thnks

    3x 4gb sticks:
    3x 1gb sticks:
  8. What settings is the RAM defaulting to? You could try loosening the timings and making sure all voltages are at default, load fail safe defaults, etc.
  9. during testing in bios everything was set to optimized defaults
Ask a new question

Read More

CPUs RAM Boot Computers Product