Sign in with
Sign up | Sign in
Your question

No internet through router via ethernet

Last response: in Networking
Share
August 2, 2010 10:14:00 AM

sorry I'm not great at explaining things, so I'll try my best

my desktop (with an ASUS m4a79xtd evo motherboard, still using the integrated realtek LAN port/card) is connected to the internet by using ethernet ports on the back of my wireless router (a netgear range max duo wireless-n router, WNDR 3300).

I, one day, decided to install OpenSUSE 11.3 Gnome 64-bit. I couldn't connect to the internet with it, I decided to boot up windows (I used GRUB to dual boot) and windows was having connection problems. It told me there was a broken or unplugged ethernet cable, but I switched the cables multiple times and there was the same problem. all of my operating systems were having problems, including ASUS Express Gate (a little mini operating system that comes with the board and activates as one of the first things on startup). I installed ubuntu (and I was angry at openSUSE and uninstalled it, its version of grub was blocking my partitions containing ubuntu derivatives) and was still having connection problems (although, read on and you'll see why I'm dismissing ubuntu's connection problems, I think that may just be it's problem with my realtek chip and not the overall connection problem). My router isn't even showing that my desktop is plugged into it, when my desktop is physically plugged into the router. Now I made sure that the router just wasn't having a connection by keeping it plugged into the modem and trying to access the internet with a laptop. The laptop was able to access the internet

I have tried reloading the BIOS, loading in different versions of the BIOS, trying to configure some settings, even running a cable checker utility found in the BIOS. I called my ISP for help, ran a few device utilities in windows, nothing. it seems like a hardware error. I am going to try ONE more thing when the computer store opens. I'm going to see if I can get a cheap network card and see if there's any difference

I did multiple things, and a few things I found out where that all of my partitions (which would be windows 7 professional 64-bit, Openartist 4th incarnation 32-bit (an ubuntu derivative running on the generic-PAE kernel) and linux mint 9 isadora gnome 64bit, and the ASUS express gate I explained earlier) except ubuntu lucid lynx (which was a fresh install) could connect to the internet. now I plugged the router back in and plugged the desktop back into the router and the only thing that could connect to the internet was ASUS express gate (which is odd because even then the router was displaying no connections on the ethernet ports).

now I also tried plugging the laptop into the ethernet port on the router. what was odd was that I had to get the cable in a certain position on port #3 and it worked fine in port #4 (the indicator was showing up on the router) yet I did the same thing with the desktop and nothing happened, same position, same thing, same ethernet cable, nothing except asus express gate got a connection.

I honestly have no idea how this could be happening, or how installing a linux operating system could've killed my connection like this. it would make sense if it were BIOS, but I reset the BIOS to default settings, I even loaded updates and regressions of the BIOS.

that's all the information I remember right now, and I'm going to try and get more (probably later today when I run by and get the network card)
August 2, 2010 10:20:30 AM

is there any possibilty you have overclocked? raising certain frequencies can casue your network card to bascially disapear... like not in device manager or anything
m
0
l
August 2, 2010 11:24:08 AM

thanks for the quick reply axxeon

well, it's possible, but my card DOES appear in the device manager and in dmesg (a linux command)

I haven't overclocked, but a few days back, I tried a utility that came with my motherboard to automatically overclock, but it didn't do anything (I made sure it wasn't overclocked) except crash my system. now I've restarted a few times and haven't had anything bad happen, so I don't think that had anything to do with it (just stated the possibility) but also, when this started happening (I think, I could have it mixed up) when I started my desktop it said there was an overclocking failure and asked me to change some BIOS settings. I had not overclocked and I made sure the BIOS had not set an overclock (it was all default as far as CPU settings were concerned, it's an AMD Phenom II x4 955 black edition)

I think, not sure, but I think that BIOS error message happened after I installed openSUSE and restarted the computer

is it possible for the installation to have messed with my BIOS causing the card to work at a different frequency that's not detectable by my router but is detectable by most everything else. also, making sure it's irreversable even after resetting the BIOS and reloading different BIOS versions?

EDIT: there's also that I'm using the desktop right now (it's plugged directly into the router on windows 7, as stated earlier it works when plugged directly into the modem, but not when it's running through the ports on the router)
m
0
l
August 3, 2010 8:23:45 AM

I have no idea what I did or how it happened, but my problem has inexplicably been fixed. My BIOS showed yet another overclocking error and after that it was fine

thanks anyways
m
0
l
Related resources
!