Sign in with
Sign up | Sign in
Your question

Hard drive order keeps changing

Last response: in Motherboards
Share
March 23, 2012 1:25:10 PM

I have 1 IDE and 3 SATA hard drives (and 1 SATA DVD). When I shut down my computer the hard drive order changes in the BIOS so that the IDE HDD is placed first. How can I prevent that?
a b V Motherboard
March 23, 2012 1:30:12 PM

and if you go back to BIOS ..... is the order reset again... if so try change the Battery.. looks like it actually didn't save to the BIOS... or see any update BIOS for this board
March 23, 2012 8:20:16 PM

The order is only reset when I shut down the computer completely, not when I reboot it. If it was a battery problem, wouldn't I have the wrong time in Windows? Also, I updated my BIOS a few months ago, so I doubt there's a new version out fixing that problem...
Related resources
a b V Motherboard
March 29, 2012 2:48:32 AM

Are you running multiple operating systems? LIke one on the sata and one on the ide drive? If so then while you have one of the windows running go to - Start, Run, - type in "msconfig" and click on the boot tab." Look to see which operating system is set to boot first, change the order if necessary. Or you can delete one from the boot menu then only the one left will start.
Otherwise your saying that when you go into bios, you are actually changing the order of the drives? Not just hitting the F12 key to boot from a particular drive? Then doing the save and exit? When you reboot and go back into bios it remains in the order you put them? Stays that way no matter how many times you reboot and start windows? Then, when you shut down for any length of time it reverts back to the old way? Which drive does it keep returning to? The sata or the ide? Check, while in bios, can you remove/disable all boot devices except the one you want to boot from most of the time. Then, if/when you want to boot from a different drive you can go to the F12 and select the other one on those rare occasions when you want to boot to the other drive. Sorry for the stupid questions, just trying to wrap my head around it.
March 29, 2012 2:52:10 PM

I'm using EasyBCD on one SATA drive to boot Win7 from that SATA drive or WinXP from the IDE drive, so I only have Win7 in the msconfig - boot tab and I don't need to hit F12 at the start. (I forgot you could do that...)

The default drive randomly keeps returning to IDE (and booting to WinXP instead of the boot manager (which has Win7 by default)).
Removing all the drives in the BIOS except the boot SATA one doesn't fix this problem.

I have a theory : maybe the problem comes from the 3 TB storage SATA hard drive : I noticed that sometimes the BIOS doesn't detect it (because it's too big?). So it thinks that the system configuration has changed and restores the default hard drive order, placing the IDE drive first again...

I think I'm just going to add a boot manager to the IDE drive too...
a b V Motherboard
March 29, 2012 4:41:15 PM

"I have a theory : maybe the problem comes from the 3 TB storage SATA hard drive : I noticed that sometimes the BIOS doesn't detect it (because it's too big?). So it thinks that the system configuration has changed and restores the default hard drive order, placing the IDE drive first again... " Easy way to check this - just unplug it and do the shutdown procedure that causes the problem and see if it persists, a couple of times to be sure it is or isn't the trouble. As for the other, isn't there a setting in bios specifically for the combination sata/ide ports? Something like -
Enhanced mode / PATA if you have an IDE device you'd like to support
Compatible mode if you have an IDE device and enhanced mode doesn't work with your OS
Enhanced mode with SATA if you have SATA devices that your OS can't find (plain SATA if you have no IDE devices attached, SATA+PATA if you have SATA and IDE)
Disabled if you have no IDE devices and SATA devices work properly in AHCI mode
Try some of those settings and see if it fixes things.
Do you have a secondary device on the ide? If so, probably a dvd/cd burner, try setting that one to master and the hdd to slave. Maybe it will take it out of the loop. You can always use the F12 whenever you want the XP to boot.
!