6950 Crossfire SLOW FPS

Hi Guys,

I'm running out of ideas.. I'm getting really low FPS in games but speed are good if I enable only 1 card.

I tested both card 1 by 1 for about 10 days each to make sure everything was fine.

3D Marks 11 Score with default settings:
P 7431 (Crossfire)
P 4618 (1 card)

Everything seem fine in 3dmarks.. lower then I expected but at least i know the crossfire work.

I tried latest Ati drivers 11.1 (with 11.1a hotfix & profile 10.12cap2 )
I tried earlier version 10.11 with hotfix & old profile ..
Crossfire is enabled in CCC.
Update my BIOS to the latest version.

Tried 3 different bridge for the crossfire.

I cleaned the drivers, reinstalled, tried a new Windows 7 install on a different HD & on a VHD.

Crossfire enabled in CCC.

Same results.

Crossfire All resolution at 1920x1080:

Dirt 2 - 60 fps average in the benchmark everything maxed
Mafia2 - 63 fps average in the benchmark everything maxed NO physx
Bad Company2 - 80~90 fps everything maxed
COD Black Ops - 70~90 fps everything maxed

1 card at 1920x1080:

Dirt 2 - 70 fps average in the benchmark everything maxed out
Mafia 2 - 56 fps in the benchmark everything maxed NO physx
Bad Company2 - 80~100 fps everything maxed
Cod Black Ops - 70~110fps everything maxed


My Spec:
MSI P55-GD55 (16x,4x bus lanes)
XFX 6950 2gb x2
i7 860 Intel
Antec Truepower 750W
G.Skill F3-12800 9-9-9-24 2x2gb
2x WD 500gig Black Raid 0

Everything Stock no O/C.


Something seem wrong.. but i have no idea what it is.. Unless it's the 4x lane on the second pci express screwing me up.. i don't have anymore ideas.

Please help.

thanks

Ben
6 answers Last reply
More about 6950 crossfire slow
  1. Getting the same thing but with 5870's and I driverswept and reverted back to 10.12. 3Dmark vantage score was 28760 on crossfire so I know it is working but in games I am maxing out at 60-70. Seems very common.

    In GPU-Z and CCC both cards are detected and all seems to be fine and I know they are working because of the benchmarking.

    BTW my MB is showing X8 2.0 for both cards.
  2. Do you have vsync enabled because that will cap your fps.
  3. Turned off Vsync in both CCC and the game (CODMW2). Frames went up to 70-90 but I am still getting very choppy game play. It only started after I did X-fire.

    Can I disable X-fire in CCC and operate on only one card just to test that it is the X-fire setup?
  4. While it sounds like vsync is on, looking at the motherboard I think that's your problem.

    You need to upgrade to the MSI P55GD65 or equivalent. Your 2nd PCIe lane is at only 4x bandwidth which is definitely a bottleneck. You want at least 8x.
  5. Any other ideas for me? I am running an Intel DP55SB which is a 1x16 2.0 or 2x8 2.0 PCI-E board

    Before anybody says it is the power supply it is not. XFX black edition 850.
  6. z06psi said:
    Any other ideas for me? I am running an Intel DP55SB which is a 1x16 2.0 or 2x8 2.0 PCI-E board

    Before anybody says it is the power supply it is not. XFX black edition 850.


    I don't know. I recommend you make a new thread instead of derailing the OPs.
Ask a new question

Read More

Graphics Cards Crossfire FPS Graphics