Sign in with
Sign up | Sign in
Your question

Display not coming on monitor

Last response: in Graphics & Displays
Share
February 9, 2011 8:40:05 AM

Display not coming on monitor after turning on CPU.When i try to run this in safe mode also its screen goes black while cpu is working fine.Is it a problem of OS?What should i do ?
plz help

More about : display coming monitor

February 9, 2011 9:11:03 AM

khuranarajat said:
Display not coming on monitor after turning on CPU.When i try to run this in safe mode also its screen goes black while cpu is working fine.Is it a problem of OS?What should i do ?
plz help



Have you recently installed any new hardware? I got a problem like this after changing the powersupply, moving around stuff can cause some damage, Remove your GPU and turn on your On-board Graphics see if you get a display then, if you do .. DO NOT Panic this does no mean your Graphics card is broken, have a look in your PCI-E slot and check for a dust Build up, also check nothing is shorting out the motherboard that could prevent the display.

Plug it back in and see how it goes, I had to try lots of things to get my Digital display back when i had no idea why this was happening, let me know how this goes I'll see what else can be though of
m
0
l
a b U Graphics card
a b à CPUs
February 9, 2011 12:37:58 PM

Remove your gpu and turn on your onboard graphics? How do you know he has onboard graphics? How do you know he has a gpu??

We need more information on your system and when this started happening.

Also if your display isn't even coming on, then how can it go black in safe mode, wasn't it black already??
m
0
l
Related resources
February 9, 2011 4:52:22 PM

No it was not black ....first it shows brand name HCL then screen goes blank nothing comes and there is no GPU, there is 1 GB Ram and 160GB hard disk ,processor dual core.i removed everything and again plugged it but situation remains same.
m
0
l
a b U Graphics card
a b à CPUs
February 9, 2011 6:11:01 PM

khuranarajat said:
No it was not black ....first it shows brand name HCL then screen goes blank nothing comes and there is no GPU, there is 1 GB Ram and 160GB hard disk ,processor dual core.i removed everything and again plugged it but situation remains same.


Ok, so you ARE getting a display, just not getting a video signal from the motherboard. I would try removing the cmos battery from the motherboard for 5 minutes, then put it back in and then see if it fixes it. I had this problem before and the motherboard was stuck in sleep mode.
m
0
l
January 28, 2012 12:34:39 PM

i am also facing the same problem.when i press f8 to go to safe mode,monitor goes off. Recently,i replaced my motherboard to asrock g31 with old processor.i think,this can be a power supply to vga connector problem.if u press f2,bios setup screen is comming or not?i am also not getting the solution.if u get,plz send me on my email.party.on9@gmail.com.thanks.
m
0
l
!