FAR CRY 2 NOT WORKING

Hello,
JUST UPGRADED FROM ATI X1950 PRO 512MB TO AN ZOTAC NVIDIA 1GB GTX460AMP. CARDS SWAPED AND DRIVERS INSTALLED. NOW MY FAR CRY 2 WILL NOT START? TRIED UNINSTALLING BOTH CARD DRIVERS AND GAME, BUT NO JOY...... HELP

WINDOWS ULTIMATE 7 64BIT, INTEL E8500 CORE2 3.2. 4BG XMS2, ASUS P5Q PRO M/B. GTX460 1GB
5 answers Last reply
More about working
  1. LOUD NOISES!!!!!!
  2. wolfram23 said:
    LOUD NOISES!!!!!!


    No noise, dvd spins down after splash screen appears, screen goes black like its about to load and then it just goes back to the desktop!
  3. Ok.

    What I recommend you do is download Driver Sweeper from Guru 3D.

    Run the uninstallers in Add/Remove Programs for all ATI and Nvidia drivers then run Driver Sweeper (for extra caution, reboot after uninstall into safe mode to do this). Remove all traces of ATI and Nvidia (NOTE: Make sure it's display and PhysX drivers, not any chipset drivers if you have those)

    Then reboot and reinstall Nvidia drivers.
  4. bikerboysja said:
    No noise, dvd spins down after splash screen appears, screen goes black like its about to load and then it just goes back to the desktop!


    lol oblivious...
  5. wolfram23 said:
    Ok.

    What I recommend you do is download Driver Sweeper from Guru 3D.

    Run the uninstallers in Add/Remove Programs for all ATI and Nvidia drivers then run Driver Sweeper (for extra caution, reboot after uninstall into safe mode to do this). Remove all traces of ATI and Nvidia (NOTE: Make sure it's display and PhysX drivers, not any chipset drivers if you have those)

    Then reboot and reinstall Nvidia drivers.



    thanks will give it ago.
Ask a new question

Read More

Nvidia Drivers Graphics