Solved

No post with radeon 5670

I recently bought a radeon 5670 because I was sick of my old GeForce 6200, and how slow it was. I had to switch my power supply to meet the minimum requirements of the card. I installed the card correctly multiple times, andcontacted HIS to get support. They haven't helped me yet, in the 48 hours it's been. For the HIS 5670 1GB I need a port for my D-SUB monitor. I know the port I have works, as I use it in my 6200. When I have the 5670 in, and power on my pc, all of the fans turn on, including the 5670's, however, the computer will not post, and there is no signal to my monitor. What could the problem be?

My pc is a Compaq SR2170NX.
I switched the default video card to an ASUS 6200.
I switched the default power supply to a POWORK PW-600.
I switched the RAM to a newer Crucial 1 GB.
That's pretty much evertyhing.
4 answers Last reply Best Answer
More about post radeon 5670
  1. If all parts are the same and if the computer works fine with the old graphics card and doesn't even post with the new one, something is wrong with the new one.

    Does your PC work with the old 6200 since you put in the new power supply?
  2. ubercake said:
    If all parts are the same and if the computer works fine with the old graphics card and doesn't even post with the new one, something is wrong with the new one.

    Does your PC work with the old 6200 since you put in the new power supply?


    Yeah, my PC is working just as good as it used to.
  3. Best answer
    Arkyance said:
    Yeah, my PC is working just as good as it used to.

    Exhange it for a new one if you still can. Hopefully you got it at a local shop (not always the best price, but for return purposes)?
  4. Best answer selected by Arkyance.
Ask a new question

Read More

Radeon Power Supplies Graphics Product