Sign in with
Sign up | Sign in
Your question
Solved

Usb ports not recognized by windows

Last response: in Components
Share
July 20, 2011 6:26:35 PM

Hello,
I am working on a gateway ML6720 laptop. Windows 7 was windows Vista. The 4 usb ports are not being recognized by windows. The drive letter is not showing when I plug in a USB Flash and it pops up by the clock with the "Windows does not recognize the devise" and when I check the devise manager it shows unknown devise with the yellow triangle. When the flash drive is unplugged I get the typical pong saying the flash drive has been removed, so I know the USB outlets are hot. I have done everything I would normally do to solve this problem and will happily provide the information is needed. I even installed Slim Drivers and updated all the system drivers. I am at a loss.
July 23, 2011 6:18:00 PM

Hi mcnutty23, Thank you for the reply. I already went to Intel and they say in all their updates and drivers, that "this update (or driver) WILL NOT FIX YOUR USB PROBLEM"
I have tried Gateway, they tell me that I should download the Chipset update, and the Bios, update, but when I go there there is no windows 7 listed, only XP & Vista. The tech says they should work for windows 7 as well. I tried it downloaded the latest Chipset and installed it, no change, same results. I then downloaded the Bios update, and when I attempt to update the Bios following their step by step instructions when I get to the install it says to open and install a numbered .exe file, but there is no .exe file listed in the downloaded and unzipped file. So here I set. I have been to at least 6 forums and get the same comments, unplug the laptop, remove the battery hold the power switch for 2 minutes, remove everything USB from the Device manager, and when I went to computer management and services, I found all the USB referenced services stopped. I right clicked them and clicked enable, and they do not change to enable. Something is wrong on the Microsoft side of this equation, and Microsoft so far has provided no solution or suggestions other than the ones I stated. If anyone has any technical information that will help me fix this problem I would appreciate it. I am helping a friend who is a disabled Vietnam vet and has no money to take the computer to a shop for their repair. Thank you for any reply to this post. I have used Toms Hardware a lot in the past for answers to my computer problems, and have had more success solving the problem here than not. Be Blessed
Related resources

Best solution

July 23, 2011 10:02:32 PM
Share

is re-installing vista an option?

or a pcmcia usb card--i know you said your friend has no money--but these are very cheap on ebay--in the uk i could pick up one for £5 or under

did the ports ever work on windows 7 ?

as the tech said most of the time vista drivers work for 7--cant see a bios update is needed if they worked in vista
July 24, 2011 2:58:46 AM

Hello again mcnumrty, Yes I was going to try that, but first I ordered a express card with 2 usb ports on it from Amazon day before yesterday and expect to have it next week. Your are right on with my thoughts. I was going to see if the 2 usb ports on the express card would work, then if they did, I was going to reformat the drive and install Vista home premium which is what was on the machine. The ports did not work on the vista installation that was on it, but I thought I would retry it. I also though about putting XP Pro on it to see if it would install usable drivers on it. I appreciate your help very much. I will keep this Post updated, and if I solve this issue with your, or anyone's help I will give the exact method that worked here. This on seems to be a very common problem. Which it would be great to solve so others can overcome this problem. Thank You to everyone who contributes to this Toms Forum.
July 24, 2011 4:25:37 PM

Sorry about the misspelling of your name. I just cant type that good MCNUMPTY
July 29, 2011 11:05:59 PM

It seem that either flashing the BIOS or the Chipset update did the trick. BUT it did not seem to take right away. I let it set for about 2 hours after that update, battery in and plugged in powered down. Then I unplugged it leaving the battery in and about 3 hours later reconnected it, booted it up and wahla, there were the USB ports. Go Figure. So I have no definitive answer to what was wrong. I did not need or try the PCIMAI USB Card bus, which came after the problem was solved. Thank you for your help.
July 30, 2011 10:54:35 AM

main thing is you got it working :D  --what actually did the trick doesnt really matter
August 10, 2011 11:27:04 PM

Best answer selected by computersfriend.
!