Sign in with
Sign up | Sign in
Your question
Closed

Dlink DWL-G650 connection problems

Last response: in Wireless Networking
Share
November 8, 2010 4:01:33 PM

I have a new router and I am having problems getting a computer to connect.

New router: DLink DIR-601 (updated firmware to 1.01)

Computer with problem: Dell Inspiron XP SP 3 with a DLink DWL-G650 PC card (driver 2.2.4.71) - this setup was working flawlessly with a DLink DI-624 router until several days ago...may it rest in peace.

I am trying to connect using WPA-PSK and have tried both TKIP/AES. No luck.

Once I got past the validation problem (unticking the IEEE 802.1x authentication box) I have not been able to make a connection. It waits for the network for quite some time then silently fails.

Here is something strange. When I go back to check the network properties (in advanced settings) some of the settings change on their own:
Network Authentication: from WPA-PSK to Open
Data Encryption: from AES to WEP

I have 2 other computers connecting without problems, 1 with an Intel Wireless 4965AGN and 1 with a DLink WDA-2320. Both using WPA2-PSK/AES. Any ideas?
November 8, 2010 4:45:35 PM

Did you "recycle" the SSID and WPA password from your previous router? If so, the DLink is likely trying to use cached data and since the MAC addresses don't match, it is confused.

If this is the case, you might find just renaming your new router's SSID to be the easiest solution. Then you can reconnect all of your systems to the "new" system with "new" security settings.

Good luck!!
Score
0
November 8, 2010 5:04:06 PM

Thanks COLGeek.

I don't think this is the problem. I have used a new SSID name and password, and I am not filtering on MAC addresses yet.
Score
0
Related resources
November 8, 2010 5:20:30 PM

Thanks for the clarification. The DWL-G650's reverting back to the default security settings isn't a surprise since it failed to connect with the provided WPA settings.

Have you tried to turn off WPA at the router and see if you can connect with no security?

Also, are you using a router generated WPA passphrase or one of your own making?
Score
0
November 8, 2010 10:40:48 PM

The computer can connect with security turned off.

I am using a passphrase that I made. It is all alpha numeric and is working on 2 other computers. I tried changing it to something else but it made no difference. Also tried copy/pasting from notepad to make sure it is correct.

Is the card somehow not dealing with WPA? It was working fine with the old router.

Very frustrating :fou: 
Score
0

Best solution

November 8, 2010 10:47:30 PM

I am pretty sure that the 650 supports WPA. Have you tried TKPIP vs. AES?
Share
November 9, 2010 12:41:32 PM

The only way I can get it to work is setting authentication in the router to WPA only and TKIP.

I was trying to get it to work on auto WPA/WPA2 and TKIP/AES. The other devices that were working were both WPA2/AES. It seems in that in this auto-select mode it fails to authenticate with WPA.

Oh well. I am stuck with WPA only.
Score
0
November 9, 2010 1:35:59 PM

Since it is an older card, I am not surprised. However, WPA with TKIP is still secure. Glad you have working now. Good luck!
Score
0
November 9, 2010 1:53:43 PM

Thanks for the help COLGeek!
Score
0
January 30, 2012 10:28:21 AM

Best answer selected by mousemonkey.
Score
0
January 30, 2012 10:28:24 AM

This topic has been closed by Mousemonkey
Score
0
!