Sign in with
Sign up | Sign in
Your question

Problems with USB 2.0 ports on x79 Rampage IV extreme

Last response: in Motherboards
Share
March 31, 2012 11:44:46 PM

I've been having problems with USB 2.0 ports on the ASUS rampage Iv extreme

the problem is when I plug my headset (Razer megalodon) into one of the USB 2.0 ports while other devices are plugged in it does not work but there is power on the headset (the lights are on)

but if I unplugged my keyboard (Logitech G15) the headset will work just fine , and If I plugged the headset before the keyboard then I plugged the keyboard the keyboard will not work but again the lights are on on the keyboard


I tried plugging the headset on USB 3.0 while the keyboard plugged in they all work

I tried updating the bios to 1005 then 1101 and currently on the latest 1202 and still the same problem
The total USB devices are 3 : logitech G9 mouse , Logitech G15 keyboard , Razer megalodon 7.1

my specs

CPU : 3930K Stock 3.2 H100
Mobo : Asus rampage extreme Bios 1202
RAM : G.skill Ripjaws z 4x4gb 16GB
GPU: 2x ATI 5850 CF
PSU : Corsair AX1200
SSD : Intel 520 240GB
HDD: WD black 1TB 64mb
Case : Coolermaster HafX
a b Ĉ ASUS
a c 125 V Motherboard
April 1, 2012 6:20:02 AM

Sound like a voltage undercurrent problem on your USB 2 hub. If there is a way to up the USB 2 voltage slightly in your BIOS, that should solve your problem, otherwise I don't see a way around it.
a b V Motherboard
April 1, 2012 7:43:55 AM

I would consider looking at the drivers for these devices as a cause, I have come across at least one other USB device they will not work while my G15 has it's drivers installed.
Plus you can eliminate voltage concerns by plugging one into the USB2 and the other into the rear or front USB3 headers (specially since the USB3 on the R4E can output upto2 or what it 3 times the normal current), if it still don't work then suspect drivers
Related resources
a b Ĉ ASUS
a b V Motherboard
April 1, 2012 9:50:38 AM

I believe this is more to do with USBv, based on your plug in order/results - especially since you can have the headset plugged into a USB3 port with the others in 2.0 ports and all play nicely.

Solutions attempts I would suggest are:
- Leave keyboard and mouse in one location. Then "musical chairs" the headset in all the other 2.0 ports until it works. I suspect the further down the I/O panel you go the more likely they will work, or if you use ports that come from mid-board.
- Just use the 3.0 port for the headset. :) 
- Buy a A/C powered USB hub and stick all your gear in there. This solution isn't ideal, but should fix the problem should no other ports work and/or you don't want to use your 3.0 port for the headset.
April 1, 2012 3:42:41 PM

thank you all for your comments , Now I need to now is it the motherboard fault because if it is I'm gonna RMA it I just bought it a week ago
a c 207 Ĉ ASUS
a c 716 V Motherboard
April 1, 2012 4:30:04 PM

Hold on. How are all of these USB devices connected? MOBO via Back I/O Ports or the Cases' USB or a combination of the two?

First, I would unplug the Cases' USB 2.0 and USB 3.0 headers and retest.
Second, I would use a PS/2 Keyboard and uninstall ALL of the USB devices, and everything listed under the tree [+] 'Universal Serial Bus Controllers' and restart. Then adding (1) device at a time: install the drivers, connect the device and if needed reboot. Slow, methodical, and correct installation.

Q - Did you install ALL of the Drivers and most importantly the Chipset INF (Intel Chipset Software Installation Utility)

Q -Did you use the drivers from the ASUS DVD or did you download the latest and NOT use the DVD?

Q - What order did you install the Drivers?
Q - Are there any {? or !} listed in the Device Manager?

Run Intel Driver Update Utility -> http://downloadcenter.intel.com/default.aspx?lang=eng

Also, 9/10 you didn't install Windows 7 correctly. Unless you used the Custom and Load Driver chances are you are using the much older Windows AHCI driver verses the correct Intel RST Enterprise driver. A good test, in the BIOS change SATA -> RAID and reboot if you BSOD then you didn't install the OS correctly; see -> http://www.tomshardware.com/forum/303873-30-wont-resume... I'd say 90% of the folks are doing it wrong.
April 1, 2012 8:52:11 PM

jaquith dude you are totally right I tried changing from AHCI to RAID and I got BSOD right away but I couldn't see the code of the BSOD

Now What should I do ? and How do I install Windows 7 correctly ? Im sorry I'm new to these kind of problems

and Does that mean that the Motherboard is OK or defective ?
a c 207 Ĉ ASUS
a c 716 V Motherboard
April 2, 2012 12:08:35 AM

Well I wish I could sugar coat it. Once I accidentally forgot to 'F6' aka Load Drivers and I wasted a boat load of time, The solution (Fix) is to delete that partitions, reformat and start from scratch. The link I placed above in the last paragraph is a how to fix the f'up and start from scratch. Use the Custom Install option.

The end result is less oddball issues e.g. shutdown, sleep, and an assortment of unexplained behavior.

Now I don't know if correctly installing the OS will solve your USB issues or not or even if the USB is indeed a MOBO issue, but it will also keep the MBR from corrupting over time. Typically what you posted is not a bad USB controller -- if it were then it simply wouldn't work. It seems more like a driver, corruption or conflict including an IRQ, or registry issue. Keep in mind some USB devices don't like to be moved (different USB ports) at all once the diver is installed and won't work once moved -- I see this often with Keyboards and Mice -- registry corruptions.

Further, I wouldn't use any ASUS Utilities, if at all, until the PC is full tested and 24~48 burn-in with AID64; ASUS AI Suite includes ASUS USB 3.0 Boost. Also, I would avoid, unless really needed, the white USB BIOS Flashback port, in other words stick to the black USB 2.0 ports.

OS Installation:
I strongly encourage you to set the Intel SATA -> RAID; it keeps Windows from sneaking in the wrong AHCI drivers and you making a mistake. Afterwards you can set the SATA back to AHCI or visa versa, and using the latest Intel RST Enterprise divers you will as a benefit see both SSD and HDD performance increases.

Everyone who has used the 'Fix' has been happy after the pain of re-installing the OS.

Good Luck! Let me know.
April 2, 2012 1:38:24 PM

Jaquith thank you man you've been very helpful

Now I need to know what is the right driver for my X79 Asus Rampage IV
I found this
http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&...
and this http://downloadcenter.intel.com/SearchResult.aspx?lang=...

which one is the right one and the latest ? because there are a lot of them , and is this the only driver that I should load when Installing the OS ? or there are others ?

and can you give me the link for the right Driver , thank you

a c 207 Ĉ ASUS
a c 716 V Motherboard
April 2, 2012 2:00:51 PM

I don't know if the 1st is correct, but the 2nd are mostly wrong except the last on the list which has the "RSTE_3.0.0.3020_F6-Drivers.zip" that are in the 're-install post' that I originally linked.

Use RSTE_3.0.0.3020_F6-Drivers.zip

There's a huge difference between vanilla Intel RST (Z68), and RST Enterprise which the X79's use.

From your 2nd link @ bottom - http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&...

Same as what I linked - http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&...

I've been keeping an eye out and updating my post.

---

The "Intel® RSTe AHCI & SCU Software RAID driver for Windows*" may work, but I am not 100% sure...

Once you re-install the OS then go to Intel and update all of the drivers and chipset:

Run Intel Driver Update Utility -> http://downloadcenter.intel.com/default.aspx?lang=eng
a c 207 Ĉ ASUS
a c 716 V Motherboard
April 2, 2012 2:10:57 PM

Again, from both ASUS and Intel download the latest drivers (don't use the ASUS DVD), unzip and/or extract all of the drivers.

On the Flash Drive installer follow the video guide, and create (2) folders "RAID" and DRIVERS". You'll use the RAID during installation and after the install copy/paste the DRIVERS folder to the Desktop. Install the Chipset first as per the post.

Don't forget to unplug all SATA ports except the Primary SSD/HDD. Also, you MUST use only a USB 2.0 port (black); USB 3.0 is non-native and simply wont work.

Good Luck!
April 2, 2012 3:27:50 PM

I always download the latest drivers from Asus website
http://www.asus.com/Motherboards/Intel_Socket_2011/Ramp...
but isn't it strange that they didn't put RSTE_3.0.0.3020_F6-Drivers.zip in Asus drivers page?! while the Gigabyte website provide it (I also have GA-x58-UD5 in my other rig)
I thought I can find all the Important drivers in ASUS's website

so here is my order in installing the drivers

While installing the OS
1- RSTE_3.0.0.3020_F6-Drivers.zip : from Intel website

after installing the OS
From Asus Website
1- Chipset :Intel Chipset Software Installation Utility
2- SATA : Intel(R) Rapid Storage Technology enterprise Driver Software V3.0.0.2003 then Asmedia SATA Controller Driver
3- USB : Asmedia USB 3.0 Host Controller Driver
4- AUDIO :Realtek High Definition Audio Driver
5- LAN : Intel Gigabit Ethernet Driver

Is this the right order not to mention that I'm having problem in the sound , the sound cut off (the sound disappear) and comes back after 2 or 4 seconds
I think it has something to do with my order of installing the drivers or hopefully the correct clean install will solve the sound problem

Note : I didn't do anything yet (I'm still on my not correctly installed OS) I will Install the OS correctly this weekend
a c 207 Ĉ ASUS
a c 716 V Motherboard
April 2, 2012 3:58:49 PM

Strange no, ASUS and Gigabyte have different testing schedules. Worst if sales aren't high then they'll ignore updating the download pages; multiply the (MOBO(s) * Driver(s) * Language Pack(s)) and you'll understand the lackadaisical updates. The drivers are from their respective OEM (Intel, Realtek, Asmedia, etc).

Not that it'll make any difference, my order:

1- Chipset :Intel Chipset Software Installation Utility
2- LAN : Intel Gigabit Ethernet Driver
3- SATA : Intel(R) Rapid Storage Technology enterprise Driver Software V3.0.0.2003
4- Asmedia SATA Controller Driver
5- USB : Asmedia USB 3.0 Host Controller Driver
6- AUDIO :Realtek High Definition Audio Driver ; sometimes I only use Windows WHQL divers and spare myself the bloatware.

7- Run Intel Driver Update Utility -> http://downloadcenter.intel.com/default.aspx?lang=eng

--

RE: "Is this the right order not to mention that I'm having problem in the sound , the sound cut off (the sound disappear) and comes back after 2 or 4 seconds"
Q - How is the sound connected? (Case or Rear I/O aka Green 3mm)

The reason I suggested pulling (most) of the cases's headers is because I've seen shorted front panels from cases (USB, Sound, etc). As noted in (#6) above post OS install use the WHQL that 'should be' installed from the OS's drivers -- later sure add it (Realtek) if desired.
April 2, 2012 4:32:27 PM

whether I connect it to the green 3.5 mm jack in the rear I/O or my Razer USB headset or external sound card (logitech USB to 3.5 jack) still the same problem

I can't wait to install the OS correctly and after that I will see which problem will go away

and thank you again for all of your support
!