Gigabyte HD4650 AGP not playing HD videos!

Hello, i've purchased this card a few days ago and installed on a P4 2,8 MGz, 1,5GB DDR SDRAM with Win7 32-bit and no matter what i try, i can't make this card play HD videos, it even lags on full screen 360p ones.

I've applied the latest Catalyst 11.1 drivers but still nothing.I tried to update the BIOS through a small program that Gigabyte provides but the screen freezes when i run it and then the PC reboots or it remains freezed forever.

Just to say, this PC had a ATI 2600 Pro before and was playing HD videos with no problems at all.

Tested on KM Player, GOM player, VLC Player and YouTube videos.

Any suggestions? Gigabyte last reply was to test it on another system and if the problem remains, then return it back to the shop i bought it...

Thanks
9 answers Last reply
More about gigabyte hd4650 playing videos
  1. First, are you using the AGP Hotfix version of Catalyst? It can be found at the link below. Second, did you completely remove the previous drivers before you installed the 4650? If not, download and install driversweeper (below) and then install the Hotfix version. Report results back. Good luck!


    http://support.amd.com/us/kbarticles/Pages/CatalystAGPHotfix.aspx

    http://www.guru3d.com/category/driversweeper/
  2. Hello and thanks for your reply.

    Yes i've applied the 11.1 AGP Hotfix drivers and yes these drivers were applied over the Windows generic drivers after i've uninstalled the ones found on the CD that came with my card.
  3. OK, go through the driversweeper removal process and try again.

    By the way, you shouldn't need a BIOS update. However, were you trying the Windows application method or the DOS disk method? What make/model of motherboard are you using?

    Good luck!
  4. I've cleaned all previous leftovers with Driver Sweeper, installed the 11.1 Hotfix drivers but nothing changed at all.

    I want to add at this point that when i install the new drivers, desktop colors seem a bit too edgy and the contrast doesn't seem right.

    As for VGA @BIOS flashing tool, i tried the Windows application method.

    Motherboard model : Asus P4C800-E Deluxe. Power Supply Zalman 400W.

    Thanks again
  5. Are you trying to flash (update) your motherboard's OR your video card's BIOS?

    You mobo BIOS (along with utilities and instructions) can be found at:
    http://support.asus.com/download/download.aspx?SLanguage=en-us&model=P4C800-E%20Deluxe

    Also, is this the model of GPU you are using? GV-R465D2-1GI
  6. If I got the correct model (above), then the firmware (BIOS) for it can be downloaded at:

    http://us.test.giga-byte.com/Support/VGA/BIOS_DownloadFile.aspx?FileType=BIOS&FileID=14580

    However, it isn't typical to have to update GPU BIOSes/firmware. Were you directed to do this by someone?
  7. I would also suggest that you go to intel.com and make sure you have the latest chipset drivers for your mobo. Link is below:

    http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Chipsets&ProductLine=Workstation+Chipsets&ProductProduct=Intel%C2%AE+875P+Chipset
  8. Yep, thats the model of GPU i'm using. GV-R465D2-1GI / Ati Radeon HD4650 AGP GDDR2

    I was directed by Gigabyte's Tech Support after i've turned to them first for instructions on how to setup my GPU to play HD videos.

    This was the link they gave me :

    http://www.gigabyte.com/support-downloads/Utility.aspx?cg=3

    I assume that the first tool of the above link is the flashing tool (that never worked for me, PC freezes etc.) while they also gave me the link that you posted above of the new firmware.
  9. Understood. Have you tried file from the link I sent yet?
Ask a new question

Read More

Radeon Video HD Gigabyte Graphics