Sign in with
Sign up | Sign in
Your question

6970, crysis bad performance?

Last response: in Graphics & Displays
Share
February 15, 2011 3:37:26 PM

hello again. so i just upgraded my computer from a 6870 to a 6970.. and let me tell you.. it didnt make a difference. when im watching benchmarks for the card people are getting average framerate in crysis higher then my max framerate.. what gives. im playing on 1080p, max settings, no vsync, 2x aa. my catalyst is all switch to performance. im running 11.1 driver.. my card is even overclocked to 950mhz.. when i play crysis my framerate is in the 20s... what is my bottleneck.. my ram? my mobo?

Motherboard - msi 870a - g54
ram - corsair xm3 2x2 1333mhz
videa card - saphire 6970 950mhz core, 1450mhz memory, 1.22 volts
cpu - amd 1090t oc to 4ghz 1.44 volts, NB 2400 mhz
PSU - coolmaster silent pro 850 watts



i just dont get it.. why is everyones framerate double mine wile playing on the exact same settings?
February 15, 2011 7:06:50 PM

Try putting a 11.5 driver. Many people had issues with drivers.
m
0
l
a c 125 U Graphics card
February 15, 2011 8:05:23 PM

^ I think you mean 10.5...

OP: First off set Catalyst to defaults (Use Application Settings) for everything. Set AA to MSAA not SSAA. Set Catalyst AI to Advanced.

Make sure you installed the Catalyst Crossfire Profiles

And I would also maybe try 10.11 or earlier drivers but with the newest crossfire profiles.
m
0
l
Related resources
February 15, 2011 9:10:37 PM

Catalyst 11.2 just came out. Try with that driver and see what happens.
m
0
l
February 15, 2011 9:12:42 PM

@Robiss If you did mean the 10.5, then he can't because the 6970 didn't come out until December, not May.
m
0
l
February 16, 2011 12:06:43 AM

wolfram23 said:
^ I think you mean 10.5...

OP: First off set Catalyst to defaults (Use Application Settings) for everything. Set AA to MSAA not SSAA. Set Catalyst AI to Advanced.

Make sure you installed the Catalyst Crossfire Profiles

And I would also maybe try 10.11 or earlier drivers but with the newest crossfire profiles.



everything is set to the lowest spec. catalyst AI is set to performance which is the lowest setting. i dont have advanced?.... why do i need the catalyst crossfire profiles? im running a single 6970?

im downloading 11.2 now. see if that helps
m
0
l
February 16, 2011 2:07:55 AM

Quote:
It's because you have an X6 and not an I7



it makes that much of a difference lol>?
m
0
l
February 16, 2011 3:11:10 AM


It can, some games run (a lot) better on Intel architecture.

Also, Intel seems superior when using multi video card setups.
m
0
l
February 16, 2011 3:23:41 AM

I have a 955 and get better perfromace than that. Has nothing to do with x6 vs i7.
m
0
l
February 16, 2011 3:49:28 AM

Quote:
It's because you have an X6 and not an I7


lol sounds like some serious AMD hate
m
0
l
a b U Graphics card
February 16, 2011 3:52:52 AM

i just dont get it.. why is everyones framerate double mine wile playing on the exact same settings? said:
i just dont get it.. why is everyones framerate double mine wile playing on the exact same settings?


question is are you comparing with the same hardware setup?
m
0
l
February 16, 2011 5:01:38 AM

wh3resmycar said:
question is are you comparing with the same hardware setup?



no. but i figure sence i have a 1090t at 4ghz and 4 gigs of ram. with the same video card shouldnt it be somewhat close.? i updated my driver to 11.2 and it helped a bit.. but levels in crysis where its really dark and im in combat.. im getting like 19 fps lol. untill i look away then its in the 30s. its awful. i tried to flash my bios to an asus one and it made it way worse lol. so i just switch the bios from setting on to 2 to resit it back to the saphire bios. ugh. i hate this card or what ever is making it shittty lol.
m
0
l
a c 125 U Graphics card
February 16, 2011 2:10:21 PM

lindseyhunt1090 said:
no. but i figure sence i have a 1090t at 4ghz and 4 gigs of ram. with the same video card shouldnt it be somewhat close.? i updated my driver to 11.2 and it helped a bit.. but levels in crysis where its really dark and im in combat.. im getting like 19 fps lol. untill i look away then its in the 30s. its awful. i tried to flash my bios to an asus one and it made it way worse lol. so i just switch the bios from setting on to 2 to resit it back to the saphire bios. ugh. i hate this card or what ever is making it shittty lol.


My advice, run other benchmarks. Run 3DMark 11, 3DMark Vantage, RE5 demo bench, Alien Vs Predator bench, STALKER bench, Dirt 2 bench etc etc.

Crysis might just be effed. For all I know it's not updated or it's a broken pirated version... so try other (free) benchmarks and see if you can get decent results.

Also make sure you have your motherboard's BIOS updated to the right version, maybe you also need to update your chipset drivers.
m
0
l
February 16, 2011 2:45:18 PM

wolfram23 said:
My advice, run other benchmarks. Run 3DMark 11, 3DMark Vantage, RE5 demo bench, Alien Vs Predator bench, STALKER bench, Dirt 2 bench etc etc.

Crysis might just be effed. For all I know it's not updated or it's a broken pirated version... so try other (free) benchmarks and see if you can get decent results.

Also make sure you have your motherboard's BIOS updated to the right version, maybe you also need to update your chipset drivers.


ill try updating my bios and chipset.. see if that helps.. its a legit copy. and its updated. i had a pirate version of it before but when out and got it because i thought it could be the problem. pirate version vs real copy does not make a difference in performance.
m
0
l
February 16, 2011 4:36:23 PM

Try resetting your Morphological AA and Tesselation settings to default maybe?
m
0
l
a b U Graphics card
February 16, 2011 4:58:37 PM

This is a quick stab in the dark but try downloading the full DX10 installer or even better install Direct X from the Crysis DVD. I had a real problem with framrates a while ago and it turned out I had installed some other games and it had altered the DX which Crysis didn't like. I reinstalled it from the disc and it ran much better.
m
0
l
February 16, 2011 7:50:18 PM

Kkkk1 said:
This is a quick stab in the dark but try downloading the full DX10 installer or even better install Direct X from the Crysis DVD. I had a real problem with framrates a while ago and it turned out I had installed some other games and it had altered the DX which Crysis didn't like. I reinstalled it from the disc and it ran much better.


i just re installed the game. so direct x was installed right from crysis about a hour ago lol.. same thing.. when its light out and theres no action it runs in the 40s.. but dark and action... its like 15 lol.. maybe i have a bunk card lol..

you think getting a better mobo would do anything at all? i have an 870 chipset and my mobo is a msi 870a-g54. its bad lol. upgrading to a asus crosshair with a 890fx do anything at all?
m
0
l
February 17, 2011 12:35:47 AM

hmm soo.. wierd.. sence people were saying its a cpu bottle neck i decided to play with some settings in the bios.. i overclocked my cpu another 200 mhz. so 4.2 also overclocked my northbridge from 2000mhz to 2800mnz.

it made a big difference. its actually playable. framerate still peaks around 45fps but doesnt dip into the teans anymore. barly drops to 20s at all. its usually in the high 30s to 40s..

does this make sence at all lol?

im going to get a crosshair IV and overclock the *** out of my cpu and northbridge. also some faster ram so its easier to tune.. im pretty sure it is the cpu holding this card back..

so what does this mean? if i get another gpu and run crossfire 6970s its not going to be that much better? some poeple are reporting 90% gains on some games.
m
0
l
!