Boot EFI instead of BIOS

G'day all, gently please. First appearance and very much an amateur.

I recently had my gaming computer (FlightSim) upgraded with the addition of a Gigabyte GA-X79-UD5 motherboard. All has been well until I tried to replace my Primary Hard Drive. I am using Windows 7 64 bit which appears to require the computer to boot to EFI instead of the default BIOS in order to restore the image I made of the primary SSD to a new SSD. The current SSD certainly has a 100MB Healthy (EFI System Partition).

If this is correct how does this novice go about changing the boot from BIOS to EFI please?

Thanks, Mac
6 answers Last reply
More about boot bios
  1. I am not sure what you mean. the BIOS is the BIOS. it is either a standard BIOS or a UEFI BIOS. Not both. You don't switch modes back and forth. That board has 2 UEFI BIOS. there is no standard one. there's supposed to be a switch o. the back if you need to switch them, but they are both UEFI
  2. Thank you for prompt reply. This saga all started when I tried to restore a Windows 7 system image to a new SSD and got this

    Windows cannot restore a system image to a computer that has different firmware. The system image was created on a computer using EFI and this computer is using BIOS.

    So I guessed that I needed to change the computer booting to EFI. I also discovered that the primary drive from which the image was taken has a Healthy (EFI System Partition). MS Windows Answers also told me that I had a dual boot motherboard.

    Now I am stuck. Your help will be greatly appreciated.
  3. The uefi bios already support EFI HDD by default.
  4. I might be confused but first of all are you aware that using a different model motherboard requires a fresh OS install? System files always install specifically for your old motherboard and onboard hardware, which means it's natural and exactly correct that the image will not work for your new one. Basically, the image being deployed would have to be an image created using the same model motherboard you are trying to deploy it to.

    (If you know this and this does not relate to your problem I apologize.)
  5. No please do not apologize, It was my bad explanation. The image was created using all the same hardware/software including the MB. Basically I installed a new OCZ Vertex 3 (480GB) which has a higher capacity that my Intel (250GB). All I wanted to do was restore the Intel system image to the OCZ. It simply would not happen. Here are my log notes:

    Page 51 (of the Gigabyte manual states): Or if you want to install an operating system ...

    I have been unable to find the BIOS option that allows us to actually BOOT the computer in EFI. The fact is that the only time I can see the UEFI tag, after the ASUS DVD draw in the BIOS, is when I have a Win7 installation disc in the draw. The Recovery disks do not show UEFI so obviously the machine will boot to BIOS not EFI Hence the original message. I have come to the conclusion therefore that it is not possible to use a Win 7 64-bit Recovery disc from any source with this MB.

    However it gets more puzzling yet. I used the OEM and checked that the BIOS was showing the UEFI after the DVD Draw. At the Windows 7, Install or Repair option I chose repair. Selected a System Image from the Backup Drive and again got:

    The system image restore failed. Windows cannot restore and image to a computer that has different firmware. The system image was created on a computer using EFI and this computer is using Bios.


    Finally Acronis achieved the job without problem.

    Thanks and cheers, Mac
  6. So the problem was within the image restoration program? Interesting. Congrats!
Ask a new question

Read More

Gigabyte BIOS Boot Motherboards