Sign in with
Sign up | Sign in
Your question
Closed

Probs with games_Dual XFX 6970 2GB

Last response: in Graphics & Displays
Share
February 19, 2011 4:28:48 PM

I'm having some diplay problems with my new gaming rig. I have an AMD1100t on an ASUS Crosshair IV Extreme with 2 XFX 6970 2 GB. The problem that is bothering me the most is I can't play GTA IV....it will boot fine but the graphics are "locked" all the way down. It even displays a message in the graphics menu saying that my gpu's cant handle the game, also in the message is shows that I have 4GB of available resource's and that I'm only using 256MB. All the AA and detail settings are unable to be changed. Other games seem to run fine. I now I have the newest drivers installed, The PC recognizes the cards, even the blasted game recognizes them! 1 cards outta make that game wet its pants....and 2 isn't enough?

I also had a problem with Revit...small one though. The program told me that it wasn't an optimal card. I know a workstation card would be better, but this was a gaming build. The cards actually perform amazingly in 3d model space, you can pan and rotate object at high detail WITH shadows with no lag or rebuild! They render models pretty fast too! The only problem that I've had with the card/graphics is: Revit has a status bar in the bottom of the window that displays text names of objects your tool tip rolls over; the glich is that is stacks all the text on top of each other untill it is unreadable. Not a big deal I guess.......

BUT I WANT TO RUN OVER PEOPLE AND KILL HOOKERS DAG NABIT :cry:  ....I have 2 of the most advance cards of this week! Some one please sell me some magic beans that will fix this .
February 19, 2011 4:36:23 PM

lol No clue about what could be causing it but good luck, and may you be killing civilians and hookers in no time :lol: 
February 19, 2011 4:38:42 PM

Add these to the GTAIV command line.

  1. -nomemrestrict
  2. -norestrictions
  3. -percentvidmem 100
  4. -DX9 /high


I've never played this game, so I can't particularly help you. I hope this works.

As a side note, 2x2GB graphics cards does NOT equal 4GB of vRam. It's still 2GB.
Related resources
February 19, 2011 4:47:52 PM

shadow187 said:
Add these to the GTAIV command line.

  1. -nomemrestrict
  2. -norestrictions
  3. -percentvidmem 100
  4. -DX9 /high


I've never played this game, so I can't particularly help you. I hope this works.

As a side note, 2x2GB graphics cards does NOT equal 4GB of vRam. It's still 2GB.



Do you know how or where i can get to the command line?

and in the error it gives me, it does say that there is 4GB of rescources available, not arguing about something i'm not an expert in but I think it si recognizing the 2gb of each card......
February 19, 2011 4:52:34 PM

That's odd. Is it recognizing 4GB of system memory?

For the command line...if it's through Steam, go to Library, GTA IV, right-click, properties, set launch options, and then add.

If it isn't through steam (or if the above doesn't work), right-click the shortcut to GTA IV, enter the "Target" text box, and add them after the quotes.

Eg, Start In: "C:\Program Files\XXXXXX\GTAIV.exe" -nomemrestrict -norestrictions -percentvidmem 100 -DX9 /high
February 19, 2011 4:58:41 PM

shadow187 said:
That's odd. Is it recognizing 4GB of system memory?

For the command line...if it's through Steam, go to Library, GTA IV, right-click, properties, set launch options, and then add.

If it isn't through steam (or if the above doesn't work), right-click the shortcut to GTA IV, enter the "Target" text box, and add them after the quotes.

Eg, Start In: "C:\Program Files\XXXXXX\GTAIV.exe" -nomemrestrict -norestrictions -percentvidmem 100 -DX9 /high



Excellent, it is through steam, Im gonna check this out.

I have 8GB of system memory, Gskill turbulence ddr3 2000 (2x4gb)

I'll report back soon.
February 19, 2011 5:00:11 PM

Excellent, I hope it works.
February 19, 2011 5:39:21 PM

shadow187 said:
Excellent, I hope it works.


It was a good shot, but no fix. Still have the same problem.
This time noticed that the mouse cursor was acting jerky in the menu, this game is crippling evrything.
thanks anyhow :sol: 

Best solution

February 19, 2011 6:50:35 PM
Share

Read the thread linked below; it might help.
http://forums.steampowered.com/forums/showthread.php?t=...
February 19, 2011 9:46:25 PM

I have solved my own issue,
Apparently you can't run the game with the cards in crossfire.
I found a forum with that answer and its true.
I turned off the X-fire setting in the ATI catylist control and viola.
I am able to run the game and max out settings...haven't checked my fps but , hey it looks good.
But yeah.....no x-fire with GTA IV using XFX 6970's......only 1 card will work. :hello: 
February 19, 2011 9:48:48 PM

PS im gonna pick you , Shadow, as best answer cause i don't know how to select myself and I don't want the emails piling up from Tom's wanting me to select the best answer. thanks anyhow for hanging in there with some good advice.
February 19, 2011 9:49:10 PM

Best answer selected by gabe_07.
February 20, 2011 2:47:05 AM

You could have picked me. I did a good job reading it. LOL. Good job doing your homework. It's not something I would have readily thought about. You think there would have been a fix for it since this problem has been out there for so long.
February 20, 2011 8:24:28 AM

This topic has been closed by Mousemonkey
!